aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorunlsycn <unlsycn@unlsycn.com>2023-12-11 00:36:10 +0800
committerYixun Lan <dlan@gentoo.org>2023-12-11 13:42:33 +0000
commit8b21b333b47aa122742dff4252990d4f8678e99a (patch)
treeb7a5f1a40245abcc082c4d6eb4d8d191ecdc51a0
parentapp-emulation/spike: update EAPI=8 (diff)
downloadriscv-8b21b333b47aa122742dff4252990d4f8678e99a.tar.gz
riscv-8b21b333b47aa122742dff4252990d4f8678e99a.tar.bz2
riscv-8b21b333b47aa122742dff4252990d4f8678e99a.zip
app-emulation/spike: fix spike-9999
Closes: https://github.com/gentoo/riscv/pull/10 Signed-off-by: Yixun Lan <dlan@gentoo.org>
-rw-r--r--app-emulation/spike/spike-9999.ebuild25
1 files changed, 17 insertions, 8 deletions
diff --git a/app-emulation/spike/spike-9999.ebuild b/app-emulation/spike/spike-9999.ebuild
index 830475e..5743f06 100644
--- a/app-emulation/spike/spike-9999.ebuild
+++ b/app-emulation/spike/spike-9999.ebuild
@@ -1,21 +1,30 @@
-# Copyright 2021 Gentoo Authors
+# Copyright 2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="8"
-inherit autotools git-r3 multilib
+EAPI=8
DESCRIPTION="The RISC-V ISA Simulator"
-HOMEPAGE="https://github.com/riscv/riscv-isa-sim/"
-EGIT_REPO_URI="https://github.com/riscv-software-src/riscv-isa-sim"
+HOMEPAGE="https://github.com/riscv-software-src/riscv-isa-sim"
LICENSE="BSD"
SLOT="0/${PV}"
IUSE=""
-DEPEND=""
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/riscv-software-src/riscv-isa-sim.git"
+else
+ SRC_URI="https://github.com/riscv-software-src/riscv-isa-sim/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT}"
+ KEYWORDS="~amd64"
+fi
+
+DEPEND="sys-apps/dtc"
+RDEPEND="${DEPEND}"
+BDEPEND=""
src_prepare() {
default
- sed -i -e "/install_libs_dir/s:/lib:/$(get_libdir):g" Makefile.in || die
- eautoreconf
+
+ sed -i -e "/install_libs_dir/s:/lib:/$(get_libdir)/spike:g" Makefile.in || die
}