aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/docker-api/docker-api-1.34.2-r2.ebuild')
-rw-r--r--dev-ruby/docker-api/docker-api-1.34.2-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/docker-api/docker-api-1.34.2-r2.ebuild b/dev-ruby/docker-api/docker-api-1.34.2-r2.ebuild
new file mode 100644
index 0000000..5541eb8
--- /dev/null
+++ b/dev-ruby/docker-api/docker-api-1.34.2-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple REST client for the Docker Remote API"
+HOMEPAGE="https://github.com/upserve/docker-api"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+# Requires docker to be running to perform live tests
+RESTRICT="test"
+
+ruby_add_rdepend "
+ >=dev-ruby/excon-0.47.0
+ dev-ruby/multi_json
+"