summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <hans@degraaff.org>2014-03-06 07:31:46 +0100
committerHans de Graaff <hans@degraaff.org>2014-03-06 07:31:46 +0100
commite3229fb4d8ab3141d23020de9a0492539cd8453d (patch)
tree863c5f034f462934567a3174418ad8f517494f01
parentPatch set for ruby 2.0.0 p451 (diff)
downloadruby-scripts-e3229fb4d8ab3141d23020de9a0492539cd8453d.tar.gz
ruby-scripts-e3229fb4d8ab3141d23020de9a0492539cd8453d.tar.bz2
ruby-scripts-e3229fb4d8ab3141d23020de9a0492539cd8453d.zip
Add patches for ruby 2.1.1.
-rw-r--r--patchsets/patches-2.1.1/004_gfbsd7.patch37
-rw-r--r--patchsets/patches-2.1.1/005_no-undefined-ext.patch11
-rw-r--r--patchsets/patches-2.1.1/009_no-gems.patch62
-rw-r--r--patchsets/patches-2.1.1/011_readline.patch18
4 files changed, 128 insertions, 0 deletions
diff --git a/patchsets/patches-2.1.1/004_gfbsd7.patch b/patchsets/patches-2.1.1/004_gfbsd7.patch
new file mode 100644
index 0000000..450d714
--- /dev/null
+++ b/patchsets/patches-2.1.1/004_gfbsd7.patch
@@ -0,0 +1,37 @@
+--- configure.in.orig 2013-05-05 19:36:02.800254192 +0200
++++ configure.in 2013-05-05 19:37:56.573346196 +0200
+@@ -2156,7 +2156,7 @@
+ fi
+
+ AS_CASE(["$target_os"],
+-[linux* | gnu* | k*bsd*-gnu | bsdi* | kopensolaris*-gnu | nacl], [
++[linux* | gnu* | k*bsd*-gnu | bsdi* | kopensolaris*-gnu | nacl | freebsd* | dragonfly*], [
+ if test "$rb_cv_binary_elf" = no; then
+ with_dln_a_out=yes
+ else
+@@ -2249,7 +2249,7 @@
+ [bsdi3*], [ AS_CASE(["$CC"],
+ [*shlicc*], [ : ${LDSHARED='$(CC) -r'}
+ rb_cv_dlopen=yes])],
+- [linux* | gnu* | k*bsd*-gnu | netbsd* | bsdi* | kopensolaris*-gnu], [
++ [linux* | gnu* | k*bsd*-gnu | netbsd* | bsdi* | kopensolaris*-gnu | freebsd7*], [
+ : ${LDSHARED='$(CC) -shared'}
+ if test "$rb_cv_binary_elf" = yes; then
+ LDFLAGS="$LDFLAGS -Wl,-export-dynamic"
+@@ -2262,7 +2262,6 @@
+ [freebsd*|dragonfly*], [
+ : ${LDSHARED='$(CC) -shared'}
+ if test "$rb_cv_binary_elf" = yes; then
+- LDFLAGS="$LDFLAGS -rdynamic"
+ DLDFLAGS="$DLDFLAGS "'-Wl,-soname,$@'
+ else
+ test "$GCC" = yes && test "$rb_cv_prog_gnu_ld" = yes || LDSHARED='$(LD) -Bshareable'
+@@ -2638,7 +2637,7 @@
+ [sunos4*], [
+ LIBRUBY_ALIASES='lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR) lib$(RUBY_SO_NAME).so'
+ ],
+- [linux* | gnu* | k*bsd*-gnu | atheos* | kopensolaris*-gnu], [
++ [linux* | gnu* | k*bsd*-gnu | atheos* | kopensolaris*-gnu | freebsd7*], [
+ LIBRUBY_DLDFLAGS='-Wl,-soname,lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR)'" $LDFLAGS_OPTDIR"
+ LIBRUBY_ALIASES='lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR) lib$(RUBY_SO_NAME).so'
+ if test "$load_relative" = yes; then
diff --git a/patchsets/patches-2.1.1/005_no-undefined-ext.patch b/patchsets/patches-2.1.1/005_no-undefined-ext.patch
new file mode 100644
index 0000000..f279932
--- /dev/null
+++ b/patchsets/patches-2.1.1/005_no-undefined-ext.patch
@@ -0,0 +1,11 @@
+--- ruby-1.9.3-preview1.orig/configure.in
++++ ruby-1.9.3-preview1/configure.in
+@@ -2038,7 +2038,7 @@ if test "$with_dln_a_out" != yes; then
+ [linux* | gnu* | k*bsd*-gnu | netbsd* | bsdi* | kopensolaris*-gnu], [
+ : ${LDSHARED='$(CC) -shared'}
+ if test "$rb_cv_binary_elf" = yes; then
+- LDFLAGS="$LDFLAGS -Wl,-export-dynamic"
++ LDFLAGS="$LDFLAGS -Wl,-export-dynamic -Wl,--no-undefined"
+ fi
+ rb_cv_dlopen=yes],
+ [interix*], [ : ${LDSHARED='$(CC) -shared'}
diff --git a/patchsets/patches-2.1.1/009_no-gems.patch b/patchsets/patches-2.1.1/009_no-gems.patch
new file mode 100644
index 0000000..7c61bbd
--- /dev/null
+++ b/patchsets/patches-2.1.1/009_no-gems.patch
@@ -0,0 +1,62 @@
+--- tool/rbinstall.rb.~1~ 2013-11-09 17:37:46.000000000 +0100
++++ tool/rbinstall.rb 2013-12-25 20:10:03.651964649 +0100
+@@ -711,58 +711,7 @@
+ # :startdoc:
+
+ install?(:ext, :comm, :gem) do
+- $:.unshift(File.join(srcdir, "lib"))
+- require("rubygems.rb")
+- gem_dir = Gem.default_dir
+- directories = Gem.ensure_gem_subdirectories(gem_dir, :mode => $dir_mode)
+- prepare "default gems", gem_dir, directories
+-
+- spec_dir = File.join(gem_dir, directories.grep(/^spec/)[0])
+- default_spec_dir = "#{spec_dir}/default"
+- makedirs(default_spec_dir)
+-
+- gems = {}
+- File.foreach(File.join(srcdir, "defs/default_gems")) do |line|
+- line.chomp!
+- line.sub!(/\s*#.*/, '')
+- next if line.empty?
+- words = []
+- line.scan(/\G\s*([^\[\]\s]+|\[([^\[\]]*)\])/) do
+- words << ($2 ? $2.split : $1)
+- end
+- name, base_dir, src, execs = *words
+- next unless name and base_dir and src
+-
+- src = File.join(srcdir, src)
+- base_dir = File.join(srcdir, base_dir)
+- specgen = RbInstall::Specs::Generator.new(name, base_dir, src, execs || [])
+- gems[name] ||= specgen
+- end
+-
+- Dir.glob(srcdir+"/{lib,ext}/**/*.gemspec").each do |src|
+- specgen = RbInstall::Specs::Reader.new(src)
+- gems[specgen.gemspec.name] ||= specgen
+- end
+-
+- gems.sort.each do |name, specgen|
+- gemspec = specgen.gemspec
+- base_dir = specgen.src.sub(/\A#{Regexp.escape(srcdir)}\//, "")
+- full_name = "#{gemspec.name}-#{gemspec.version}"
+-
+- puts "#{" "*30}#{gemspec.name} #{gemspec.version}"
+- gemspec_path = File.join(default_spec_dir, "#{full_name}.gemspec")
+- open_for_install(gemspec_path, $data_mode) do
+- specgen.spec_source
+- end
+-
+- unless gemspec.executables.empty? then
+- bin_dir = File.join(gem_dir, 'gems', full_name, 'bin')
+- makedirs(bin_dir)
+-
+- execs = gemspec.executables.map {|exec| File.join(srcdir, 'bin', exec)}
+- install(execs, bin_dir, :mode => $prog_mode)
+- end
+- end
++ # gems are unbundled in Gentoo.
+ end
+
+ parse_args()
diff --git a/patchsets/patches-2.1.1/011_readline.patch b/patchsets/patches-2.1.1/011_readline.patch
new file mode 100644
index 0000000..a593a50
--- /dev/null
+++ b/patchsets/patches-2.1.1/011_readline.patch
@@ -0,0 +1,18 @@
+# Upstream patch from revision 45225 for breakage introduced in readline 6.3.
+# https://bugs.gentoo.org/show_bug.cgi?id=503106
+# https://bugs.ruby-lang.org/issues/9578
+
+# This solution is later patched to also work with <readline-4.2 but
+# we don't have these versions in tree anymore.
+
+--- ext/readline/readline.c.~1~ 2013-02-01 06:37:29.000000000 +0100
++++ ext/readline/readline.c 2014-03-05 08:00:01.952968497 +0100
+@@ -1883,7 +1883,7 @@
+
+ rl_attempted_completion_function = readline_attempted_completion_function;
+ #if defined(HAVE_RL_PRE_INPUT_HOOK)
+- rl_pre_input_hook = (Function *)readline_pre_input_hook;
++ rl_pre_input_hook = (rl_hook_func_t *)readline_pre_input_hook;
+ #endif
+ #ifdef HAVE_RL_CATCH_SIGNALS
+ rl_catch_signals = 0;