aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2019-05-24 16:37:09 -0500
committerMatthias Maier <tamiko@gentoo.org>2019-05-25 01:36:05 -0500
commit3b54629b2562254c2a1bf380db6c34992216414e (patch)
treeb1f2e6979aef83db628041d89c3144f7d36c0c63 /dev-lang
parentdev-lang/icc: version bump to 19.0.4.243 (diff)
downloadsci-3b54629b2562254c2a1bf380db6c34992216414e.tar.gz
sci-3b54629b2562254c2a1bf380db6c34992216414e.tar.bz2
sci-3b54629b2562254c2a1bf380db6c34992216414e.zip
dev-lang/ifc: version bump to 19.0.4.243
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ifc/Manifest1
-rw-r--r--dev-lang/ifc/ifc-19.0.4.243.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-lang/ifc/Manifest b/dev-lang/ifc/Manifest
index ac43ecaf8..e20607e91 100644
--- a/dev-lang/ifc/Manifest
+++ b/dev-lang/ifc/Manifest
@@ -1 +1,2 @@
DIST parallel_studio_xe_2018_update2_professional_edition.tgz 3877755304 BLAKE2B c8852df23abf080f482002a37af7781b3fbae3ecec448914ea5a237fa2b925073d1a3dc2dd94ba64002ff0f6c7e9b18b25fa7ada811a83b10344eb9b92cb37ff SHA512 a9b644b0305d83a9d0daa14d146cb3ce79949db55a410afe48d62259414e6256d9ef533a04bb50807103511db2016c4abcbbf769146854a25638f402a6d0f2be
+DIST parallel_studio_xe_2019_update4_professional_edition.tgz 2629662464 BLAKE2B a5619f33535063ccd7310378504ca960aa8512527cef7e0884fae5570633c1823e50ff7135adbbc571b4d47e0b6fcc01afe8639e09feb50a7f289eeec3f61ca0 SHA512 d8f6780a3671f30a1bad5d3a9792062c73b31188dc31fbd38212e98abc593f1c8f64bb970a8a4fce9ce237afef18ed38adf8fd81aa73b63ec964224590d4a34d
diff --git a/dev-lang/ifc/ifc-19.0.4.243.ebuild b/dev-lang/ifc/ifc-19.0.4.243.ebuild
new file mode 100644
index 000000000..a45765a2f
--- /dev/null
+++ b/dev-lang/ifc/ifc-19.0.4.243.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+INTEL_DIST_PV=2019_update4_professional_edition
+
+inherit intel-sdp-r1
+
+DESCRIPTION="Intel FORTRAN Compiler"
+HOMEPAGE="http://software.intel.com/en-us/articles/intel-composer-xe/"
+
+IUSE="doc"
+KEYWORDS="-* ~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="~dev-libs/intel-common-${PV}[compiler]"
+
+CHECKREQS_DISK_BUILD=400M
+
+INTEL_DIST_DAT_RPMS=( "ifort-common-19.0.4-243-19.0.4-243.noarch.rpm" )
+INTEL_DIST_AMD64_RPMS=( "ifort-19.0.4-243-19.0.4-243.x86_64.rpm" )
+INTEL_DIST_X86_RPMS=( "ifort-32bit-19.0.4-243-19.0.4-243.x86_64.rpm" )
+
+pkg_setup() {
+ if use doc; then
+ INTEL_DIST_DAT_RPMS+=( "ifort-doc-19.0-19.0.4-243.noarch.rpm" )
+ fi
+}
+
+src_install() {
+ # already provided in dev-libs/intel-common
+ rm \
+ "${WORKDIR}"/opt/intel/compilers_and_libraries_2019.4.243/linux/compiler/include/omp_lib.f90 \
+ "${WORKDIR}"/opt/intel/compilers_and_libraries_2019.4.243/linux/compiler/include/intel64/omp_lib.mod \
+ "${WORKDIR}"/opt/intel/compilers_and_libraries_2019.4.243/linux/compiler/include/intel64/omp_lib_kinds.mod \
+ || die "rm failed"
+
+ intel-sdp-r1_src_install
+}