aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-10-19 14:18:12 +0200
committerAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-10-22 10:32:28 +0200
commit36b3b0fa3c51f82ed9bee3519ac051a94acd2f31 (patch)
tree44d0b00e6f03117f371cdd15468aac28a7b52887 /sci-physics/decaylanguage/decaylanguage-0.18.5.ebuild
parentsci-physics/mplhep-data: new package, add 0.0.4 (diff)
downloadsci-36b3b0fa3c51f82ed9bee3519ac051a94acd2f31.tar.gz
sci-36b3b0fa3c51f82ed9bee3519ac051a94acd2f31.tar.bz2
sci-36b3b0fa3c51f82ed9bee3519ac051a94acd2f31.zip
sci-physics/decaylanguage: new package, add 0.18.5
Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de>
Diffstat (limited to 'sci-physics/decaylanguage/decaylanguage-0.18.5.ebuild')
-rw-r--r--sci-physics/decaylanguage/decaylanguage-0.18.5.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-physics/decaylanguage/decaylanguage-0.18.5.ebuild b/sci-physics/decaylanguage/decaylanguage-0.18.5.ebuild
new file mode 100644
index 000000000..1dc5173ca
--- /dev/null
+++ b/sci-physics/decaylanguage/decaylanguage-0.18.5.ebuild
@@ -0,0 +1,28 @@
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..13} )
+DISTUTILS_USE_PEP517=hatchling
+inherit distutils-r1 pypi
+
+DESCRIPTION="DecayLanguage: describe, manipulate and convert particle decays"
+HOMEPAGE="https://github.com/scikit-hep/decaylanguage"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/attrs-19.2[${PYTHON_USEDEP}]
+ >=dev-python/graphviz-0.12.0[${PYTHON_USEDEP}]
+ >=dev-python/lark-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.12[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.22[${PYTHON_USEDEP}]
+ >=sci-physics/particle-0.21.0[${PYTHON_USEDEP}]
+ >=sci-physics/hepunits-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/plumbum-1.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest