aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-10-19 13:45:57 +0200
committerAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-10-22 10:32:25 +0200
commit0d0d5b2b489b01331e4239bdf9054c998cafa37a (patch)
tree9884a3cc01363c8a1f6f5a612e445fcac875f062 /sci-physics
parentsci-physics/scikit-hep-testdata: add 0.4.48 (diff)
downloadsci-0d0d5b2b489b01331e4239bdf9054c998cafa37a.tar.gz
sci-0d0d5b2b489b01331e4239bdf9054c998cafa37a.tar.bz2
sci-0d0d5b2b489b01331e4239bdf9054c998cafa37a.zip
sci-physics/pylhe: add 0.9.0
Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/pylhe/Manifest1
-rw-r--r--sci-physics/pylhe/pylhe-0.9.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/sci-physics/pylhe/Manifest b/sci-physics/pylhe/Manifest
index 11dbc6d26..cc103d71e 100644
--- a/sci-physics/pylhe/Manifest
+++ b/sci-physics/pylhe/Manifest
@@ -1,2 +1,3 @@
DIST pylhe-0.7.0.gh.tar.gz 140203 BLAKE2B 6c167b37bb6c978752de79586e4f655169b5134c6cd7637807e649323ebaca50d8a360b1ca32eeff2cc162efe5e13d7de92f72d5a9263a7b2c48a5b87b7b919c SHA512 1a338ab4e1c5dd1d8d80e4a03ad84eb59f19ebb151a4b1393b68ee6ecade920c88db6cb940d56bd1f238e833f59b266507ab678124ea49b4086fe05b7f9baa88
DIST pylhe-0.8.0.gh.tar.gz 144541 BLAKE2B 5c6a6511acd1adefad6bf3769fdb5ac2a528a8cc939bb1209d7fd4dc31eef9060d129c330b34e3cfc7b640c9b82f68f043e4604f3a535865240ceda0a33dd691 SHA512 6fc3c525cbb5f2ebe8678d1e03940fde8bdc837f1da6a667c70069584de476ea73c72e817cc84637e018ca7cf21e8bb0f7b2721fe54ef78a9b0eee7900ec400e
+DIST pylhe-0.9.0.gh.tar.gz 146969 BLAKE2B 09d1395bfb1b802e8e9bdac2aef91757a54ae4a921d90be27604846b990a2fd68341a17acf113f53347f208773e57572b13490750d47f633abf95668e190cef1 SHA512 3adebbdfee40d25dc6e17d9c058375e0741474f54afd120219c12d2b04c84536202e95af70c5dc56335c424303b51cd449fdf832af5434e3ec2ce6b14abee36b
diff --git a/sci-physics/pylhe/pylhe-0.9.0.ebuild b/sci-physics/pylhe/pylhe-0.9.0.ebuild
new file mode 100644
index 000000000..7f52fa1d9
--- /dev/null
+++ b/sci-physics/pylhe/pylhe-0.9.0.ebuild
@@ -0,0 +1,34 @@
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..13} )
+DISTUTILS_USE_PEP517=hatchling
+inherit distutils-r1 pypi
+
+DESCRIPTION="Lightweight Python interface to read Les Houches Event (LHE) files"
+HOMEPAGE="https://github.com/scikit-hep/pylhe"
+# pypi does not include tests
+SRC_URI="https://github.com/scikit-hep/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+# export is needed here!
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/graphviz-0.12.0[${PYTHON_USEDEP}]
+ >=sci-physics/particle-0.16[${PYTHON_USEDEP}]
+ >=dev-python/awkward-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/vector-0.8.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=sci-physics/scikit-hep-testdata-0.4.36[${PYTHON_USEDEP}]
+ )
+"
+PATCHES=(
+ "${FILESDIR}/${PN}"-0.7.0-coverage.patch
+)
+
+distutils_enable_tests pytest