aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-03-12 23:05:26 +0100
committerAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-03-14 13:29:46 +0100
commitf582ca64c1dff0d61b9b012515f84887cc227959 (patch)
tree9322937b843a9195cb1b77bf90e434c914f68fb4 /sci-physics
parentsci-physics/hepunits: add 2.3.3, python3_12 (diff)
downloadsci-f582ca64c1dff0d61b9b012515f84887cc227959.tar.gz
sci-f582ca64c1dff0d61b9b012515f84887cc227959.tar.bz2
sci-f582ca64c1dff0d61b9b012515f84887cc227959.zip
sci-physics/spheno: add 4.0.5
Closes: https://github.com/gentoo/sci/pull/1254 Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/spheno/Manifest3
-rw-r--r--sci-physics/spheno/files/spheno-4.0.5-gfortran.patch29
-rw-r--r--sci-physics/spheno/spheno-3.3.8-r1.ebuild (renamed from sci-physics/spheno/spheno-3.3.8.ebuild)14
-rw-r--r--sci-physics/spheno/spheno-4.0.5.ebuild39
4 files changed, 75 insertions, 10 deletions
diff --git a/sci-physics/spheno/Manifest b/sci-physics/spheno/Manifest
index afe87bb28..5db72217b 100644
--- a/sci-physics/spheno/Manifest
+++ b/sci-physics/spheno/Manifest
@@ -1 +1,2 @@
-DIST ?f=SPheno-3.3.8.tar.gz 1415645 BLAKE2B 830cdbcd8f213f0de0cd0b72455d5919e390069f097bca5a0cabdbfb77ec21549c9455139ff960a0cdbd425368805c1f2d11384c240a8e82f66e33864f4fce7b SHA512 e6c923586eae198f62121e0410f9f1f87e7badfd58d90e3b5f600e8364ea054dfb8b58c1c39d74ec6067112fa6cad727797230bce6cfc6040e2bf4c6d01b0eae
+DIST spheno-3.3.8.tar.gz 1415645 BLAKE2B 830cdbcd8f213f0de0cd0b72455d5919e390069f097bca5a0cabdbfb77ec21549c9455139ff960a0cdbd425368805c1f2d11384c240a8e82f66e33864f4fce7b SHA512 e6c923586eae198f62121e0410f9f1f87e7badfd58d90e3b5f600e8364ea054dfb8b58c1c39d74ec6067112fa6cad727797230bce6cfc6040e2bf4c6d01b0eae
+DIST spheno-4.0.5.tar.gz 1587855 BLAKE2B d3cb92740be416934a928147d980e180be623dbbfeac7a1b0b16e7e4a36d2b3088e455b5348f6e65cfa2ac8d90286c0b65a81498527419ed4eaa42622651408b SHA512 387099c3d9c9c7baf4a5da6d46b819d53dc703f72cc3a73fac7c2e63b66623e328294ac131e128253002ab03a81e96c686702ac90a58479ae573f228d3a51379
diff --git a/sci-physics/spheno/files/spheno-4.0.5-gfortran.patch b/sci-physics/spheno/files/spheno-4.0.5-gfortran.patch
new file mode 100644
index 000000000..1abf36367
--- /dev/null
+++ b/sci-physics/spheno/files/spheno-4.0.5-gfortran.patch
@@ -0,0 +1,29 @@
+--- a/src/Makefile 2023-05-04 12:33:44.804394098 +0200
++++ b/src/Makefile 2023-05-04 12:34:37.023776033 +0200
+@@ -21,9 +21,9 @@
+ #
+
+ # Intels ifort, default in optimized mode
+-F90 = ifort
+-comp = -c -O -module ${Mdir} -I${InDir}
+-LFlagsB = -O
++F90 = ${F90}
++comp = -c -O -J${Mdir} -I${InDir} ${FFLAGS} ${FCFLAGS} ${CFLAGS}
++LFlagsB = -O ${LDFLAGS}
+
+ # Intels ifort, debug modus
+ ifeq (${F90},ifortg)
+@@ -81,11 +81,11 @@
+ #
+ .f90.a:
+ ${F90} ${comp} $<
+- ar ${linker} $@ $*.o
++ $(AR) ${linker} $@ $*.o
+ rm -f $*.o
+ .F90.a:
+ ${F90} ${comp} ${PreDef} $<
+- ar ${linker} $@ $*.o
++ $(AR) ${linker} $@ $*.o
+ rm -f $*.o
+ .f90.o:
+ ${F90} ${comp} $<
diff --git a/sci-physics/spheno/spheno-3.3.8.ebuild b/sci-physics/spheno/spheno-3.3.8-r1.ebuild
index 9a740b89e..7ed53c4c7 100644
--- a/sci-physics/spheno/spheno-3.3.8.ebuild
+++ b/sci-physics/spheno/spheno-3.3.8-r1.ebuild
@@ -3,14 +3,14 @@
EAPI=8
-inherit toolchain-funcs
+inherit fortran-2
MY_PN=SPheno
MY_P=${MY_PN}-${PV}
DESCRIPTION="SPheno stands for S(upersymmetric) Pheno(menology)"
HOMEPAGE="https://spheno.hepforge.org/"
-SRC_URI="https://spheno.hepforge.org/downloads/?f=${MY_P}.tar.gz"
+SRC_URI="https://spheno.hepforge.org/downloads/?f=${MY_P}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${MY_P}"
LICENSE="all-rights-reserved"
@@ -18,16 +18,11 @@ RESTRICT="bindist mirror"
SLOT="0"
KEYWORDS="~amd64"
-DEPEND="virtual/fortran"
-RDEPEND="${DEPEND}"
-
PATCHES=( "${FILESDIR}"/${P}-gfortran.patch )
src_compile() {
# single thread force needed since fortan mods depend on each other
- export MAKEOPTS=-j1
- tc-export FC AR
- emake AR="${AR}" F90="${FC}"
+ emake -j1 F90="${FC}"
}
src_install() {
@@ -35,7 +30,8 @@ src_install() {
# convenience symlink since the package is lowercase but the default produced binary is uppercase
dosym ${MY_PN} /usr/bin/${PN}
dolib.a lib/lib${MY_PN}.a
- doheader include/*
+ mv include ${PN}
+ doheader -r ${PN}
dodoc doc/*
docinto examples
dodoc input/*
diff --git a/sci-physics/spheno/spheno-4.0.5.ebuild b/sci-physics/spheno/spheno-4.0.5.ebuild
new file mode 100644
index 000000000..7ed53c4c7
--- /dev/null
+++ b/sci-physics/spheno/spheno-4.0.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit fortran-2
+
+MY_PN=SPheno
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="SPheno stands for S(upersymmetric) Pheno(menology)"
+HOMEPAGE="https://spheno.hepforge.org/"
+SRC_URI="https://spheno.hepforge.org/downloads/?f=${MY_P}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="all-rights-reserved"
+RESTRICT="bindist mirror"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=( "${FILESDIR}"/${P}-gfortran.patch )
+
+src_compile() {
+ # single thread force needed since fortan mods depend on each other
+ emake -j1 F90="${FC}"
+}
+
+src_install() {
+ dobin bin/${MY_PN}
+ # convenience symlink since the package is lowercase but the default produced binary is uppercase
+ dosym ${MY_PN} /usr/bin/${PN}
+ dolib.a lib/lib${MY_PN}.a
+ mv include ${PN}
+ doheader -r ${PN}
+ dodoc doc/*
+ docinto examples
+ dodoc input/*
+ docompress -x /usr/share/doc/${PF}/examples
+}