aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2021-01-13 18:29:14 +0000
committerAisha Tammy <gentoo@aisha.cc>2021-01-13 18:29:14 +0000
commit29174023f61c3476581fc0ffba61d3c095a60b66 (patch)
treee1f562195b9aac4cb50fed485031d463ee0f1379 /sys-cluster
parentsci-chemistry/usf-tools: remove pack, missing deps, source is 404 (diff)
downloadsci-29174023f61c3476581fc0ffba61d3c095a60b66.tar.gz
sci-29174023f61c3476581fc0ffba61d3c095a60b66.tar.bz2
sci-29174023f61c3476581fc0ffba61d3c095a60b66.zip
sys-cluster/lmod: version bump to 8.4.20
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/lmod/Manifest1
-rw-r--r--sys-cluster/lmod/lmod-8.4.20.ebuild126
2 files changed, 127 insertions, 0 deletions
diff --git a/sys-cluster/lmod/Manifest b/sys-cluster/lmod/Manifest
index 6a0267db6..eec0ac03d 100644
--- a/sys-cluster/lmod/Manifest
+++ b/sys-cluster/lmod/Manifest
@@ -1 +1,2 @@
DIST lmod-8.4.19.tar.gz 19949543 BLAKE2B fe061e7f49d373ba684a8b4071e9353d711869a1d9d0bc55c18d7739a129939ee965f33efc57b9dea6da935f3d5d6631d2457f5e77ecbfb8a8bb3be09b70d1c5 SHA512 e284a1d733286b1aa7d876f7b49752cac36b261a4d9a25b2f4ab7d629361e3fe8aa857f2f074b8e927fbc922ee2a6e67d0548ff79a229bee5ecdc0152cb7f286
+DIST lmod-8.4.20.tar.gz 19889342 BLAKE2B aef498ec8dd2b87aca02d66f394418aba4a81d1fec4684750e59d48d06bad16db7a24290920e40290ecba8a4bc65c7dbe5c23be28654db79433f41164fa4aaf6 SHA512 9749e34e7ad75531c87770b73fd20dab16c89c24e1a2d01e58f09f8510ffc8f896dfa7eab9dab26fe4d6d14ba04d331f98e08e92e0943aede9fe5131af038970
diff --git a/sys-cluster/lmod/lmod-8.4.20.ebuild b/sys-cluster/lmod/lmod-8.4.20.ebuild
new file mode 100644
index 000000000..3d69b1e7d
--- /dev/null
+++ b/sys-cluster/lmod/lmod-8.4.20.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..3} )
+inherit autotools lua-single
+
+DESCRIPTION="Environment Module System based on Lua"
+HOMEPAGE="https://lmod.readthedocs.io/en/latest"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/TACC/Lmod"
+else
+ SRC_URI="https://github.com/TACC/Lmod/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/Lmod-${PV}
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="auto-swap cache dotfiles duplicate +extend italic module-cmd nocase redirect test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="${LUA_DEPS}
+ app-shells/tcsh
+ || (
+ app-shells/loksh
+ app-shells/mksh
+ app-shells/ksh
+ )
+ app-shells/zsh
+ dev-lang/tcl
+ dev-lang/tk
+ $(lua_gen_cond_dep '
+ >=dev-lua/luafilesystem-1.8.0[${LUA_USEDEP}]
+ dev-lua/luajson[${LUA_USEDEP}]
+ dev-lua/luaposix[${LUA_USEDEP}]
+ dev-lua/lua-term[${LUA_USEDEP}]
+ ')
+ virtual/pkgconfig
+"
+DEPEND="${RDEPEND}"
+BDEPEND="${RDEPEND}
+ test? (
+ $(lua_gen_cond_dep '
+ dev-util/hermes[${LUA_SINGLE_USEDEP}]
+ ')
+ )
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-8.4.19-no-libsandbox.patch )
+
+pkg_pretend() {
+ elog "You can control the siteName and syshost settings by"
+ elog "using the variables LMOD_SITENAME and LMOD_SYSHOST, during"
+ elog "build time, which are both set to 'Gentoo' by default."
+ elog "There are a lot of options for this package, especially"
+ elog "for run time behaviour. Remember to use the EXTRA_ECONF variable."
+ elog "To see full list of options visit:"
+ elog "\t https://lmod.readthedocs.io/en/latest/090_configuring_lmod.html"
+}
+
+src_prepare() {
+ default
+ rm -rf pkgs/{luafilesystem,term} || die
+ rm -rf rt/{colorize,end2end,help,ifur,settarg} || die
+ eautoreconf
+}
+
+src_configure() {
+ local LMOD_SITENAME="${LMOD_SITENAME:-Gentoo}"
+ local LMOD_SYSHOST="${LMOD_SYSHOST:-Gentoo}"
+
+ local LUAC="${LUA%/*}/luac${LUA#*lua}"
+
+ local myconf=(
+ --with-tcl
+ --with-fastTCLInterp
+ --with-colorize
+ --with-supportKsh
+ --without-useBuiltinPkgs
+ --with-siteControlPrefix
+ --with-siteName="${LMOD_SITENAME}"
+ --with-syshost="${LMOD_SYSHOST}"
+ --with-lua_include="$(lua_get_include_dir)"
+ --with-lua="${LUA}"
+ --with-luac="${LUAC}"
+ --with-module-root-path="${EPREFIX}/etc/modulefiles"
+ --with-updateSystemFn="${EPREFIX}/etc/modulefiles/.lmod_system_update"
+ --prefix="${EPREFIX}/usr/share/Lmod"
+ $(use_with duplicate duplicatePaths)
+ $(use_with nocase caseIndependentSorting)
+ $(use_with italic hiddenItalic)
+ $(use_with auto-swap autoSwap)
+ $(use_with module-cmd exportedModuleCmd)
+ $(use_with redirect)
+ $(use_with dotfiles useDotFiles)
+ $(use_with cache cachedLoads)
+ $(use_with extend extendedDefault)
+ )
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ default
+}
+
+src_test() {
+ local -x PATH="/opt/hermes/bin:${PATH}"
+ tm -vvv || die
+ testcleanup || die
+}
+
+src_install() {
+ default
+
+ insinto /etc/profile.d
+ newins "${ED}"/usr/share/Lmod/init/profile lmod.sh
+ newins "${ED}"/usr/share/Lmod/init/profile.fish lmod.fish
+
+ keepdir /etc/modulefiles
+}