aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-02-16 20:49:54 +0100
committerAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-02-16 20:49:54 +0100
commitff4a11344e04fd3e7b74bca15b739178e7399e35 (patch)
treecf2186ee88c25b2cff196ca1059927dceaa2da00 /sys-cluster
parentsys-cluster/easybuild-easyconfigs: add 4.9.0, 9999 (diff)
downloadsci-ff4a11344e04fd3e7b74bca15b739178e7399e35.tar.gz
sci-ff4a11344e04fd3e7b74bca15b739178e7399e35.tar.bz2
sci-ff4a11344e04fd3e7b74bca15b739178e7399e35.zip
sys-cluster/easybuild: add 4.9.0, 9999
Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/easybuild/Manifest1
-rw-r--r--sys-cluster/easybuild/easybuild-4.9.0.ebuild40
-rw-r--r--sys-cluster/easybuild/easybuild-9999.ebuild40
3 files changed, 81 insertions, 0 deletions
diff --git a/sys-cluster/easybuild/Manifest b/sys-cluster/easybuild/Manifest
index 6ae785a0e..b17222baf 100644
--- a/sys-cluster/easybuild/Manifest
+++ b/sys-cluster/easybuild/Manifest
@@ -1 +1,2 @@
DIST easybuild-4.6.2.tar.gz 10680 BLAKE2B ed9dcaf1e138dd0d56fbff51151b5e0a6c0842495a950fe6a37a16435ab679bd0f60d34a703f6791b1486001fa3508e23d8a82ae6cc39f90137f03b5a93f5a0e SHA512 34097122968d31cf7fa8503f1566ff43c4fd34849c02050eb2f7304028479afd224128a0b83c195150b9ff6680b903a6b20fee715c9511bde292e2c4ac88397b
+DIST easybuild-4.9.0.tar.gz 10622 BLAKE2B bf7c69db95d49e2d992541baa145346e173fc35eab6002afd59a62d7c2007fea41672d81a3f1cf0e170f630dcf4bbea957b254fbffd5237738180d2df0976964 SHA512 3a1a4433e58d90f90dd8ba2700f7dcc07a07333d7f103ea23f82145af76a41af436d9e606fbe95fc5cfcf4be07399a3b3d5cc10c57c0bd77ea8018ba4e852c8d
diff --git a/sys-cluster/easybuild/easybuild-4.9.0.ebuild b/sys-cluster/easybuild/easybuild-4.9.0.ebuild
new file mode 100644
index 000000000..c0f284835
--- /dev/null
+++ b/sys-cluster/easybuild/easybuild-4.9.0.ebuild
@@ -0,0 +1,40 @@
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="EasyBuild is a software build and installation framework."
+HOMEPAGE="
+ https://easybuild.io/
+ https://github.com/easybuilders/easybuild
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/easybuilders/easybuild"
+else
+ inherit pypi
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+ dev-libs/openssl
+ dev-tcltk/tclx
+ || ( >=sys-cluster/lmod-6.5.1 >=sys-cluster/modules-4.6.0-r1 )
+ ~sys-cluster/easybuild-framework-${PV}[${PYTHON_USEDEP}]
+ ~sys-cluster/easybuild-easyblocks-${PV}[${PYTHON_USEDEP}]
+ ~sys-cluster/easybuild-easyconfigs-${PV}[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}"
+
+pkg_postinst() {
+ elog "Remember to set the module install path"
+ elog "ml use \$installpath/modules/all"
+ elog "where --installpath is passed to eb"
+
+ optfeature "GitHub PR integration" dev-python/keyring dev-python/GitPython
+}
diff --git a/sys-cluster/easybuild/easybuild-9999.ebuild b/sys-cluster/easybuild/easybuild-9999.ebuild
new file mode 100644
index 000000000..c0f284835
--- /dev/null
+++ b/sys-cluster/easybuild/easybuild-9999.ebuild
@@ -0,0 +1,40 @@
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="EasyBuild is a software build and installation framework."
+HOMEPAGE="
+ https://easybuild.io/
+ https://github.com/easybuilders/easybuild
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/easybuilders/easybuild"
+else
+ inherit pypi
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+ dev-libs/openssl
+ dev-tcltk/tclx
+ || ( >=sys-cluster/lmod-6.5.1 >=sys-cluster/modules-4.6.0-r1 )
+ ~sys-cluster/easybuild-framework-${PV}[${PYTHON_USEDEP}]
+ ~sys-cluster/easybuild-easyblocks-${PV}[${PYTHON_USEDEP}]
+ ~sys-cluster/easybuild-easyconfigs-${PV}[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}"
+
+pkg_postinst() {
+ elog "Remember to set the module install path"
+ elog "ml use \$installpath/modules/all"
+ elog "where --installpath is passed to eb"
+
+ optfeature "GitHub PR integration" dev-python/keyring dev-python/GitPython
+}