aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-05 21:01:23 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-05 21:01:23 +0100
commit5a6c60e29c622924c82eb2a76609b378400b5b6d (patch)
tree60f03347187f73e5a67ddd1eb40dbba0e294ceff /x11-libs
parentsci-chemistry/openbabel-python: remove pack, py2 only (diff)
downloadsci-5a6c60e29c622924c82eb2a76609b378400b5b6d.tar.gz
sci-5a6c60e29c622924c82eb2a76609b378400b5b6d.tar.bz2
sci-5a6c60e29c622924c82eb2a76609b378400b5b6d.zip
x11-libs/xview-bin: fix fetch, fix homepage, fix install
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/xview-bin/Manifest2
-rw-r--r--x11-libs/xview-bin/xview-bin-3.2_p14211.ebuild24
-rw-r--r--x11-libs/xview-bin/xview-bin-3.2_p1428.ebuild35
3 files changed, 25 insertions, 36 deletions
diff --git a/x11-libs/xview-bin/Manifest b/x11-libs/xview-bin/Manifest
index 96a7e7dce..5a495242c 100644
--- a/x11-libs/xview-bin/Manifest
+++ b/x11-libs/xview-bin/Manifest
@@ -1 +1 @@
-DIST xviewg_3.2p1.4-28.1_i386.deb 781214 BLAKE2B 33fe4552341ae8f96ab788b6a2c7060ac55d1f55631f510d062776607eadcccaa96b6296c2d860a439f57d97f4dd3415c893dc4d763dc891a80ba33a6441ba28 SHA512 f6a5b969c74596f6b7376ce76174b0381425fd01ffd3fc13c28331e19572b978707cc392ca0c26c9c526c3e3fdb2a91e4de89c90264adafa5446960be5ee7df1
+DIST xview-3.2p1.4-21.1.fc8.i386.rpm 2156462 BLAKE2B e1900f644907c28258aecfbab59f84ac7c2f60ab5c0ccd3361c84ba5dc4c9fe837d0153abaf40f18bc924b6cecc6564920318447abe5cba6d140b0493af25910 SHA512 d29c1f6c892e9d5aae4dab5609b586e7f00ff431eaf2ec8f6317ff34bb20004ed6a87cd65ce893b7e708351c17684c426ac8d446374c106c82677bfd750136f9
diff --git a/x11-libs/xview-bin/xview-bin-3.2_p14211.ebuild b/x11-libs/xview-bin/xview-bin-3.2_p14211.ebuild
new file mode 100644
index 000000000..99f90c838
--- /dev/null
+++ b/x11-libs/xview-bin/xview-bin-3.2_p14211.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit rpm multilib
+
+RPMVER="3.2p1.4-21.1"
+
+DESCRIPTION="The X Window-System-based Visual/Integrated Environment - binary package"
+HOMEPAGE="https://archive.physionet.org/physiotools/xview/"
+SRC_URI="https://archive.physionet.org/physiotools/xview/i386-Fedora/xview-${RPMVER}.fc8.i386.rpm"
+
+LICENSE="XVIEW"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="*"
+
+src_install() {
+ dolib.so usr/*/lib/*.so.*
+}
diff --git a/x11-libs/xview-bin/xview-bin-3.2_p1428.ebuild b/x11-libs/xview-bin/xview-bin-3.2_p1428.ebuild
deleted file mode 100644
index 50ccb3804..000000000
--- a/x11-libs/xview-bin/xview-bin-3.2_p1428.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DEBVER="3.2p1.4-28.1"
-
-DESCRIPTION="The X Window-System-based Visual/Integrated Environment - binary package"
-HOMEPAGE="http://physionet.caregroup.harvard.edu/physiotools/xview/"
-SRC_URI="mirror://debian/pool/main/x/xview/xviewg_${DEBVER}_i386.deb"
-
-LICENSE="XVIEW"
-SLOT="0"
-KEYWORDS=""
-IUSE="static-libs"
-
-S=${WORKDIR}
-
-QA_PREBUILT="*"
-
-src_unpack() {
- unpack ${A}
- unpack ./data.tar.gz
-}
-
-src_install() {
- local lib_dir
- if use prefix; then
- lib_dir=lib
- else
- lib_dir=lib32
- fi
- dodir /usr/${lib_dir}/
- mv usr/lib/* "${ED}"/usr/${lib_dir}/ || die
-}