aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/cutadapt/cutadapt-4.9.ebuild')
-rw-r--r--sci-biology/cutadapt/cutadapt-4.9.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-biology/cutadapt/cutadapt-4.9.ebuild b/sci-biology/cutadapt/cutadapt-4.9.ebuild
new file mode 100644
index 000000000..cd1a8fe7c
--- /dev/null
+++ b/sci-biology/cutadapt/cutadapt-4.9.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Adapter trimming and other preprocessing of high-throughput sequencing reads"
+HOMEPAGE="https://github.com/marcelm/cutadapt/"
+SRC_URI="$(pypi_sdist_url "${PN^}" "${PV}")"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="test"
+DEPEND="
+ >=dev-python/xopen-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/dnaio-1.2.0[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+ test? ( dev-python/pytest )
+"
+distutils_enable_tests pytest