aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/agg/agg-2.5-r3.ebuild')
-rw-r--r--x11-libs/agg/agg-2.5-r3.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/x11-libs/agg/agg-2.5-r3.ebuild b/x11-libs/agg/agg-2.5-r3.ebuild
deleted file mode 100644
index e3b31660e..000000000
--- a/x11-libs/agg/agg-2.5-r3.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools
-
-DESCRIPTION="High quality rendering engine library for C++"
-HOMEPAGE="http://antigrain.com/"
-SRC_URI="http://antigrain.com/${P}.tar.gz"
-
-LICENSE="GPL-2 gpc? ( free-noncomm )"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="+gpc sdl static-libs +truetype +X"
-
-# preffer X with enabled xcb, really
-RDEPEND="
- sdl? ( >=media-libs/libsdl-1.2.0[X?] )
- X? ( >=x11-libs/libX11-1.3.99.901 )
- truetype? ( media-libs/freetype:2 )
-"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
-
-DOCS=( readme authors ChangeLog news )
-
-# patches taken from fedora
-PATCHES=(
- "${FILESDIR}"/agg-2.4-depends.patch
- "${FILESDIR}"/${P}-pkgconfig.patch
- "${FILESDIR}"/${P}-autotools.patch
- "${FILESDIR}"/${P}-sdl-m4.patch
- "${FILESDIR}"/${P}-sdl-automagic.patch
- "${FILESDIR}"/${PV}
-)
-
-src_prepare() {
- default
- mv configure.{in,ac} || die
- AT_M4DIR="." eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- --disable-ctrl
- --disable-examples
- --disable-dependency-tracking
- $(use_enable gpc)
- $(use_enable sdl)
- $(use_enable truetype freetype)
- $(use_with X x)
- )
- econf ${myeconfargs[@]}
-}