summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-04-30 15:42:07 +0000
committerJustin Lecher <jlec@gentoo.org>2011-04-30 15:42:07 +0000
commit7ef1056e89f49d16845f6a09d6687d04c069ed0a (patch)
tree045482f3c6efb739a9ae718de9e5a6899eaf3490 /media-gfx/mashup/mashup-2.9.ebuild
parentmove media-gfx/printoxx media-gfx/mashup (diff)
downloadsunrise-reviewed-7ef1056e89f49d16845f6a09d6687d04c069ed0a.tar.gz
sunrise-reviewed-7ef1056e89f49d16845f6a09d6687d04c069ed0a.tar.bz2
sunrise-reviewed-7ef1056e89f49d16845f6a09d6687d04c069ed0a.zip
Moved from printoxx to mashup, Fix deps for gnome3
svn path=/sunrise/; revision=11976
Diffstat (limited to 'media-gfx/mashup/mashup-2.9.ebuild')
-rw-r--r--media-gfx/mashup/mashup-2.9.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/media-gfx/mashup/mashup-2.9.ebuild b/media-gfx/mashup/mashup-2.9.ebuild
new file mode 100644
index 000000000..cd81bc047
--- /dev/null
+++ b/media-gfx/mashup/mashup-2.9.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Program for printing one or more image files with a user-defined page layout"
+HOMEPAGE="http://kornelix.squarespace.com/mashup"
+SRC_URI="http://kornelix.squarespace.com/storage/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/gtk+:2"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+}
+
+src_compile() {
+ # provide real PREFIX here as it is used in zfuncs.cc
+ # provide HTML-dir for DOCDIR as it used only to display the userguide
+ emake CXX="$(tc-getCXX)" PREFIX=/usr DOCDIR=/usr/share/doc/${PF}/html || die
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /usr/share/${PN}
+ doins data/*
+ doicon icons/*
+ insinto /usr/share/
+ doins -r locales/*
+
+ make_desktop_entry ${PN} "Printoxx" /usr/share/${PN}/icons/${PN}.png "Application;Graphics;2DGraphics;"
+ newman doc/${PN}.man ${PN}.1 || die
+
+ rm -rf "${D}"/tmp || die
+ dodoc doc/{CHANGES,TRANSLATIONS} || die
+ dohtml -r doc/*.html doc/images || die
+}