summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/yapgvb/yapgvb-1.1.1.ebuild')
-rw-r--r--media-gfx/yapgvb/yapgvb-1.1.1.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/media-gfx/yapgvb/yapgvb-1.1.1.ebuild b/media-gfx/yapgvb/yapgvb-1.1.1.ebuild
index 12e1a1f77..251364717 100644
--- a/media-gfx/yapgvb/yapgvb-1.1.1.ebuild
+++ b/media-gfx/yapgvb/yapgvb-1.1.1.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI=3
+
inherit distutils eutils
DESCRIPTION="Python bindings for Graphviz"
@@ -17,13 +19,11 @@ RDEPEND=">=dev-lang/python-2.4
DEPEND="${RDEPEND}
dev-libs/boost"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/boost_include_path.patch
}
src_install() {
distutils_src_install
- doenvd "${FILESDIR}"/90graphviz
+ doenvd "${FILESDIR}"/90graphviz || die
}