summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-02-25 12:19:11 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-02-25 12:19:11 +0000
commit57a22e323e1aae5255831977185f78eacbb1e26e (patch)
tree5beafa2fda1383571a05ff52192c6c03ddf9288d /net-irc
parentdev-python/pythoncad: Version bump (diff)
downloadsunrise-57a22e323e1aae5255831977185f78eacbb1e26e.tar.gz
sunrise-57a22e323e1aae5255831977185f78eacbb1e26e.tar.bz2
sunrise-57a22e323e1aae5255831977185f78eacbb1e26e.zip
Cleanup a bit
svn path=/sunrise/; revision=3086
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/bip/Manifest8
-rw-r--r--net-irc/bip/bip-0.5.3.ebuild35
2 files changed, 33 insertions, 10 deletions
diff --git a/net-irc/bip/Manifest b/net-irc/bip/Manifest
index 94e69c489..ac1506729 100644
--- a/net-irc/bip/Manifest
+++ b/net-irc/bip/Manifest
@@ -1,8 +1,8 @@
DIST bip-0.5.3.tar.bz2 130089 RMD160 d45c6ec43b73e26fb7d74abf78570bee1a13c2bf SHA1 60d4e64dafb67146dd6cfd50328f6ca3180d614b SHA256 ad58abc810c1cedd51333d4d1a2195d4c41be7077da7f9a42f66bf91d74e3a31
-EBUILD bip-0.5.3.ebuild 671 RMD160 a4be8ab31a01bbab27cdbaa68da3a63473b7f7b4 SHA1 1f5bfaa726b7197ed75fb0d10f265504f2d83e8c SHA256 15b537a28dfbbe67f944c5cfffd8152405e8d7eb0761c7af7ebd897bd803bc86
-MD5 84779c68e4815b9b91c8bf7b402108e0 bip-0.5.3.ebuild 671
-RMD160 a4be8ab31a01bbab27cdbaa68da3a63473b7f7b4 bip-0.5.3.ebuild 671
-SHA256 15b537a28dfbbe67f944c5cfffd8152405e8d7eb0761c7af7ebd897bd803bc86 bip-0.5.3.ebuild 671
+EBUILD bip-0.5.3.ebuild 1057 RMD160 49a31e5fc08184788c71c5badd4106367457c6f1 SHA1 9c8ff3262db06a00536f179cc929bd9e42fcb5ab SHA256 7048b6dbfbccaef37ec66d636dd12adf7f2d21b3a2a09f678809f7b103a74304
+MD5 c78c5aa3dc17fdc54f2545f87dbd138c bip-0.5.3.ebuild 1057
+RMD160 49a31e5fc08184788c71c5badd4106367457c6f1 bip-0.5.3.ebuild 1057
+SHA256 7048b6dbfbccaef37ec66d636dd12adf7f2d21b3a2a09f678809f7b103a74304 bip-0.5.3.ebuild 1057
MISC ChangeLog 263 RMD160 a919bbfed4181b375ce76bb9e7b05c6579ba26c7 SHA1 797c784353c3497a792e88baf311ef7c6b1ae4f1 SHA256 b44fe75605b2293e46e6940ecc145ba78e2d675fdf2a57e71b0073c373a2288e
MD5 dc7ccba014cf619d16accf1d5fe23dd3 ChangeLog 263
RMD160 a919bbfed4181b375ce76bb9e7b05c6579ba26c7 ChangeLog 263
diff --git a/net-irc/bip/bip-0.5.3.ebuild b/net-irc/bip/bip-0.5.3.ebuild
index fdbec3ae2..e966ea4bb 100644
--- a/net-irc/bip/bip-0.5.3.ebuild
+++ b/net-irc/bip/bip-0.5.3.ebuild
@@ -2,6 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit autotools
+
DESCRIPTION="Multiuser IRC proxy with ssl support"
SRC_URI="mirror://berlios/bip/${P}.tar.bz2"
HOMEPAGE="http://bip.berlios.de/"
@@ -13,19 +18,37 @@ IUSE="ssl"
DEPEND="ssl? ( dev-libs/openssl )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Respect CFLAGS
+ sed -i -e "s/CFLAGS=\"-O2 -W -Wall\"/CFLAGS=\"${CFLAGS}\"/g" \
+ configure.in || die "sed failed"
+
+ eautoreconf
+}
+
src_compile() {
local myconf=""
use ssl || myconf="--disable-ssl"
econf ${myconf} || die "econf failed"
- make || die "make failed"
+ emake || die "emake failed"
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
- rm -rf "${D}/usr/share/doc/bip/"
+ dobin src/bip src/bipmkpw || "dobin failed"
+ insinto "/usr/share/${PN}"
+ doins samples/bip.conf
+
+ dodoc AUTHORS ChangeLog README NEWS TODO
+ doman bip.1 bip.conf.1 bipmkpw.1
+}
- dodoc AUTHORS ChangeLog README IDEAS NEWS TODO
- docinto samples
- dodoc samples/*
+pkg_postinst() {
+ elog
+ elog "Copy the /usr/share/${PN}/bip.conf file to ~/.bip/bip.conf"
+ elog "and modify it according to your needs"
+ elog
}