summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-zope/relations/relations-0.6b.ebuild')
-rw-r--r--net-zope/relations/relations-0.6b.ebuild21
1 files changed, 5 insertions, 16 deletions
diff --git a/net-zope/relations/relations-0.6b.ebuild b/net-zope/relations/relations-0.6b.ebuild
index 3664c71e8..ff0fb9a63 100644
--- a/net-zope/relations/relations-0.6b.ebuild
+++ b/net-zope/relations/relations-0.6b.ebuild
@@ -2,14 +2,14 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit versionator zproduct
+inherit zproduct
-MY_PV="$(replace_version_separator 1 '-' )"
-MY_P="${PN}-${MY_PV}"
+MY_PN="Relations"
+MY_P="${MY_PN}-${PV}"
DESCRIPTION="Relations allows for component-wise control of validation, creation and lifetime of Archetypes references."
HOMEPAGE="http://plone.org/products/relations/"
-SRC_URI="http://plone.org/products/relations/releases/${PV}/${MY_P}-tar.gz"
+SRC_URI="http://plone.org/products/relations/releases/${PV}/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -17,15 +17,4 @@ KEYWORDS="~x86"
RDEPEND="net-zope/archetypes"
-ZPROD_LIST="Relations"
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- # this has to be done manually since $A is incorrect, and readonly
- # unpack function does not work either
- #
- # reviewed (grudgingly) by masterdriverz pending a mail I sent to upstream
- # requesting they fix their tarball names
- tar xzf "${DISTDIR}/${MY_P}-tar.gz" -C "${WORKDIR}" || die 'unpack failed'
-}
+ZPROD_LIST="$MY_PN"