summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-11-20 20:52:47 +0000
committerMike Frysinger <vapier@gentoo.org>2013-11-20 20:52:47 +0000
commit3163e2b94c3c70ad644a072a88994a5526fc6584 (patch)
treef1dad61622fe0780f409658ca9d3fd92302490fc /sys-devel/gdb/gdb-7.5.50.20130226.ebuild
parentupdate gdb snapshots (diff)
downloadtoolchain-3163e2b94c3c70ad644a072a88994a5526fc6584.tar.gz
toolchain-3163e2b94c3c70ad644a072a88994a5526fc6584.tar.bz2
toolchain-3163e2b94c3c70ad644a072a88994a5526fc6584.zip
gdb: update to latest combined gdb-9999 ebuild variant
Diffstat (limited to 'sys-devel/gdb/gdb-7.5.50.20130226.ebuild')
-rw-r--r--sys-devel/gdb/gdb-7.5.50.20130226.ebuild195
1 files changed, 158 insertions, 37 deletions
diff --git a/sys-devel/gdb/gdb-7.5.50.20130226.ebuild b/sys-devel/gdb/gdb-7.5.50.20130226.ebuild
index 617672c..ce86c86 100644
--- a/sys-devel/gdb/gdb-7.5.50.20130226.ebuild
+++ b/sys-devel/gdb/gdb-7.5.50.20130226.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-6.6.ebuild,v 1.1 2006/12/19 06:30:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.14 2013/09/15 12:04:52 grobian Exp $
+
+EAPI="3"
inherit flag-o-matic eutils
@@ -10,67 +12,186 @@ if [[ ${CTARGET} == ${CHOST} ]] ; then
export CTARGET=${CATEGORY/cross-}
fi
fi
+is_cross() { [[ ${CHOST} != ${CTARGET} ]] ; }
+
+RPM=
+MY_PV=${PV}
+case ${PV} in
+*.*.*.*.*.*)
+ # fedora version: gdb-6.8.50.20090302-8.fc11.src.rpm
+ inherit versionator rpm
+ gvcr() { get_version_component_range "$@"; }
+ MY_PV=$(gvcr 1-4)
+ RPM="${PN}-${MY_PV}-$(gvcr 5).fc$(gvcr 6).src.rpm"
+ SRC_URI="mirror://fedora/development/source/SRPMS/${RPM}"
+ ;;
+*.*.50.*)
+ # weekly snapshots
+ SRC_URI="ftp://sourceware.org/pub/gdb/snapshots/current/gdb-weekly-${PV}.tar.bz2"
+ ;;
+9999*)
+ # live git tree
+ EGIT_REPO_URI="git://sourceware.org/git/gdb.git"
+ inherit git-2
+ SRC_URI=""
+ ;;
+*)
+ # Normal upstream release
+ SRC_URI="mirror://gnu/gdb/${P}.tar.bz2
+ ftp://sourceware.org/pub/gdb/releases/${P}.tar.bz2"
+ ;;
+esac
+PATCH_VER=""
DESCRIPTION="GNU debugger"
-HOMEPAGE="http://sources.redhat.com/gdb/"
-SRC_URI="ftp://sources.redhat.com/pub/gdb/snapshots/current/gdb-weekly-${PV}.tar.bz2"
+HOMEPAGE="http://sourceware.org/gdb/"
+SRC_URI="${SRC_URI} ${PATCH_VER:+mirror://gentoo/${P}-patches-${PATCH_VER}.tar.xz}"
LICENSE="GPL-2 LGPL-2"
-[[ ${CTARGET} != ${CHOST} ]] \
- && SLOT="${CTARGET}" \
- || SLOT="${PV}"
-KEYWORDS=""
-IUSE="nls test"
+SLOT="0"
+if [[ ${PV} != 9999* ]] ; then
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+IUSE="+client expat multitarget nls +python +server test vanilla zlib"
-RDEPEND=">=sys-libs/ncurses-5.2-r2"
+RDEPEND="!dev-util/gdbserver
+ >=sys-libs/ncurses-5.2-r2
+ sys-libs/readline
+ expat? ( dev-libs/expat )
+ python? ( =dev-lang/python-2* )
+ zlib? ( sys-libs/zlib )"
DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/yacc
test? ( dev-util/dejagnu )
nls? ( sys-devel/gettext )"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_prepare() {
+ [[ -n ${RPM} ]] && rpm_spec_epatch "${WORKDIR}"/gdb.spec
+ use vanilla || [[ -n ${PATCH_VER} ]] && EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/patch
strip-linguas -u bfd/po opcodes/po
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ # make sure we have a python-config that matches our install,
+ # such that the python check doesn't fail just because the
+ # gdb-provided copy isn't quite what our python installed
+ # version is
+ rm -f "${S}"/gdb/python/python-config.py || die
+ pushd "${S}"/gdb/python > /dev/null || die
+ ln -s "${EROOT}"/usr/bin/$(eselect python show --python2)-config \
+ python-config.py || die
+ popd > /dev/null || die
+ fi
}
-src_compile() {
- econf \
- --program-suffix=-${PV} \
- --disable-werror \
- $(use_enable nls) \
- || die
- emake || die
+gdb_branding() {
+ printf "Gentoo ${PV} "
+ if ! use vanilla && [[ -n ${PATCH_VER} ]] ; then
+ printf "p${PATCH_VER}"
+ else
+ printf "vanilla"
+ fi
+}
+
+src_configure() {
+ strip-unsupported-flags
+
+ local sysroot="${EPREFIX}"/usr/${CTARGET}
+ local myconf=(
+ --with-pkgversion="$(gdb_branding)"
+ --with-bugurl='http://bugs.gentoo.org/'
+ --disable-werror
+ $(is_cross && echo \
+ --with-sysroot="${sysroot}" \
+ --includedir="${sysroot}/usr/include")
+ )
+
+ if use server && ! use client ; then
+ # just configure+build in the gdbserver subdir to speed things up
+ cd gdb/gdbserver
+ myconf+=( --program-transform-name='' )
+ else
+ # gdbserver only works for native targets (CHOST==CTARGET).
+ # it also doesn't support all targets, so rather than duplicate
+ # the target list (which changes between versions), use the
+ # "auto" value when things are turned on.
+ is_cross \
+ && myconf+=( --disable-gdbserver ) \
+ || myconf+=( $(use_enable server gdbserver auto) )
+ fi
+
+ if ! ( use server && ! use client ) ; then
+ # if we are configuring in the top level, then use all
+ # the additional global options
+ myconf+=(
+ --enable-64-bit-bfd
+ --disable-install-libbfd
+ --disable-install-libiberty
+ --with-system-readline
+ --with-separate-debug-dir="${EPREFIX}"/usr/lib/debug
+ $(use_with expat)
+ $(use_enable nls)
+ $(use multitarget && echo --enable-targets=all)
+ $(use_with python python "${EPREFIX}/usr/bin/python2")
+ $(use_with zlib)
+ )
+ fi
+
+ econf "${myconf[@]}"
}
src_test() {
- make check || ewarn "tests failed"
+ emake check || ewarn "tests failed"
}
src_install() {
- emake \
- DESTDIR="${D}" \
- libdir=/nukeme includedir=/nukeme \
- install || die
- rm -r "${D}"/nukeme || die
+ use server && ! use client && cd gdb/gdbserver
+ emake DESTDIR="${D}" install || die
+ use client && { find "${ED}"/usr -name libiberty.a -delete || die ; }
+ cd "${S}"
+ # Don't install docs when building a cross-gdb
if [[ ${CTARGET} != ${CHOST} ]] ; then
- # Don't install docs when building a cross-gdb
- rm -r "${D}"/usr/share
+ rm -r "${ED}"/usr/share
return 0
- else
- # Fix collisions with release gdb
- rm -r "${D}"/usr/share/{info,locale}
fi
+ # Install it by hand for now:
+ # http://sourceware.org/ml/gdb-patches/2011-12/msg00915.html
+ # Only install if it exists due to the twisted behavior (see
+ # notes in src_configure above).
+ [[ -e gdb/gdbserver/gdbreplay ]] && { dobin gdb/gdbserver/gdbreplay || die ; }
dodoc README
- docinto gdb
- dodoc gdb/CONTRIBUTE gdb/README gdb/MAINTAINERS \
- gdb/NEWS gdb/ChangeLog gdb/PROBLEMS
+ if use client ; then
+ docinto gdb
+ dodoc gdb/CONTRIBUTE gdb/README gdb/MAINTAINERS \
+ gdb/NEWS gdb/ChangeLog gdb/PROBLEMS
+ fi
docinto sim
- dodoc sim/ChangeLog sim/MAINTAINERS sim/README-HACKING
+ dodoc sim/{ChangeLog,MAINTAINERS,README-HACKING}
+ if use server ; then
+ docinto gdbserver
+ dodoc gdb/gdbserver/{ChangeLog,README}
+ fi
- dodoc "${WORKDIR}"/extra/gdbinit.sample
+ if [[ -n ${PATCH_VER} ]] ; then
+ dodoc "${WORKDIR}"/extra/gdbinit.sample
+ fi
# Remove shared info pages
- rm -f "${D}"/usr/share/info/{annotate,bfd,configure,standards}.info*
+ rm -f "${ED}"/usr/share/info/{annotate,bfd,configure,standards}.info*
+}
+
+pkg_postinst() {
+ # portage sucks and doesnt unmerge files in /etc
+ rm -vf "${EROOT}"/etc/skel/.gdbinit
+
+ if use prefix && [[ ${CHOST} == *-darwin* ]] ; then
+ ewarn "gdb is unable to get a mach task port when installed by Prefix"
+ ewarn "Portage, unprivileged. To make gdb fully functional you'll"
+ ewarn "have to perform the following steps:"
+ ewarn " % sudo chgrp procmod ${EPREFIX}/usr/bin/gdb"
+ ewarn " % sudo chmod g+s ${EPREFIX}/usr/bin/gdb"
+ fi
}