summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-03-13 09:35:43 +0000
committerMike Frysinger <vapier@gentoo.org>2014-03-13 09:35:43 +0000
commite8423d3fccd040e2d3f3b1bc5d062a170a80c651 (patch)
treeb0965ed2f1a6fd89053770e80380917b638a1729 /sys-devel/gdb/gdb-7.5.50.20130226.ebuild
parentgdb: upgrade to EAPI=4 (diff)
downloadtoolchain-e8423d3fccd040e2d3f3b1bc5d062a170a80c651.tar.gz
toolchain-e8423d3fccd040e2d3f3b1bc5d062a170a80c651.tar.bz2
toolchain-e8423d3fccd040e2d3f3b1bc5d062a170a80c651.zip
gdb: upgrade to python-single-r1
Diffstat (limited to 'sys-devel/gdb/gdb-7.5.50.20130226.ebuild')
-rw-r--r--sys-devel/gdb/gdb-7.5.50.20130226.ebuild18
1 files changed, 4 insertions, 14 deletions
diff --git a/sys-devel/gdb/gdb-7.5.50.20130226.ebuild b/sys-devel/gdb/gdb-7.5.50.20130226.ebuild
index c9c7fc0..3ef6e47 100644
--- a/sys-devel/gdb/gdb-7.5.50.20130226.ebuild
+++ b/sys-devel/gdb/gdb-7.5.50.20130226.ebuild
@@ -3,8 +3,9 @@
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.24 2014/03/09 00:04:37 vapier Exp $
EAPI="4"
+PYTHON_COMPAT=( python2_7 )
-inherit flag-o-matic eutils
+inherit flag-o-matic eutils python-single-r1
export CTARGET=${CTARGET:-${CHOST}}
if [[ ${CTARGET} == ${CHOST} ]] ; then
@@ -58,7 +59,7 @@ RDEPEND="!dev-util/gdbserver
>=sys-libs/ncurses-5.2-r2
sys-libs/readline
expat? ( dev-libs/expat )
- python? ( =dev-lang/python-2* )
+ python? ( ${PYTHON_DEPS} )
zlib? ( sys-libs/zlib )"
DEPEND="${RDEPEND}
app-arch/xz-utils
@@ -72,17 +73,6 @@ src_prepare() {
[[ -n ${RPM} ]] && rpm_spec_epatch "${WORKDIR}"/gdb.spec
use vanilla || [[ -n ${PATCH_VER} ]] && EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/patch
strip-linguas -u bfd/po opcodes/po
- if [[ ${CHOST} == *-darwin* ]] ; then
- # make sure we have a python-config that matches our install,
- # such that the python check doesn't fail just because the
- # gdb-provided copy isn't quite what our python installed
- # version is
- rm -f "${S}"/gdb/python/python-config.py || die
- pushd "${S}"/gdb/python > /dev/null || die
- ln -s "${EROOT}"/usr/bin/$(eselect python show --python2)-config \
- python-config.py || die
- popd > /dev/null || die
- fi
}
gdb_branding() {
@@ -138,7 +128,7 @@ src_configure() {
$(use_with expat)
$(use_enable nls)
$(use multitarget && echo --enable-targets=all)
- $(use_with python python "${EPREFIX}/usr/bin/python2")
+ $(use_with python python "${EPYTHON}")
$(use_with zlib)
)
fi