summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-03-13 09:36:09 +0000
committerMike Frysinger <vapier@gentoo.org>2014-03-13 09:36:09 +0000
commite239fb6549b4be327e35173fd439264ec5fbe11e (patch)
tree47c15c03ebfe408d4a0b1b695e48105fe5266211 /sys-devel/gdb/gdb-7.5.50.20130312.ebuild
parentgdb: upgrade to python-single-r1 (diff)
downloadtoolchain-e239fb6549b4be327e35173fd439264ec5fbe11e.tar.gz
toolchain-e239fb6549b4be327e35173fd439264ec5fbe11e.tar.bz2
toolchain-e239fb6549b4be327e35173fd439264ec5fbe11e.zip
gdb: clean up sysroot logic
Diffstat (limited to 'sys-devel/gdb/gdb-7.5.50.20130312.ebuild')
-rw-r--r--sys-devel/gdb/gdb-7.5.50.20130312.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/sys-devel/gdb/gdb-7.5.50.20130312.ebuild b/sys-devel/gdb/gdb-7.5.50.20130312.ebuild
index 3ef6e47..c29471b 100644
--- a/sys-devel/gdb/gdb-7.5.50.20130312.ebuild
+++ b/sys-devel/gdb/gdb-7.5.50.20130312.ebuild
@@ -87,16 +87,17 @@ gdb_branding() {
src_configure() {
strip-unsupported-flags
- local sysroot="${EPREFIX}"/usr/${CTARGET}
local myconf=(
--with-pkgversion="$(gdb_branding)"
--with-bugurl='http://bugs.gentoo.org/'
--disable-werror
# Disable modules that are in a combined binutils/gdb tree. #490566
--disable-{binutils,etc,gas,gold,gprof,ld}
- $(is_cross && echo \
- --with-sysroot="${sysroot}" \
- --includedir="${sysroot}/usr/include")
+ )
+ local sysroot="${EPREFIX}/usr/${CTARGET}"
+ is_cross && myconf+=(
+ --with-sysroot="${sysroot}"
+ --includedir="${sysroot}/usr/include"
)
if use server && ! use client ; then