summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'src/core/librccore/Makefile.am')
-rw-r--r--src/core/librccore/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/src/core/librccore/Makefile.am b/src/core/librccore/Makefile.am
new file mode 100644
index 0000000..7513965
--- /dev/null
+++ b/src/core/librccore/Makefile.am
@@ -0,0 +1,26 @@
+AUTOMAKE_OPTIONS = foreign
+
+INCLUDES = \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/include \
+ -I$(top_builddir)/include \
+ $(RCSCRIPTS_DEFINES)
+
+LIBRCUTIL = $(top_builddir)/librcutil/librcutil.la
+
+lib_LTLIBRARIES = librccore.la
+
+librccore_la_LIBADD = $(LIBRCUTIL)
+librccore_la_SOURCES = \
+ internal/rccore.h \
+ scripts.c \
+ api/scripts.h \
+ runlevels.c \
+ api/runlevels.h \
+ parse.c \
+ api/parse.h \
+ depend.c \
+ api/depend.h \
+ services.c \
+ internal/services.h \
+ init.c