summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2019-12-20 16:44:50 +0000
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2019-12-20 16:44:50 +0000
commit2de0b6a33def545ef111e316e467566f8b5cd314 (patch)
tree0a6f4eafe7b1adb8b78f1053aa66dae70e16dac2 /www-apps/glpi/glpi-9.4.5.ebuild
parentDrop unused flag from metadata.xml. (diff)
downloadjmbsvicetto-2de0b6a33def545ef111e316e467566f8b5cd314.tar.gz
jmbsvicetto-2de0b6a33def545ef111e316e467566f8b5cd314.tar.bz2
jmbsvicetto-2de0b6a33def545ef111e316e467566f8b5cd314.zip
www-apps/glpi: Add 9.4.5 release.
Signed-off-by: Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
Diffstat (limited to 'www-apps/glpi/glpi-9.4.5.ebuild')
-rw-r--r--www-apps/glpi/glpi-9.4.5.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/www-apps/glpi/glpi-9.4.5.ebuild b/www-apps/glpi/glpi-9.4.5.ebuild
new file mode 100644
index 0000000..d4d5c1a
--- /dev/null
+++ b/www-apps/glpi/glpi-9.4.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit webapp
+
+MY_PN="glpi-project"
+MY_P=${P/_/-}
+MY_PV=${PV/_/-}
+
+DESCRIPTION="The Information Resource-Manager with an additional Administration Interface."
+HOMEPAGE="http://www.glpi-project.org/"
+SRC_URI="https://github.com/${MY_PN}/${PN}/releases/download/${MY_PV}/${MY_P}.tgz"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ app-admin/webapp-config
+"
+RDEPEND="
+ dev-lang/php[curl,json,mysqli,session,unicode]
+ virtual/mysql
+"
+S="${WORKDIR}/${PN}"
+
+pkg_config () {
+
+ webapp_pkg_setup
+}
+
+src_install () {
+
+ webapp_src_preinst
+
+ einfo "Installing files"
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ # Protect config files
+ webapp_configfile -R config .htaccess
+
+ # Allow writing to the config and files directories
+ for dir in config files .htaccess ; do
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}/${dir}"
+ done
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}