summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2025-02-21 08:01:29 +0100
committerAlfredo Tupone <tupone@gentoo.org>2025-02-21 08:02:33 +0100
commit155c10424db6c7f7f437f314db6d3fcb94894d46 (patch)
tree98d79efa94bbbc57bde331a38b981fe49f9fa10f
parentdev-python/weasyprint: Bump to 64.1 (diff)
downloadgentoo-155c10424db6c7f7f437f314db6d3fcb94894d46.tar.gz
gentoo-155c10424db6c7f7f437f314db6d3fcb94894d46.tar.bz2
gentoo-155c10424db6c7f7f437f314db6d3fcb94894d46.zip
sci-libs/kineto: add 0.4.0_p20241109
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--sci-libs/kineto/Manifest1
-rw-r--r--sci-libs/kineto/kineto-0.4.0_p20241109.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/sci-libs/kineto/Manifest b/sci-libs/kineto/Manifest
index e978bd09f2a7..a331bc2e5bab 100644
--- a/sci-libs/kineto/Manifest
+++ b/sci-libs/kineto/Manifest
@@ -1,2 +1,3 @@
DIST kineto-0.4.0_p20240525.tar.gz 8243259 BLAKE2B 677529d327254c26000271a6c845356604598fb05ba57befd0e5cbd0f112f6776d2851ea1e2a7671a38ee6cb06df45db68ff0435fcddbf69496db43f5ec1e7ee SHA512 41a08c7da9eea7d12402f80a5550c9d4df79798719cc52b12a507828c8c896ba28a37c35d8adf809ca72589e1d84965d5ef6dd01f3f8dc1c803c5ed67b03a43a
DIST kineto-0.4.0_p20240807.tar.gz 8263052 BLAKE2B 79a9035939164595f30f55c6cdfdc72ab42fd93d6d8fc63dc028cae50498823916993cb2d856c4b4dc43f4107602e28e8cf70584b4aea4cacda2a700b9e856e3 SHA512 f037fac78e566c40108acf9eace55a8f67a2c5b71f298fd3cd17bf22cf05240c260fd89f017fa411656a7505ec9073a06a3048e191251d5cfc4b52c237b37d0b
+DIST kineto-0.4.0_p20241109.tar.gz 8275370 BLAKE2B 976e629eda6b967e3169e4179e021d8e6e62671d53ceadae420dc2c586445ab701a1f4b479d7e2abd8f0bd689e4679e66d57dcadc42f5e763c127fb371bb389c SHA512 e56500c3fb967d808b9aa052587a4bdeb5561bd47ab4de87cc636496867089c5b480e1c7634a0269b97262504e03ced047dc612903fa0f56a018c23adef4e686
diff --git a/sci-libs/kineto/kineto-0.4.0_p20241109.ebuild b/sci-libs/kineto/kineto-0.4.0_p20241109.ebuild
new file mode 100644
index 000000000000..c8bfaa7c2cc4
--- /dev/null
+++ b/sci-libs/kineto/kineto-0.4.0_p20241109.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2022-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+inherit python-any-r1 cmake prefix
+
+CommitId=338140f58a28d599da3434ced4fd2d75dd1a213d
+
+DESCRIPTION="part of the PyTorch Profiler"
+HOMEPAGE="https://github.com/pytorch/kineto"
+SRC_URI="https://github.com/pytorch/${PN}/archive/${CommitId}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${CommitId}/libkineto
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-libs/libfmt
+ dev-libs/dynolog
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? ( dev-cpp/gtest )
+ ${PYTHON_DEPS}
+"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.4.0-gcc13.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DLIBKINETO_THIRDPARTY_DIR="${EPREFIX}"/usr/include/
+ -DKINETO_BUILD_TESTS=OFF # tests require cuda toolkit
+ -DCUDA_SOURCE_DIR=/opt/cuda
+ -DLIBKINETO_NOXPUPTI=Yes
+ )
+ eapply $(prefixify_ro "${FILESDIR}"/${PN}-0.4.0_p20231031-gentoo.patch)
+
+ cmake_src_configure
+}