summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-08-14 09:37:10 +0200
committerMichał Górny <mgorny@gentoo.org>2017-08-14 09:47:12 +0200
commit15db0163a34000b3fb9d347fc7d9428186d57ebb (patch)
tree6ba4d943d895302335815439f4572a143d55388d
parentnet-p2p/dclib: Remove last-rited pkg, #618950 (diff)
downloadgentoo-15db0163a34000b3fb9d347fc7d9428186d57ebb.tar.gz
gentoo-15db0163a34000b3fb9d347fc7d9428186d57ebb.tar.bz2
gentoo-15db0163a34000b3fb9d347fc7d9428186d57ebb.zip
net-irc/bobotpp: Remove last-rited pkg, #617794
-rw-r--r--net-irc/bobotpp/Manifest1
-rw-r--r--net-irc/bobotpp/bobotpp-2.2.3.ebuild49
-rw-r--r--net-irc/bobotpp/files/bobotpp-2.2.2-asneeded.patch15
-rw-r--r--net-irc/bobotpp/files/bobotpp-2.2.3-fix-c++14.patch103
-rw-r--r--net-irc/bobotpp/files/bobotpp-2.2.3-stdout.patch13
-rw-r--r--net-irc/bobotpp/metadata.xml5
-rw-r--r--profiles/package.mask4
7 files changed, 0 insertions, 190 deletions
diff --git a/net-irc/bobotpp/Manifest b/net-irc/bobotpp/Manifest
deleted file mode 100644
index 84104fd16679..000000000000
--- a/net-irc/bobotpp/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST bobotpp-2.2.3.tar.gz 301675 SHA256 b45e84529b4417d31686e355951e0d4ceb7f0bb470f5c6498adb530f50a6d908 SHA512 473728350727da9225035c4a40303e3656f27d40786558b6a12939b22be56db9c3822a48ac1463a4baef6f45f5c9cf0ae90fdad0e9adc465c185ce1491034586 WHIRLPOOL 5acd2b5e4bd38f38d67196f386bc567c4acd621fce2b1b333107efa45c11a9417f06609823c7d9f5a022812e3f4f9a9acbb86f1a24c65d84ac2a8480a17ca780
diff --git a/net-irc/bobotpp/bobotpp-2.2.3.ebuild b/net-irc/bobotpp/bobotpp-2.2.3.ebuild
deleted file mode 100644
index 1076aa7ab954..000000000000
--- a/net-irc/bobotpp/bobotpp-2.2.3.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools
-
-DESCRIPTION="A flexible IRC bot scriptable in scheme"
-HOMEPAGE="http://unknownlamer.org/code/bobot.html"
-SRC_URI="https://savannah.nongnu.org/download/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="guile"
-
-DEPEND="guile? ( dev-scheme/guile )"
-RDEPEND="${DEPEND}"
-
-HTML_DOCS=( documentation/index.html )
-PATCHES=(
- "${FILESDIR}"/${PN}-2.2.2-asneeded.patch
- "${FILESDIR}"/${PN}-2.2.3-stdout.patch
- "${FILESDIR}"/${PN}-2.2.3-fix-c++14.patch
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- econf \
- --enable-crypt \
- $(use_enable guile scripting)
-}
-
-src_install() {
- default
- docinto examples
- dodoc -r examples/config examples/scripts
-
- dosym bobot++.info /usr/share/info/bobotpp.info
-}
-
-pkg_postinst() {
- elog "You can find a sample configuration file set in"
- elog "${EPREFIX}/usr/share/doc/${PF}/example-config"
-}
diff --git a/net-irc/bobotpp/files/bobotpp-2.2.2-asneeded.patch b/net-irc/bobotpp/files/bobotpp-2.2.2-asneeded.patch
deleted file mode 100644
index e960e008f187..000000000000
--- a/net-irc/bobotpp/files/bobotpp-2.2.2-asneeded.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- bobotpp-2.2.2.orig/configure.ac 2006-06-29 02:02:46.000000000 +0200
-+++ bobotpp-2.2.2/configure.ac 2009-10-15 19:31:42.058285332 +0200
-@@ -58,9 +58,9 @@
- AC_CPP_STL_IOSBASE
-
- dnl Checks for libraries.
--AC_CHECK_LIB(crypt, crypt, [LDFLAGS="-lcrypt $LDFLAGS]")
--AC_CHECK_LIB(socket, socket, [LDFLAGS="-lsocket $LDFLAGS]")
--AC_CHECK_LIB(nsl, connect, [LDFLAGS="-lnsl $LDFLAGS]")
-+AC_CHECK_LIB(crypt, crypt)
-+AC_CHECK_LIB(socket, socket)
-+AC_CHECK_LIB(nsl, connect)
-
- dnl CC++ is special (no function to check_lib on
- dnl AC_CHECK_PROG(CCGNU_FOUND, [ccgnu2-config],
diff --git a/net-irc/bobotpp/files/bobotpp-2.2.3-fix-c++14.patch b/net-irc/bobotpp/files/bobotpp-2.2.3-fix-c++14.patch
deleted file mode 100644
index 4f03c4a19568..000000000000
--- a/net-irc/bobotpp/files/bobotpp-2.2.3-fix-c++14.patch
+++ /dev/null
@@ -1,103 +0,0 @@
-Fix building with C++14, which errors out due to ambiguity as a result of crappy implicit
-conversion operators running astray with new std::string and iostream interfaces.
-See also: https://bugs.gentoo.org/show_bug.cgi?id=594152
-
---- a/source/Bot.C
-+++ b/source/Bot.C
-@@ -111,7 +111,7 @@
- dccConnections = new DCCManager ();
-
- // Let's read the alias file
-- std::ifstream initFile(initFileName);
-+ std::ifstream initFile(static_cast<const char*>(initFileName));
-
- if (initFile)
- {
-@@ -217,7 +217,7 @@
- void
- Bot::readConfig()
- {
-- std::ifstream file(configFileName);
-+ std::ifstream file(static_cast<const char*>(configFileName));
- String temp;
- int line = 1;
-
-@@ -736,11 +736,12 @@
- logFileName = name;
- logFile.close ();
- logFile.clear ();
-+ String myTempLogFileName(logs_dir + logFileName);
- #if HAVE_IOSBASE
-- logFile.open(logs_dir + logFileName, std::ios_base::out |
-+ logFile.open(static_cast<const char*>(myTempLogFileName), std::ios_base::out |
- std::ios_base::ate | std::ios_base::app);
- #else
-- logFile.open(logs_dir + logFileName, ios::out | ios::ate
-+ logFile.open(static_cast<const char*>(myTempLogFileName), ios::out | ios::ate
- | ios::app);
- #endif
-
---- a/source/Bot.H
-+++ b/source/Bot.H
-@@ -43,8 +43,8 @@
- #include <libguile.h>
- #endif
-
--#define VERSION_STRING PACKAGE" version "VERSION" by unknown_lamer@FreeNode <clinton@unknownlamer.org>\n1.97 and below by eb@IRCNet <eb@via.ecp.fr>"
--#define COPYRIGHT_STRING PACKAGE" version "VERSION", Copyright (C) 1997-2000 Etienne BERNARD\nCopyright (C) 2002,2003,2004,2005,2008 Clinton Ebadi"
-+#define VERSION_STRING PACKAGE " version " VERSION " by unknown_lamer@FreeNode <clinton@unknownlamer.org>\n1.97 and below by eb@IRCNet <eb@via.ecp.fr>"
-+#define COPYRIGHT_STRING PACKAGE " version " VERSION ", Copyright (C) 1997-2000 Etienne BERNARD\nCopyright (C) 2002,2003,2004,2005,2008 Clinton Ebadi"
-
- class Channel;
- class DCCConnection;
---- a/source/ShitList.C
-+++ b/source/ShitList.C
-@@ -45,7 +45,7 @@
- void
- ShitList::read()
- {
-- std::ifstream file(listFileName);
-+ std::ifstream file(static_cast<const char*>(listFileName));
- String temp;
- int line = 1;
-
-@@ -74,7 +74,7 @@
- ShitList::save()
- {
- std::list<ShitEntry *>::iterator it = l.begin();
-- std::ofstream file(listFileName);
-+ std::ofstream file(static_cast<const char*>(listFileName));
-
- if (!file)
- return;
---- a/source/UserCommands.C
-+++ b/source/UserCommands.C
-@@ -612,7 +612,7 @@
-
- StringTokenizer st(rest);
- String command = Utils::to_upper (st.next_token());
-- std::ifstream helpFile(cnx->bot->helpFileName);
-+ std::ifstream helpFile(static_cast<const char*>(cnx->bot->helpFileName));
-
- if (!helpFile) {
- from->sendNotice(String("\002Error: I can not find the "
---- a/source/UserList.C
-+++ b/source/UserList.C
-@@ -39,7 +39,7 @@
- void
- UserList::read()
- {
-- std::ifstream file(listFilename);
-+ std::ifstream file(static_cast<const char*>(listFilename));
- String temp, empty = "";
- int line = 1;
-
-@@ -88,7 +88,7 @@
- UserList::save()
- {
- std::list<UserListItem *>::iterator it = l.begin();
-- std::ofstream file(listFilename);
-+ std::ofstream file(static_cast<const char*>(listFilename));
-
- if (!file)
- return;
diff --git a/net-irc/bobotpp/files/bobotpp-2.2.3-stdout.patch b/net-irc/bobotpp/files/bobotpp-2.2.3-stdout.patch
deleted file mode 100644
index 8bbb78be966c..000000000000
--- a/net-irc/bobotpp/files/bobotpp-2.2.3-stdout.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-From: Nathan Phillip Brink <binki@gentoo.org>
-Subject: Reduce amount of noise printed to stdout.
-
---- a/source/Utils.C
-+++ b/source/Utils.C
-@@ -97,7 +97,6 @@
- if (host == "") host = "*";
- }
-
-- std::cout << nick + "!" + user + "@" + host << std::endl;
-
- return nick + "!" + user + "@" + host;
- }
diff --git a/net-irc/bobotpp/metadata.xml b/net-irc/bobotpp/metadata.xml
deleted file mode 100644
index 6f49eba8f496..000000000000
--- a/net-irc/bobotpp/metadata.xml
+++ /dev/null
@@ -1,5 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<!-- maintainer-needed -->
-</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index 2f40960ed602..adeed68498b5 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -406,10 +406,6 @@ www-client/w3mir
dev-util/pida
# Pacho Ramos <pacho@gentoo.org> (14 Jul 2017)
-# Not compatible with guile2, bug #617794. Removal in a month.
-net-irc/bobotpp
-
-# Pacho Ramos <pacho@gentoo.org> (14 Jul 2017)
# Dead for ages, relies on dead libs (#622010), you can move to moserial, cutecom or
# minicom. Removal in 2 months.
net-dialup/gtkterm