summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-07-23 23:17:08 -0400
committerSam James <sam@gentoo.org>2022-07-24 18:10:46 +0100
commit29abc9a1f1297d2bf7486785d227a790ed462598 (patch)
tree1b81b0cd968eac983288289bd3d1097f9c268a34
parentdev-haskell/network-byte-order: add 0.1.6, drop 0.1.4.0 (diff)
downloadgentoo-29abc9a1f1297d2bf7486785d227a790ed462598.tar.gz
gentoo-29abc9a1f1297d2bf7486785d227a790ed462598.tar.bz2
gentoo-29abc9a1f1297d2bf7486785d227a790ed462598.zip
dev-haskell/http2: add 3.0.1, drop 2.0.3
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-haskell/http2/Manifest2
-rw-r--r--dev-haskell/http2/http2-2.0.3.ebuild46
-rw-r--r--dev-haskell/http2/http2-3.0.1.ebuild53
3 files changed, 54 insertions, 47 deletions
diff --git a/dev-haskell/http2/Manifest b/dev-haskell/http2/Manifest
index 4a2fae055607..6648bbe0a355 100644
--- a/dev-haskell/http2/Manifest
+++ b/dev-haskell/http2/Manifest
@@ -1 +1 @@
-DIST http2-2.0.3.tar.gz 5211934 BLAKE2B cc1fad663650eaa1514e5f94737966ac86a92c2cc15f47db06c057a78873ca7d745aa77280cf451e11a9c2e328cad2a89d965bb7502d6b2e0b9b808b88570a8d SHA512 ff5f02c355f9f5c459d94993f05636955f81b91cbdbd4e8c262b56e1fa3846f92aff946f8ec6851ab57ffbb73afb42999cb3597eb250a9e15a8d6788da860b20
+DIST http2-3.0.1.tar.gz 5556373 BLAKE2B 40daf73f0460ce649d6bed41b9df961b7388f7ac2e67a11aae56be2f31209183e68cef558b7880b87d1a752f96f989779e5ecbf1a86df5bd4ac8443cd476c41b SHA512 aaa32209fb9945cc33c557866acb053df403bbe37c2bd024ac52e7fc6a3e816d0249e48b83e8846017fe0df0998327cf3498f1bc96b57b0fa81ce9c4d35589c6
diff --git a/dev-haskell/http2/http2-2.0.3.ebuild b/dev-haskell/http2/http2-2.0.3.ebuild
deleted file mode 100644
index e0372b83bcb4..000000000000
--- a/dev-haskell/http2/http2-2.0.3.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.6.1.9999
-#hackport: flags: -devel
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="HTTP/2.0 library including frames and HPACK"
-HOMEPAGE="https://github.com/kazu-yamamoto/http2"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE=""
-
-RDEPEND="dev-haskell/case-insensitive:=[profile?]
- dev-haskell/http-types:=[profile?]
- dev-haskell/network:=[profile?]
- >=dev-haskell/network-byte-order-0.1.1:=[profile?]
- dev-haskell/psqueues:=[profile?]
- dev-haskell/stm:=[profile?]
- dev-haskell/time-manager:=[profile?]
- >=dev-lang/ghc-7.10.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.22.2.0
- test? ( dev-haskell/aeson
- dev-haskell/aeson-pretty
- dev-haskell/base16-bytestring
- >=dev-haskell/doctest-0.9.3
- >=dev-haskell/glob-0.9
- >=dev-haskell/hspec-1.3
- dev-haskell/text
- dev-haskell/unordered-containers
- dev-haskell/vector )
-"
-
-src_configure() {
- haskell-cabal_src_configure \
- --flag=-devel
-}
diff --git a/dev-haskell/http2/http2-3.0.1.ebuild b/dev-haskell/http2/http2-3.0.1.ebuild
new file mode 100644
index 000000000000..2e8e06788c55
--- /dev/null
+++ b/dev-haskell/http2/http2-3.0.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.7.9999
+#hackport: flags: -devel,-doc,-h2spec
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # test-suite
+inherit haskell-cabal
+
+DESCRIPTION="HTTP/2 library"
+HOMEPAGE="https://github.com/kazu-yamamoto/http2"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RESTRICT=test # test suite requires too new dependencies
+
+RDEPEND="dev-haskell/case-insensitive:=[profile?]
+ dev-haskell/http-types:=[profile?]
+ dev-haskell/network:=[profile?]
+ >=dev-haskell/network-byte-order-0.1.5:=[profile?]
+ dev-haskell/psqueues:=[profile?]
+ dev-haskell/stm:=[profile?]
+ dev-haskell/time-manager:=[profile?]
+ dev-haskell/unix-time:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1"
+# test? ( dev-haskell/aeson
+# dev-haskell/aeson-pretty
+# dev-haskell/async
+# >=dev-haskell/base16-bytestring-1.0
+# dev-haskell/cryptonite
+# >=dev-haskell/glob-0.9
+# >=dev-haskell/hspec-1.3
+# >=dev-haskell/network-run-0.1.0
+# dev-haskell/text
+# dev-haskell/typed-process
+# dev-haskell/unordered-containers
+# dev-haskell/vector )
+# "
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-devel \
+ --flag=-doc \
+ --flag=-h2spec
+}