summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Udvare <audvare@gmail.com>2023-04-22 04:01:04 -0400
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-04-25 13:01:03 +0200
commit3dcac20944ad957106be9e8b710ae8a1e4fbb6d8 (patch)
treee780d294e690ba40f2791709b27ed38bc254c586
parentmedia-sound/spotify: update wrapper for changed spotify-tray path (diff)
downloadgentoo-3dcac20944ad957106be9e8b710ae8a1e4fbb6d8.tar.gz
gentoo-3dcac20944ad957106be9e8b710ae8a1e4fbb6d8.tar.bz2
gentoo-3dcac20944ad957106be9e8b710ae8a1e4fbb6d8.zip
sci-libs/libqalculate: add 4.6.1
Signed-off-by: Andrew Udvare <audvare@gmail.com> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--sci-libs/libqalculate/Manifest1
-rw-r--r--sci-libs/libqalculate/libqalculate-4.6.1.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/sci-libs/libqalculate/Manifest b/sci-libs/libqalculate/Manifest
index fa43c41f3e1f..3af099deeda8 100644
--- a/sci-libs/libqalculate/Manifest
+++ b/sci-libs/libqalculate/Manifest
@@ -4,3 +4,4 @@ DIST libqalculate-4.1.1.tar.gz 2172017 BLAKE2B e9dcc22ad2d102572610ddc103afc5a27
DIST libqalculate-4.2.0.tar.gz 2215812 BLAKE2B 393bab0d9cf5d4a3158d93bf676805d829a2103ec1dc733e3d98fd7a54ab0c42d3797dadb1cde72b1df2e13cfb691430982f5fbd886ac9f0a906b3884f912202 SHA512 105f567a3b24a1c396df0eb85f299d18228f489e4d989f0fa09cf97321494030e9a85d9cd9fe4b5dd8cc233b4329025788275ba168546929e912598dee8ef6b8
DIST libqalculate-4.3.0.tar.gz 2230559 BLAKE2B 724dde0bc16e5eaed63420c6dd68ac7c94477c44c007c92bb3b4560d8a2d2062ade4be6d2c8005ff64bf8ffe4c42d95d6990f7900df7a1c1a36cd4cd717bd04d SHA512 234c111435d9461ab65d274030f9a5f6ee401cd81df62b9c2273e921edb8db3bde4254060285dbfaa7b9701a257a5801c8ab8f26b0c2aeeafd2a36042bdeeb84
DIST libqalculate-4.5.0.tar.gz 2603599 BLAKE2B 142790cf89e97c601b08d553b1f9cd6c1bf184a43c2614a07fa91560a875ea3e3124cf29d7652640b1f2fb4fada1519d48e4cb0ebcfb844c26369d3031aee230 SHA512 a123eaa725c6c6badce0eceecd6ef7e37ca281e7de18085d6a28aa6043bb3f1069f9ebba82b29989c9958455aa093ee183fd8013a86b39bd34e56454bdb35770
+DIST libqalculate-4.6.1.tar.gz 2610769 BLAKE2B 02ad7371c537bf40d98bb1b32877f0a39394b0723c45e53b00381df2d0d326b79ab39c66238a8e3a89f10aa093f6c12bcc5ae0457f6d65503fb3712a78bb0dfc SHA512 7f03e0f8cc87918b8ec962ce8c85840b644aad02cdd53037d41602198cdcb6567099d175771ff3752fc99fccbc4b180527da5fef68b0059bd1b259c34c57620e
diff --git a/sci-libs/libqalculate/libqalculate-4.6.1.ebuild b/sci-libs/libqalculate/libqalculate-4.6.1.ebuild
new file mode 100644
index 000000000000..6bdf2d129d50
--- /dev/null
+++ b/sci-libs/libqalculate/libqalculate-4.6.1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Bump with sci-calculators/qalculate-gtk!
+
+inherit toolchain-funcs
+
+DESCRIPTION="A modern multi-purpose calculator library"
+HOMEPAGE="https://qalculate.github.io/"
+SRC_URI="https://github.com/Qalculate/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+# SONAME changes pretty often on bumps. Check!
+SLOT="0/22"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="curl icu gnuplot +hardened readline test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-libs/gmp:=
+ dev-libs/libxml2:2
+ dev-libs/mpfr:=
+ virtual/libiconv
+ curl? ( net-misc/curl )
+ icu? ( dev-libs/icu:= )
+ readline? ( sys-libs/readline:= )"
+RDEPEND="${DEPEND}
+ gnuplot? ( >=sci-visualization/gnuplot-3.7 )"
+BDEPEND="dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ cat >po/POTFILES.skip <<-EOF || die
+ # Required by make check
+ data/currencies.xml.in
+ data/datasets.xml.in
+ data/elements.xml.in
+ data/functions.xml.in
+ data/planets.xml.in
+ data/prefixes.xml.in
+ data/units.xml.in
+ data/variables.xml.in
+ src/defs2doc.cc
+ EOF
+}
+
+src_configure() {
+ # Needed for po-defs/Makefile
+ export CXX_FOR_BUILD="$(tc-getBUILD_CXX)"
+ export CXXCPP_FOR_BUILD="$(tc-getBUILD_CXX) -E"
+
+ # bug #792027
+ tc-export CC
+
+ econf \
+ $(use_enable test tests) \
+ $(use_enable test unittests) \
+ $(use_with curl libcurl) \
+ $(use_with gnuplot gnuplot-call) \
+ $(use_enable !hardened insecure) \
+ $(use_with icu) \
+ $(use_with readline)
+}
+
+src_install() {
+ # docs/reference/Makefile.am -> referencedir=
+ emake \
+ DESTDIR="${D}" \
+ referencedir="${EPREFIX}/usr/share/doc/${PF}/html" \
+ install
+
+ einstalldocs
+
+ find "${ED}" -name '*.la' -delete || die
+}