summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-17 05:55:54 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-17 06:54:34 +0200
commit5802a8d1b18b72e5859b6ac4f6c11157b977209a (patch)
tree1e66aa313a26734e050e1f162f7d488aac487018
parentdev-util/rbtools: add 3.1.1 (diff)
downloadgentoo-5802a8d1b18b72e5859b6ac4f6c11157b977209a.tar.gz
gentoo-5802a8d1b18b72e5859b6ac4f6c11157b977209a.tar.bz2
gentoo-5802a8d1b18b72e5859b6ac4f6c11157b977209a.zip
dev-python/botocore: Bump to 1.27.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.27.11.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index ab1101965e4d..f83ffe55bdad 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -1,5 +1,6 @@
DIST botocore-1.26.10.tar.gz 9008316 BLAKE2B a05078ec5732015cbd8ea4da2d2d82e28f4241b7c3164f3410ae396a19f79c116f7a9059a3361e99eacc952f860a516b187375dbf64ee5e4e5648e8c3b0f95a5 SHA512 b12e9002dc8e0912a9681938f343b51d628f0b2798693dc81636fe7ede01d006d5bc8a901f92edf10a88d97c3c6311aaf97206a6f55070e645747536fe39b144
DIST botocore-1.27.10.tar.gz 9107238 BLAKE2B 9bf9d6d0789acc84e1328704d6db0a36d5d036be38aa61b26f776aa42ab91889faa1f871a5373808a76906973c897dcd4a6d07d914c29fd4edf8b6ac2fae3511 SHA512 1a178ca96d126b74d63d0a3199cbb55370c8ba77559d87173f496aef961364ab1df13a8f5e5565cbf79ec8f17cf2d2178952e1739b40b29a34b8b78118d18982
+DIST botocore-1.27.11.tar.gz 9127530 BLAKE2B b0b852c1f8038d8f95ed8a0fb8191b18411ad8345bd99ef5f9cac6e6ea4406e945a9430fce4691c1c19365c4816d9a0ffcd40ad6ccc1c956596f779712bf0fce SHA512 650282e58b37964638c229352ff895167107c8bfde38a1e2342908787a20f53c3779758a8aec52e3c4f055ba3c3ccc5ae39a333c57a20ca095d8d06764b6e208
DIST botocore-1.27.2.tar.gz 9026413 BLAKE2B 013724df76fb87c8e7731401d09774bec303aced7c3a01bb97935865f34193d1f313d49f32c1f6b7addab9b24384f26caca44b03ba0e77014821dc7cab5142ef SHA512 85045c13fa935b017f66edc132d2a31da2ecbe0c7bfcab369cb1d5f76d8a1401d303ab7d3e2ce95d53e9a59ea81dbf5380c1106169d84f40b21cbb926e35abb9
DIST botocore-1.27.3.tar.gz 9078424 BLAKE2B 62414c2474ec44b3385c589793fd0c54984d2302239b78295bfbdc3739160bbae5bb910207dc7252b7adb96d6cd69add7413000399bcb20b671e3fbdad860c02 SHA512 47ed3e68c10e4175cdbe2122dab9319b9059f9457e27258a142224311042c5ae4692d293d29dc9b4855e65eea561fb7b703f7ddc663064413144aaf72fda33a5
DIST botocore-1.27.4.tar.gz 9079162 BLAKE2B 3707e0b53022185248d5c086860ddf99f6d43803414929252a6b090fbeb765606e1fa97896f6d9016e97a0a6b5388d754941f3a88645f5c1ea18f206d73127a7 SHA512 3743d79febcf33302de20b364267ae39a0887c7fa5e116a7209b1281b4985e593b5d3f0ea7bb6e608036d99d4df46931192f5a3a63c98f7b3da26a16ea6b5a3f
diff --git a/dev-python/botocore/botocore-1.27.11.ebuild b/dev-python/botocore/botocore-1.27.11.ebuild
new file mode 100644
index 000000000000..830c713f6036
--- /dev/null
+++ b/dev-python/botocore/botocore-1.27.11.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}