summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-05 06:08:23 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-05 06:37:26 +0100
commit6ec34b840d72db413010910c8552017b649f8f14 (patch)
tree5ef61157ef55ddf4f8960a61a37279099b34be9e
parentdev-python/pytools: Bump to 2024.1.19 (diff)
downloadgentoo-6ec34b840d72db413010910c8552017b649f8f14.tar.gz
gentoo-6ec34b840d72db413010910c8552017b649f8f14.tar.bz2
gentoo-6ec34b840d72db413010910c8552017b649f8f14.zip
dev-python/inline-snapshot: Bump to 0.14.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/inline-snapshot/Manifest1
-rw-r--r--dev-python/inline-snapshot/inline-snapshot-0.14.1.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/inline-snapshot/Manifest b/dev-python/inline-snapshot/Manifest
index 202e7398d5ce..c09c32eefcea 100644
--- a/dev-python/inline-snapshot/Manifest
+++ b/dev-python/inline-snapshot/Manifest
@@ -1 +1,2 @@
DIST inline_snapshot-0.14.0.tar.gz 209662 BLAKE2B 9bea11df88aab049af61146cb40c8afaa7607f8812c800ee7dffc7de94403029e4ae1d1ed49921f624e5327171650210744962559786e45586ae929830f81819 SHA512 32855dcd098c3e9b6a046752a3fc03c18b0df85e2cf338a928eadcd0e63bb784bdaca6855c954974ec7561e602ff3dd95ccdadb0c4f7dd1075d9d84245c171ef
+DIST inline_snapshot-0.14.1.tar.gz 220919 BLAKE2B 5bcd704ada3e31aad51fb22df3cfb8715580ded679b62205dd151b073428fffd6325b809b1aab4e5aa5d66cb7210b30e99189e72a0e031e98de6498465c5b22b SHA512 74462c7514861c1e1ac33da17b0dd61e77e76a37853fd765dde17233ccd36d11a8d184a9e7da6b855377e96968367ce5b30ca874cd209bb742fb1cdbdf2b0b54
diff --git a/dev-python/inline-snapshot/inline-snapshot-0.14.1.ebuild b/dev-python/inline-snapshot/inline-snapshot-0.14.1.ebuild
new file mode 100644
index 000000000000..9be98a99ee7d
--- /dev/null
+++ b/dev-python/inline-snapshot/inline-snapshot-0.14.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Create and update inline snapshots in your Python tests"
+HOMEPAGE="
+ https://15r10nk.github.io/inline-snapshot/
+ https://github.com/15r10nk/inline-snapshot/
+ https://pypi.org/project/inline-snapshot/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/asttokens-2.0.5[${PYTHON_USEDEP}]
+ >=dev-python/black-23.3.0[${PYTHON_USEDEP}]
+ >=dev-python/click-8.1.4[${PYTHON_USEDEP}]
+ >=dev-python/executing-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/rich-13.7.1[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-python/dirty-equals-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-6.75.5[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/mypy[${PYTHON_USEDEP}]
+ ' 'python*')
+ dev-python/pydantic[${PYTHON_USEDEP}]
+ >=dev-python/pytest-freezer-0.4.8[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ >=dev-python/pytest-subtests-0.11.0[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires pyright
+ 'tests/test_typing.py::test_typing[pyright]'
+ )
+
+ local -x COLUMNS=80
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=inline_snapshot.pytest_plugin,pytest_freezer,pytest_subtests.plugin,xdist.plugin
+ local -x PYTHONPATH=${S}/src
+ epytest -p pytest_mock
+}