summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2020-01-24 19:53:48 -0500
committerGöktürk Yüksek <gokturk@gentoo.org>2020-01-24 19:54:41 -0500
commit6fe56a79b3b7fb77e368dea14e6e68e5be4f91df (patch)
tree0dd0636a7b9a1e2bcfa39fa2d780b5441c0fbe85
parentapp-forensics/sleuthkit: bump to 4.8.0 (diff)
downloadgentoo-6fe56a79b3b7fb77e368dea14e6e68e5be4f91df.tar.gz
gentoo-6fe56a79b3b7fb77e368dea14e6e68e5be4f91df.tar.bz2
gentoo-6fe56a79b3b7fb77e368dea14e6e68e5be4f91df.zip
app-crypt/veracrypt: bump to 1.24-Update4
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
-rw-r--r--app-crypt/veracrypt/Manifest1
-rw-r--r--app-crypt/veracrypt/veracrypt-1.24_p4.ebuild101
2 files changed, 102 insertions, 0 deletions
diff --git a/app-crypt/veracrypt/Manifest b/app-crypt/veracrypt/Manifest
index a96fc6991a00..9fae3e5539b2 100644
--- a/app-crypt/veracrypt/Manifest
+++ b/app-crypt/veracrypt/Manifest
@@ -2,3 +2,4 @@ DIST VeraCrypt_1.23.tar.gz 24941166 BLAKE2B f9760342678f771192434f88a9b6c3bcc348
DIST VeraCrypt_1.24.tar.gz 25046467 BLAKE2B e8535f981d898efd797ff736a03e4a65b75bd40ed62d75e3f159932e93d9684e8601da277839b40efcd9bdda801427468386f37e9c57cd81dbc470f23693cd12 SHA512 b4a3155ec8455c51044c2aabcc785a6974d9ee740e0c77bae934a017976e715d45701811405dadfbbd9ceb2a957acbefbe15a717003c86ea38d52735de4f2e56
DIST veracrypt-1.24_p1.tar.gz 25052008 BLAKE2B 215af344a5e57e16319d6aec5f439517f774ee92b11d11060e98708d2e5390b54965eecda55bdc56e8e5f01a945b6782a8b695f24a747dd4e7ff2346b9af96e9 SHA512 2564c6b579bc3609d93fb3e6ec12c0e9e90b6b423ce06dab8870583d6b6ce0da9d864d64da67f4d1d6096e4dd750d335c66c0eed9199ec1b38c0690090f317a6
DIST veracrypt-1.24_p2.tar.gz 25208374 BLAKE2B 2667fb93e6884d97a673fe793b5f83f73961c2362e7704199b5ed0163c03f19313843583f7f2a15e05ee71516e45db97752350d2c27d22f1f278668b7c07aff9 SHA512 f778b8f6288f6f9886a15fa582f6c7126d9eaea319e854ad11bd5d44105ad5a3cb8b750d410ed8fd531ec3b23f9bad83934e6cefedd1352603d4882d2ca0ad84
+DIST veracrypt-1.24_p4.tar.gz 25212608 BLAKE2B 12d124cc5c869b8112e29624fcc5af3dd96d3c5e0179c643bf16cd361cc01677c09710faa192e7c9fe5f2ca78fbd826bc9df99f34e83ce4534f26dec01185761 SHA512 e077d6fe6a35234737387c4a6997399a251e238ab75524f53efe8ed742a35164fa4d5fcb0f15816dcb29d31fb8a4bb175d45b9aefb912c4747194fb320fa408d
diff --git a/app-crypt/veracrypt/veracrypt-1.24_p4.ebuild b/app-crypt/veracrypt/veracrypt-1.24_p4.ebuild
new file mode 100644
index 000000000000..4b069a95652c
--- /dev/null
+++ b/app-crypt/veracrypt/veracrypt-1.24_p4.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils linux-info pax-utils toolchain-funcs wxwidgets
+
+MY_PV="$(ver_cut 1-2)-Update$(ver_cut 4)"
+DESCRIPTION="Disk encryption with strong security based on TrueCrypt"
+HOMEPAGE="https://www.veracrypt.fr/en/Home.html"
+SRC_URI="https://github.com/${PN}/VeraCrypt/archive/VeraCrypt_${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+# The modules not linked against in Linux include (but not limited to):
+# libzip, chacha-xmm, chacha256, chachaRng, rdrand, t1ha2
+# Tested by actually removing the source files and performing a build
+# For this reason, we don't have to worry about their licenses
+LICENSE="Apache-2.0 BSD truecrypt-3.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+asm cpu_flags_x86_sse2 cpu_flags_x86_sse4_1 cpu_flags_x86_ssse3 doc X"
+RESTRICT="bindist mirror"
+
+WX_GTK_VER="3.0-gtk3"
+
+RDEPEND="
+ sys-fs/lvm2
+ sys-fs/fuse:0
+ x11-libs/wxGTK:${WX_GTK_VER}[X?]
+ app-admin/sudo
+ dev-libs/pkcs11-helper
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ asm? ( dev-lang/yasm )
+"
+
+S="${WORKDIR}/VeraCrypt-VeraCrypt_${MY_PV}/src"
+
+pkg_setup() {
+ local CONFIG_CHECK="~BLK_DEV_DM ~CRYPTO ~CRYPTO_XTS ~DM_CRYPT ~FUSE_FS"
+ linux-info_pkg_setup
+
+ setup-wxwidgets
+}
+
+src_compile() {
+ local myemakeargs=(
+ NOSTRIP=1
+ NOTEST=1
+ VERBOSE=1
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ AR="$(tc-getAR)"
+ RANLIB="$(tc-getRANLIB)"
+ TC_EXTRA_CFLAGS="${CFLAGS}"
+ TC_EXTRA_CXXFLAGS="${CXXFLAGS}"
+ TC_EXTRA_LFLAGS="${LDFLAGS}"
+ WX_CONFIG="${WX_CONFIG}"
+ $(usex X "" "NOGUI=1")
+ $(usex asm "" "NOASM=1")
+ $(usex cpu_flags_x86_sse2 "" "NOSSE2=1")
+ $(usex cpu_flags_x86_sse4_1 "SSE41=1" "")
+ $(usex cpu_flags_x86_ssse3 "SSSE3=1" "")
+ )
+
+ emake "${myemakeargs[@]}"
+}
+
+src_test() {
+ "${S}/Main/veracrypt" --text --test || die "tests failed"
+}
+
+src_install() {
+ local DOCS=( Readme.txt )
+ local HTML_DOCS=( )
+
+ dobin Main/veracrypt
+ if use doc; then
+ DOCS+=( "${S}"/../doc/EFI-DCS )
+ docompress -x "/usr/share/doc/${PF}/EFI-DCS"
+ HTML_DOCS+=( "${S}"/../doc/html/. )
+ fi
+ einstalldocs
+
+ newinitd "${FILESDIR}/${PN}.init" ${PN}
+
+ if use X; then
+ local s
+ for s in 16 48 128 256; do
+ newicon -s ${s} Resources/Icons/VeraCrypt-${s}x${s}.xpm veracrypt.xpm
+ done
+ make_desktop_entry ${PN} "VeraCrypt" ${PN} "Utility;Security"
+ fi
+
+ pax-mark -m "${D%/}/usr/bin/veracrypt"
+}
+
+pkg_postinst() {
+ ewarn "VeraCrypt has a very restrictive license. Please be explicitly aware"
+ ewarn "of the limitations on redistribution of binaries or modified source."
+}