summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2022-08-25 15:51:46 -0700
committerBrian Dolbec <dolsen@gentoo.org>2022-08-25 16:24:09 -0700
commit702c0ce282993021b942db1d3b94a02583715ea3 (patch)
treee063c8b105e5c96f210808cf431eec50e63ab3ce
parentdev-util/buildbot-worker: Version bump to 3.6.0 (diff)
downloadgentoo-702c0ce282993021b942db1d3b94a02583715ea3.tar.gz
gentoo-702c0ce282993021b942db1d3b94a02583715ea3.tar.bz2
gentoo-702c0ce282993021b942db1d3b94a02583715ea3.zip
dev-util/buildbot: Version bump to 3.6.0
Update 9999 twisted dep. Fix test failure due to improper PEP517 migration in commit: c79608691d5137156f43094b4dafb26c798de3ac for 3.5.0-r1 and 3.4.0-r1, 9999 Closes: https://bugs.gentoo.org/852188 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
-rw-r--r--dev-util/buildbot/Manifest1
-rw-r--r--dev-util/buildbot/buildbot-3.4.0-r1.ebuild1
-rw-r--r--dev-util/buildbot/buildbot-3.5.0-r1.ebuild1
-rw-r--r--dev-util/buildbot/buildbot-3.6.0.ebuild181
-rw-r--r--dev-util/buildbot/buildbot-9999.ebuild7
5 files changed, 185 insertions, 6 deletions
diff --git a/dev-util/buildbot/Manifest b/dev-util/buildbot/Manifest
index 28cea4cfa214..2a4093a0408e 100644
--- a/dev-util/buildbot/Manifest
+++ b/dev-util/buildbot/Manifest
@@ -1,2 +1,3 @@
DIST buildbot-3.4.0.tar.gz 2446868 BLAKE2B a58b268fd4569105f1c0ba48c9ed86210a3fee4725f167d6b6847960bbb56a092d0c0db427ecf5932a91d44065da8843fbb4046d289800a019b0b1d8b1f53fea SHA512 92e5085862ac37a6c3c059870a3998fbaac2019c48384295f3e209788ea14bddff6704f1b987a8f3b1550c1b0255d228f8a0b2a20b5cb760b22a513db465863b
DIST buildbot-3.5.0.tar.gz 2450653 BLAKE2B 0e923f2a3a334241b25c6a151b397356d7ba81ab2ff19c17c50a5996494d0f99fa198b63aa18a27ab60c5ad53c0154494bf4dea4e2bd306f4b709858a64dc3c4 SHA512 9730305540db3cdf166fdfc071142061926bbb895aa941046ad25e8350d3c161d4175f3518cd8a3ab51f320b0a5980517e5e53d9f5ddc342492ee56a0f6f266f
+DIST buildbot-3.6.0.tar.gz 2458029 BLAKE2B 5f41702d4d61fbcbfa878c6febbb89a38da2648403c4fdcab24bde246adc225e9ac3f72eb7dc893e03763f00c2d3548c31b2d6597904032e4b75e660bb1faf72 SHA512 c0bec931d08adb1eec51114619d2a085fbef224944a4c0acf3ab396f84d846fd620b84379affee238d02dd90ca1294fdb2b7fb8ea6e82d95c4cfeae93a0b5e73
diff --git a/dev-util/buildbot/buildbot-3.4.0-r1.ebuild b/dev-util/buildbot/buildbot-3.4.0-r1.ebuild
index 48e0f782f784..2805b245be55 100644
--- a/dev-util/buildbot/buildbot-3.4.0-r1.ebuild
+++ b/dev-util/buildbot/buildbot-3.4.0-r1.ebuild
@@ -86,7 +86,6 @@ src_prepare() {
}
python_test() {
- distutils_install_for_testing
"${EPYTHON}" -m twisted.trial buildbot || die "Tests failed with ${EPYTHON}"
}
diff --git a/dev-util/buildbot/buildbot-3.5.0-r1.ebuild b/dev-util/buildbot/buildbot-3.5.0-r1.ebuild
index e6a1f69bd613..38fdc881f1a2 100644
--- a/dev-util/buildbot/buildbot-3.5.0-r1.ebuild
+++ b/dev-util/buildbot/buildbot-3.5.0-r1.ebuild
@@ -86,7 +86,6 @@ src_prepare() {
}
python_test() {
- distutils_install_for_testing
"${EPYTHON}" -m twisted.trial buildbot || die "Tests failed with ${EPYTHON}"
}
diff --git a/dev-util/buildbot/buildbot-3.6.0.ebuild b/dev-util/buildbot/buildbot-3.6.0.ebuild
new file mode 100644
index 000000000000..63802dfa22aa
--- /dev/null
+++ b/dev-util/buildbot/buildbot-3.6.0.ebuild
@@ -0,0 +1,181 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{8..10} )
+inherit readme.gentoo-r1 systemd distutils-r1
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="BuildBot build automation system"
+HOMEPAGE="https://buildbot.net/
+ https://github.com/buildbot/buildbot
+ https://pypi.org/project/buildbot/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~amd64-linux ~x86-linux"
+
+IUSE="crypt docker examples irc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ acct-user/buildbot
+ >=dev-python/twisted-18.7.0[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.1[${PYTHON_USEDEP}]
+ >=dev-python/zope-interface-4.1.1[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-1.3.0[${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/alembic-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-1.5[${PYTHON_USEDEP}]
+ >=dev-python/txaio-2.2.2[${PYTHON_USEDEP}]
+ >=dev-python/autobahn-0.16.0[${PYTHON_USEDEP}]
+ dev-python/pyjwt[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-worker-${PV}[${PYTHON_USEDEP}]
+ crypt? (
+ >=dev-python/pyopenssl-16.0.0[${PYTHON_USEDEP}]
+ dev-python/service_identity[${PYTHON_USEDEP}]
+ || (
+ >=dev-python/twisted-18.7.0[${PYTHON_USEDEP},ssl(-)]
+ >=dev-python/twisted-18.7.0[${PYTHON_USEDEP},crypt(-)]
+ )
+ dev-python/idna[${PYTHON_USEDEP}]
+ )
+ irc? (
+ dev-python/txrequests[${PYTHON_USEDEP}]
+ )
+ docker? (
+ >=dev-python/docker-py-2.2.0[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/treq[${PYTHON_USEDEP}]
+ dev-python/txrequests[${PYTHON_USEDEP}]
+ dev-python/pypugjs[${PYTHON_USEDEP}]
+ >=dev-python/boto3-1.12.48[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ dev-python/lz4[${PYTHON_USEDEP}]
+ dev-python/ldap3[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-pkg-${PV}[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-worker-${PV}[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}]
+ )"
+
+DOC_CONTENTS="The \"buildbot\" user and the \"buildmaster\" init script has been added
+to support starting buildbot through Gentoo's init system. To use this,
+execute \"emerge --config =${CATEGORY}/${PF}\" to create a new instance.
+The scripts can run as a different user if desired."
+
+src_prepare() {
+ # disable all warnings as errors
+ sed -e "/warnings.filterwarnings('error')/d" -i buildbot/test/__init__.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ "${EPYTHON}" -m twisted.trial buildbot || die "Tests failed with ${EPYTHON}"
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ doman docs/buildbot.1
+
+ if use examples; then
+ dodoc -r docs/examples
+ fi
+
+ newconfd "${FILESDIR}/buildmaster.confd" buildmaster
+ newinitd "${FILESDIR}/buildmaster.initd" buildmaster
+ systemd_dounit "${FILESDIR}/buildmaster.target"
+ systemd_newunit "${FILESDIR}/buildmaster_at.service" "buildmaster@.service"
+ systemd_install_serviced "${FILESDIR}/buildmaster_at.service.conf" "buildmaster@.service"
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ ewarn
+ ewarn "Starting with buildbot-0.8.12-r2, more than one instance of buildmaster"
+ ewarn "can be run simultaneously. Note that \"BASEDIR\" in the buildbot configuration file"
+ ewarn "is now the common base directory for all instances. If you are migrating from an older"
+ ewarn "version, make sure that you copy the current contents of \"BASEDIR\" to a subdirectory."
+ ewarn "The name of the subdirectory corresponds to the name of the buildmaster instance."
+ ewarn "In order to start the service running OpenRC-based systems need to link to the init file:"
+ ewarn " ln --symbolic --relative /etc/init.d/buildmaster /etc/init.d/buildmaster.myinstance"
+ ewarn " rc-update add buildmaster.myinstance default"
+ ewarn " /etc/init.d/buildmaster.myinstance start"
+ ewarn "Systems using systemd can do the following:"
+ ewarn " systemctl enable buildmaster@myinstance.service"
+ ewarn " systemctl enable buildmaster.target"
+ ewarn " systemctl start buildmaster.target"
+ elog
+ elog "Upstream recommends the following when upgrading:"
+ elog "Each time you install a new version of Buildbot, you should run the"
+ elog "\"buildbot upgrade-master\" command on each of your pre-existing build masters."
+ elog "This will add files and fix (or at least detect) incompatibilities between"
+ elog "your old config and the new code."
+ fi
+ elog
+ elog "In order to create a new instance of buildmaster, execute:"
+ elog " emerge --config =${CATEGORY}/${PF}"
+}
+
+pkg_config() {
+ local buildmaster_path="/var/lib/buildmaster"
+ local log_path="/var/log/buildmaster"
+
+ einfo "This will prepare a new buildmaster instance in ${buildmaster_path}."
+ einfo "Press Control-C to abort."
+
+ einfo "Enter the name for the new instance: "
+ read instance_name
+ [[ -z "${instance_name}" ]] && die "Invalid instance name"
+
+ local instance_path="${buildmaster_path}/${instance_name}"
+ local instance_log_path="${log_path}/${instance_name}"
+
+ if [[ -e "${instance_path}" ]]; then
+ eerror "The instance with the specified name already exists:"
+ eerror "${instance_path}"
+ die "Instance already exists"
+ fi
+
+ local buildbot="/usr/bin/buildbot"
+ if [[ ! -d "${buildmaster_path}" ]]; then
+ mkdir --parents "${buildmaster_path}" || die "Unable to create directory ${buildmaster_path}"
+ fi
+ "${buildbot}" create-master "${instance_path}" &>/dev/null || die "Creating instance failed"
+ chown --recursive buildbot:buildbot "${instance_path}" || die "Setting permissions for instance failed"
+ mv "${instance_path}/master.cfg.sample" "${instance_path}/master.cfg" \
+ || die "Moving sample configuration failed"
+ ln --symbolic --relative "/etc/init.d/buildmaster" "/etc/init.d/buildmaster.${instance_name}" \
+ || die "Unable to create link to init file"
+
+ if [[ ! -d "${instance_log_path}" ]]; then
+ mkdir --parents "${instance_log_path}" || die "Unable to create directory ${instance_log_path}"
+ chown --recursive buildbot:buildbot "${instance_log_path}" \
+ || die "Setting permissions for instance failed"
+ fi
+ ln --symbolic --relative "${instance_log_path}/twistd.log" "${instance_path}/twistd.log" \
+ || die "Unable to create link to log file"
+
+ einfo "Successfully created a buildmaster instance at ${instance_path}."
+ einfo "To change the default settings edit the master.cfg file in this directory."
+}
diff --git a/dev-util/buildbot/buildbot-9999.ebuild b/dev-util/buildbot/buildbot-9999.ebuild
index 2f299e4c1c37..b0ebb30b9273 100644
--- a/dev-util/buildbot/buildbot-9999.ebuild
+++ b/dev-util/buildbot/buildbot-9999.ebuild
@@ -22,7 +22,7 @@ RESTRICT="!test? ( test )"
RDEPEND="
acct-user/buildbot
- >=dev-python/twisted-17.9.0[${PYTHON_USEDEP}]
+ >=dev-python/twisted-18.7.0[${PYTHON_USEDEP}]
>=dev-python/jinja-2.1[${PYTHON_USEDEP}]
>=dev-python/zope-interface-4.1.1[${PYTHON_USEDEP}]
>=dev-python/sqlalchemy-1.3.0[${PYTHON_USEDEP}]
@@ -38,8 +38,8 @@ RDEPEND="
>=dev-python/pyopenssl-16.0.0[${PYTHON_USEDEP}]
dev-python/service_identity[${PYTHON_USEDEP}]
|| (
- >=dev-python/twisted-17.9.0[${PYTHON_USEDEP},ssl(-)]
- >=dev-python/twisted-17.9.0[${PYTHON_USEDEP},crypt(-)]
+ >=dev-python/twisted-18.7.0[${PYTHON_USEDEP},ssl(-)]
+ >=dev-python/twisted-18.7.0[${PYTHON_USEDEP},crypt(-)]
)
dev-python/idna[${PYTHON_USEDEP}]
)
@@ -81,7 +81,6 @@ src_prepare() {
}
python_test() {
- distutils_install_for_testing
"${EPYTHON}" -m twisted.trial buildbot || die "Tests failed with ${EPYTHON}"
}