summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-18 03:23:00 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-18 03:58:54 +0200
commit8c659ffbb07d5b319e565640516745f57a6db44e (patch)
treee0b49736e31bb4e76ffbfbdc7bab39f448f3ac8a
parentapp-emulation/libvirt: drop 8.7.0-r1, 8.8.0-r1, 8.9.0, 8.9.0-r2, 9.2.0 (diff)
downloadgentoo-8c659ffbb07d5b319e565640516745f57a6db44e.tar.gz
gentoo-8c659ffbb07d5b319e565640516745f57a6db44e.tar.bz2
gentoo-8c659ffbb07d5b319e565640516745f57a6db44e.zip
dev-python/hypothesis: Bump to 6.79.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.79.0.ebuild104
2 files changed, 105 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index c5c51c729788..62d2e03229f4 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -8,3 +8,4 @@ DIST hypothesis-6.77.0.gh.tar.gz 9376438 BLAKE2B 2c80427a43481fbc837042c8481e56f
DIST hypothesis-6.78.1.gh.tar.gz 9376599 BLAKE2B c0998212067e947af71f17aa5f76609ed71cf57cf4d71418329ec92ca663b202bc3c8d09936e147304744d81d01f9ba0ae5f5cf369fe04cbcb95c351a3a6cd06 SHA512 5491dfce1a8a25288aca345a6a6f8b88557b3dc2a08773ee2aa10d133d9b44b9bddb4d7584ac99046a006f3d9fb85713b6b38f5cc635ddc437c8fb4bbe58a866
DIST hypothesis-6.78.2.gh.tar.gz 9376858 BLAKE2B 8bbc6e373a9dd67b47922c4ba9f938f90d154a945f7142d07304db11b5b4e4d53b21605e4f7be24fb413153a2edf9c54bec01409a72abfb8fb31b43c87836ede SHA512 65ea4396365a3f4f1740d61cbcdf0eb380f99c133d582b56ee3e557bcc4da0d329ac832b38dad64c5e5fb7afcace55a17cc22fbb15ea1751508488983a1d7cef
DIST hypothesis-6.78.3.gh.tar.gz 9377028 BLAKE2B 857d748262384fdf42f26e2656daa73e162c4058b136e2c0d1dff9e45fa42151512217653467cf81e514cb17cfc5aecfc6b1dbdbad7a62068489a79c13f3eb65 SHA512 1f15bd6ea2bb6822b3cf0cb1b679d976312a5c960e54741abab1e111ff0b9c6471c00752566bd937e86e7ef847b6bd80e53825964d6bc9fecf1b992499bf29f3
+DIST hypothesis-6.79.0.gh.tar.gz 9377619 BLAKE2B 8e0650967f8552b3968f8627ef61119ea1532656009fcc83899d4c1e5e97e71e7cb14ffe0864008f7e6c658cff864a7a6d94d04365aba99d38383e3c1b4941a6 SHA512 d4268503425805d7ce0800434474b0f582d6114c3323b36abf6ce58e9f8530d7c11ab634671670f1d67387ac8c90d198303129c552130c8127dc0b3bbad2c766
diff --git a/dev-python/hypothesis/hypothesis-6.79.0.ebuild b/dev-python/hypothesis/hypothesis-6.79.0.ebuild
new file mode 100644
index 000000000000..e338c8f52ddf
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.79.0.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" python3_12 pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/requests-toolbelt-0.10.1
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,pytest_forked,_hypothesis_pytestplugin
+
+ # NB: paths need to be relative to pytest.ini,
+ # i.e. start with hypothesis-python/
+ local EPYTEST_IGNORE=()
+ local EPYTEST_DESELECT=(
+ # these tests can randomly fail with RecursionError when run
+ # in parallel
+ # https://github.com/HypothesisWorks/hypothesis/issues/3671
+ hypothesis-python/tests/cover/test_lookup.py::test_resolving_mutually_recursive_types
+ hypothesis-python/tests/cover/test_lookup.py::test_resolving_mutually_recursive_types_with_defaults
+ )
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # failing due to warnings from numpy/cython
+ hypothesis-python/tests/pytest/test_fixtures.py::test_given_plus_overridden_fixture
+ )
+ ;;
+ python3.12)
+ EPYTEST_DESELECT+=(
+ hypothesis-python/tests/cover/test_lookup.py
+ hypothesis-python/tests/cover/test_type_lookup.py
+ hypothesis-python/tests/cover/test_type_lookup_forward_ref.py
+ )
+ ;;
+ esac
+
+ epytest -o filterwarnings= -n "$(makeopts_jobs)" \
+ tests/cover tests/pytest tests/quality
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}