summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-02-21 05:24:28 +0100
committerMichał Górny <mgorny@gentoo.org>2025-02-21 06:19:48 +0100
commit8eecf6b87f6359f7ea7f5da66be7e972e684ac02 (patch)
tree4e0d89e99a659199fd1044709be8b73ccd203f1e
parentdev-python/botocore: Bump to 1.36.25 (diff)
downloadgentoo-8eecf6b87f6359f7ea7f5da66be7e972e684ac02.tar.gz
gentoo-8eecf6b87f6359f7ea7f5da66be7e972e684ac02.tar.bz2
gentoo-8eecf6b87f6359f7ea7f5da66be7e972e684ac02.zip
dev-python/trimesh: Bump to 4.6.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/trimesh/Manifest1
-rw-r--r--dev-python/trimesh/trimesh-4.6.3.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/trimesh/Manifest b/dev-python/trimesh/Manifest
index 8d55d771a3a0..bae1f6fe28c2 100644
--- a/dev-python/trimesh/Manifest
+++ b/dev-python/trimesh/Manifest
@@ -2,3 +2,4 @@ DIST trimesh-4.5.3.gh.tar.gz 13618342 BLAKE2B 1bb74c872a09d928b9ccd4b098377f584e
DIST trimesh-4.6.0.gh.tar.gz 13621454 BLAKE2B 520d7be8479c3490dc5125c75ae91887ab499a7af82a7b4ef1568d2ff89ec78f40d2a06f4ad2f7176e9233ca1d6bf209cb64225f44642f93ec0fea4a317e9cb9 SHA512 afb430a939cba17b36d07c6b6eb1acae6aafc388ac636b76dacb8053069f929a60f0d4be56f706786d3853123f3fb361a4550c9cabdbf46aa7d07c7eea956d64
DIST trimesh-4.6.1.gh.tar.gz 13621428 BLAKE2B 2fc457ff32cfb69c93f0640c0f1a08cf801008c3804485dba1cdff8496cf4f5583223fe6c0b1099d3e75527f5ef5df2c8cbadce7cacecb878988c7d973d66bf8 SHA512 1adebab15a08324e4e6585aa2a1cd788439176c4c938a6507bb17eff1bafbb81d86f9be1fb7d7fc2274496b22ff94a47ebae050fc6c8a811cdebb7f68c008653
DIST trimesh-4.6.2.gh.tar.gz 13621607 BLAKE2B 796f06f9bd43779a6a7a9dea97ec6c62714a4dd1a9151afd37f638d715097b60c47f59f7b253cef355219359279c89f6d70b8e50b62c4746aedae77545cc0b13 SHA512 450d07e19af342f5676a33dd6594c360d6761eb19310c60c9c89bce0eaa0dc032c2a3c1503883baa9889d0c1e53a6738af0655df3ebe95bd7e62c2f9615921bf
+DIST trimesh-4.6.3.gh.tar.gz 13622877 BLAKE2B 156424ebfe41fee80fc67ed099e17e72c83d86912056b6ec0ac0fba336109eede793dd998e4133d3df3903f7426f6b5fb05db7a4ed9cde554a9e57c3e300984c SHA512 b5e614e8846b9534af545aa1d8e9ba5f5c694e0c86ef46a7f40fcd186cc6d36a52d3fcae8313b021a38a74eacc21e41189f6dbfce7397a2d5abd94b7b5ec8c3a
diff --git a/dev-python/trimesh/trimesh-4.6.3.ebuild b/dev-python/trimesh/trimesh-4.6.3.ebuild
new file mode 100644
index 000000000000..252b04a9f06e
--- /dev/null
+++ b/dev-python/trimesh/trimesh-4.6.3.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for loading and using triangular meshes"
+HOMEPAGE="
+ https://trimesh.org/
+ https://github.com/mikedh/trimesh/
+ https://pypi.org/project/trimesh/
+"
+SRC_URI="
+ https://github.com/mikedh/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/charset-normalizer[${PYTHON_USEDEP}]
+ dev-python/colorlog[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.20[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycollada[${PYTHON_USEDEP}]
+ dev-python/pyglet[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ >=dev-python/shapely-1.8.2[${PYTHON_USEDEP}]
+ dev-python/svg-path[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ dev-python/xxhash[${PYTHON_USEDEP}]
+ dev-python/rtree[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mapbox-earcut[${PYTHON_USEDEP}]
+ dev-python/pillow[webp,${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_TIMEOUT=1800
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires manifold3d
+ tests/test_boolean.py::test_multiple_difference
+ # timing nonsense
+ tests/test_bounds.py::BoundsTest::test_obb_mesh_large
+ )
+ local EPYTEST_IGNORE=(
+ # require pyinstrument
+ tests/test_sweep.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+pkg_postinst() {
+ optfeature_header "${PN} functionality can be extended by installing the following packages:"
+ optfeature "making GUI applications with 3D stuff" dev-python/glooey
+ optfeature "2D triangulations of polygons" dev-python/mapbox-earcut
+ optfeature "loading a number of additional mesh formats" dev-python/meshio
+ optfeature "figuring out how much memory we have" dev-python/psutil
+ optfeature "marching cubes and other nice stuff" dev-python/scikit-image
+}