summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-24 06:00:54 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-24 07:14:02 +0200
commit8f7abdfa0805ec280dd75f6ee48a33dcc645f68c (patch)
tree9508e3128b7fe108a7862058dfe50b1cf28770a8
parentdev-python/pdm-pep517: Bump to 1.0.5 (diff)
downloadgentoo-8f7abdfa0805ec280dd75f6ee48a33dcc645f68c.tar.gz
gentoo-8f7abdfa0805ec280dd75f6ee48a33dcc645f68c.tar.bz2
gentoo-8f7abdfa0805ec280dd75f6ee48a33dcc645f68c.zip
dev-python/zipp: Bump to 3.10.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/zipp/Manifest1
-rw-r--r--dev-python/zipp/zipp-3.10.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/zipp/Manifest b/dev-python/zipp/Manifest
index da1c719f605a..471f5346ddf2 100644
--- a/dev-python/zipp/Manifest
+++ b/dev-python/zipp/Manifest
@@ -1,2 +1,3 @@
+DIST zipp-3.10.0.tar.gz 15564 BLAKE2B 145374d6e2e251f588e198a0fd400542b34ff26de4e1240dd30710dc33e884ccde91ca1cc168d5f421aa4e04341c76cfb10fbf176c830ade237be39a886267ab SHA512 2e64b05eb0123eb3c3c87fbfe2da26721eb9e24142a43e794d04e5f86ab5fe4cf3e0e3e3497bfc9631ab61dd64226829772493f26e091a66148ddbdc5dfd8e51
DIST zipp-3.8.1.tar.gz 14189 BLAKE2B 768d25dab70ee1ddbb3adb829b68515631772e2e25a7617d58bf863c01d1900e22cd4001bf31b9eae3829a63cba77df070132e7932b9b4242bb8be3579a1546d SHA512 05639feb20c7e8d3480ce17a52115a85bb2f0706ee0c1b15589b7556bb914ef30a1a34fa743217694b753bb5e72095c90fab7dfee85f2dbf461347322acb4d2e
DIST zipp-3.9.0.tar.gz 15118 BLAKE2B 04cfd994179ea2f09e792c3b95726262ec5f9e4b04bebb2541066bc914c39c93fda74cd597a53456afabdfa7ef90c1477cfc7c392bf59d3b31959c1d299dcaec SHA512 eaff85ab7e0775bc091b4e32281397bd8fa92d1644b368593f18a04c1a408937351606ad9cc2831cd3bce61ca59b05e7622e5d14282bc28299943ef5dd9012f9
diff --git a/dev-python/zipp/zipp-3.10.0.ebuild b/dev-python/zipp/zipp-3.10.0.ebuild
new file mode 100644
index 000000000000..652dbc5d71c5
--- /dev/null
+++ b/dev-python/zipp/zipp-3.10.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Backport of pathlib-compatible object wrapper for zip files"
+HOMEPAGE="https://github.com/jaraco/zipp/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+BDEPEND="
+ test? (
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+ dev-python/jaraco-itertools[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # speed tests are flaky by design
+ tests/test_zipp.py::TestPath::test_implied_dirs_performance
+)
+
+src_prepare() {
+ # dep of disabled test
+ sed -i -e '/func_timeout/d' tests/test_zipp.py || die
+ distutils-r1_src_prepare
+}
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "zipp"
+ version = "${PV}"
+ description = "Backport of pathlib-compatible object wrapper for zip files"
+ EOF
+}