summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2024-04-21 14:22:42 -0500
committerMatthias Maier <tamiko@gentoo.org>2024-04-21 14:39:02 -0500
commit93cd316326799364114de340bb649b113011f699 (patch)
tree374fc4a3a8ab68b66d384830eb9c992535a9bbe0
parentmedia-gfx/fotocx: stabilize 24.21-r1 for amd64, x86 (diff)
downloadgentoo-93cd316326799364114de340bb649b113011f699.tar.gz
gentoo-93cd316326799364114de340bb649b113011f699.tar.bz2
gentoo-93cd316326799364114de340bb649b113011f699.zip
dev-util/debootstrap: add 1.0.134, add myself as maintainer
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
-rw-r--r--dev-util/debootstrap/Manifest1
-rw-r--r--dev-util/debootstrap/debootstrap-1.0.134.ebuild51
-rw-r--r--dev-util/debootstrap/metadata.xml5
3 files changed, 56 insertions, 1 deletions
diff --git a/dev-util/debootstrap/Manifest b/dev-util/debootstrap/Manifest
index e09cbce6293b..ab4008243e2b 100644
--- a/dev-util/debootstrap/Manifest
+++ b/dev-util/debootstrap/Manifest
@@ -1,3 +1,4 @@
DIST debootstrap-1.0.128+nmu2.tar.bz2 70406 BLAKE2B 7ba8f2cb63da3217594e9b058e1b0b4452823d9daeaaff0f91a298bd9d29ec16b332eda03259a12a9259dc759f63f1123654454341eb32f6fd882def0f3e4582 SHA512 a8baa7df3956d407c1b9344a0f0acb8162d951b55c3f402f7f04d8b652e00a366fd0e8be8fb4ecfd3997d6374c0271a329ccc631b32958a2296c73e389d622d3
+DIST debootstrap-1.0.134.tar.bz2 76120 BLAKE2B ce885d57a9c98864ea045dd3151553b57f6d9feadaba41df063f8f9056a7d1294ade2ac32374bc59cbfcae5993956bb68cb19759a109520419b8e1134563fddc SHA512 e7b9726632d3816975c8cbd0020882f69db6d2a84f6c2d086a4e002c58afa61f8b08a8a35b40dd6a284e2cdb584817292462e5dc354fb83d177d50a56aa8cda6
DIST debootstrap_1.0.123.tar.gz 78175 BLAKE2B e507ee76817eef20cfea4e37eaf893f8e64acaa791806ebd55bec97b8e60eb3c59b68bfe5e6023dc6e73706bde2468db46b84f0176ec46d086c3ea9423a206c7 SHA512 3b23f61528d4993750ba22b8765c10cfb9695793177017d9e4faf546da076be6660c5d6e0d1bf30bafe14f6d70f886190d3ec42a0057b895f40e860475eea794
DIST devices.tar.gz 47835 BLAKE2B 03bfe097fda12a7a0aa19d3308c0d44382ad945defea05a63b17a72e4051ef94f0e60e75bde35baeace81da59d9f04126f6e463163609475b9c0fdf518f533ef SHA512 994ec8d72e3d52d2d872f7ff0da2336e4cbd3a5fa73bb6cdb9e06f5e7f5b8c69cea639c738fdba1186f382d6dcf62e7746fface664bfbd744aac24b16f034432
diff --git a/dev-util/debootstrap/debootstrap-1.0.134.ebuild b/dev-util/debootstrap/debootstrap-1.0.134.ebuild
new file mode 100644
index 000000000000..f3548f563311
--- /dev/null
+++ b/dev-util/debootstrap/debootstrap-1.0.134.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV="${PV/_p/+nmu}"
+
+DESCRIPTION="Debian/Ubuntu bootstrap scripts"
+HOMEPAGE="https://packages.qa.debian.org/d/debootstrap.html"
+SRC_URI="https://salsa.debian.org/installer-team/${PN}/-/archive/${MY_PV}/${PN}-${MY_PV}.tar.bz2
+ mirror://gentoo/devices.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ app-arch/dpkg
+ net-misc/wget
+ sys-devel/binutils
+"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_unpack() {
+ unpack "${PN}-${MY_PV}".tar.bz2
+ cp "${DISTDIR}"/devices.tar.gz "${S}" || die
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ local DOCS=( TODO debian/changelog )
+ default
+ doman debootstrap.8
+}
+
+pkg_postinst() {
+ if ! has_version ${CATEGORY}/${PN} && ! has_version app-crypt/gnupg; then
+ elog "To check Release files against a keyring (--keyring=K), please"
+ elog "install app-crypt/gnupg"
+ fi
+
+ if ! has_version app-crypt/debian-archive-keyring || ! has_version app-crypt/ubuntu-keyring; then
+ elog "To check Release files from Debian or Ubuntu, please install"
+ elog " app-crypt/debian-archive-keyring or"
+ elog " app-crypt/ubuntu-keyring as required"
+ fi
+}
diff --git a/dev-util/debootstrap/metadata.xml b/dev-util/debootstrap/metadata.xml
index 115e9d64a669..41492a48020d 100644
--- a/dev-util/debootstrap/metadata.xml
+++ b/dev-util/debootstrap/metadata.xml
@@ -1,5 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>tamiko@gentoo.org</email>
+ <name>Matthias Maier</name>
+ </maintainer>
</pkgmetadata>