summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-15 12:04:23 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-15 12:16:00 +0100
commit99339ecf489e4482a4da3cc85d4db238dacfb365 (patch)
tree54935a5c5abf663b22bc1de9afa1a6dc5827e822
parentdev-python/botocore: Stabilize 1.34.1 ALLARCHES, #920014 (diff)
downloadgentoo-99339ecf489e4482a4da3cc85d4db238dacfb365.tar.gz
gentoo-99339ecf489e4482a4da3cc85d4db238dacfb365.tar.bz2
gentoo-99339ecf489e4482a4da3cc85d4db238dacfb365.zip
dev-python/pyproject-fmt: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyproject-fmt/Manifest2
-rw-r--r--dev-python/pyproject-fmt/pyproject-fmt-1.5.1.ebuild42
-rw-r--r--dev-python/pyproject-fmt/pyproject-fmt-1.5.2.ebuild42
3 files changed, 0 insertions, 86 deletions
diff --git a/dev-python/pyproject-fmt/Manifest b/dev-python/pyproject-fmt/Manifest
index 5c86aaf3dd4e..86ea74b1ed05 100644
--- a/dev-python/pyproject-fmt/Manifest
+++ b/dev-python/pyproject-fmt/Manifest
@@ -1,3 +1 @@
-DIST pyproject_fmt-1.5.1.tar.gz 15639 BLAKE2B b625504295fce9fee9cfb09c821654edad8aa8e0537777f268f759ed8aeb6d2dd49e00b63c0e35e1d2a6946702c025ed5c15282ca8d2de5f479d373720273eef SHA512 12c3734ed2fab66f01c9cd2f5335cb4f925657f7c1f2cb8f7a3f9fdc73ec0746dd6b634cc1799b4dc4760d5b8061b4b30a06ae7030f94494792070674a2da338
-DIST pyproject_fmt-1.5.2.tar.gz 15649 BLAKE2B 0765d072f0effbe805197e8c0ca082d8eb252ae2ea0d8965787eb746195f9420a2ce8c781b54c6e8300a3a3f5208f621aebea84623ecdf0ee6e7f9ce7a01ed35 SHA512 75c703cf05290cb3ee61bac581bf99100db7d8468f2a51c4a7d30ce572eeb13dbec61a87ff8eaedd07754b4eb4bdfa5f3565d96fcae8dc2187cd7dbf7225e6ab
DIST pyproject_fmt-1.5.3.tar.gz 15678 BLAKE2B 624cfc0e62285c59fdb1a3315d1f419cbb8c41430957b9a5eeed2521899a66fa15a1aae476d2986e18d990e4f5fc901312a70df819765cf8b4e077cf3678d8dc SHA512 3f269525b5e3e818cea5ef7b90644c7ced9e37a1dff4a514782ebf7769f6f5a53887cb831b488ed34d059f197a9d90fccc887146f5180c58c5a702c37ae9d79b
diff --git a/dev-python/pyproject-fmt/pyproject-fmt-1.5.1.ebuild b/dev-python/pyproject-fmt/pyproject-fmt-1.5.1.ebuild
deleted file mode 100644
index f2bb62da24c8..000000000000
--- a/dev-python/pyproject-fmt/pyproject-fmt-1.5.1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Format your pyproject.toml file"
-HOMEPAGE="
- https://github.com/tox-dev/pyproject-fmt/
- https://pypi.org/project/pyproject-fmt/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- dev-python/natsort[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/tomlkit[${PYTHON_USEDEP}]
-"
-# tox is called as a subprocess, to get targets from tox.ini
-BDEPEND="
- dev-python/hatch-vcs[${PYTHON_USEDEP}]
- test? (
- >=dev-python/pytest-mock-3.10[${PYTHON_USEDEP}]
- dev-python/tox
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # upstream lower bounds are completely meaningless and copying them
- # to the ebuild is a horrible waste of time
- sed -i -e 's:>=[0-9.]*::' pyproject.toml || die
- distutils-r1_src_prepare
-}
diff --git a/dev-python/pyproject-fmt/pyproject-fmt-1.5.2.ebuild b/dev-python/pyproject-fmt/pyproject-fmt-1.5.2.ebuild
deleted file mode 100644
index c440d098979a..000000000000
--- a/dev-python/pyproject-fmt/pyproject-fmt-1.5.2.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Format your pyproject.toml file"
-HOMEPAGE="
- https://github.com/tox-dev/pyproject-fmt/
- https://pypi.org/project/pyproject-fmt/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-RDEPEND="
- dev-python/natsort[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/tomlkit[${PYTHON_USEDEP}]
-"
-# tox is called as a subprocess, to get targets from tox.ini
-BDEPEND="
- dev-python/hatch-vcs[${PYTHON_USEDEP}]
- test? (
- >=dev-python/pytest-mock-3.10[${PYTHON_USEDEP}]
- dev-python/tox
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # upstream lower bounds are completely meaningless and copying them
- # to the ebuild is a horrible waste of time
- sed -i -e 's:>=[0-9.]*::' pyproject.toml || die
- distutils-r1_src_prepare
-}