summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-06-13 17:36:52 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-06-13 18:49:05 +0200
commita471bb9c98950cba36dcc2ab0ddd67bc05c78556 (patch)
treed9ff9de0929be831f9f200d14477d4118b754cf2
parentkde-apps/konqueror: 24.05.1 version bump (diff)
downloadgentoo-a471bb9c98950cba36dcc2ab0ddd67bc05c78556.tar.gz
gentoo-a471bb9c98950cba36dcc2ab0ddd67bc05c78556.tar.bz2
gentoo-a471bb9c98950cba36dcc2ab0ddd67bc05c78556.zip
www-client/falkon: 24.05.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--www-client/falkon/Manifest1
-rw-r--r--www-client/falkon/falkon-24.05.1.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/www-client/falkon/Manifest b/www-client/falkon/Manifest
index 5bc10d053422..cbdd01dd0b49 100644
--- a/www-client/falkon/Manifest
+++ b/www-client/falkon/Manifest
@@ -1,2 +1,3 @@
DIST falkon-23.08.5.tar.xz 2574364 BLAKE2B 9090263ee1e9a76cf9efebf6f3c8b5d0ca25a907f467ebe5adff6d54e71c79aa982317094ea354fb4fa898244b119b73640fc92ae301f95fe78551d3e84921a9 SHA512 215e2a4ff551aa6d3fab0317d2b2b823b7fee4c1f6a653118d00f3def9ebb037931e8cd81f33785a44c8aa8910e00fbda884c1cfcdb61190544d1e6c8396acf8
DIST falkon-24.05.0.tar.xz 2584448 BLAKE2B 018824b140c49651140996d9c9a0ffe5a4b3e77e661c0aecc96168c8ed28742e91ddea42002320229b212883bf6065599870bec9cda03d0ad5b008cabd57d724 SHA512 e8a3b93d07bb99d663acb9633bd5d3815eacf3e928439ebdb3570c9fcd0a04d5ef945f0af1f9d008b6998dd76fab723f0277c42a3e0733bc855099b982bd8fe1
+DIST falkon-24.05.1.tar.xz 2584592 BLAKE2B 733f30eb6d5cb55162ef43a9e9be12d758c78a9e9c47f91cd23f616b7a2652166947b9345d6cf524833f4e50efb2875713e36d8f557d6dba4ab3333fcc4d1e91 SHA512 afdcd974682a66191de5873b6ae25ae688f6e8140238b80b6656b2120e4372469c1deaaae2a43ff1db82db3f88daa57e2148a61e4a920a4f25762e3fe8537a43
diff --git a/www-client/falkon/falkon-24.05.1.ebuild b/www-client/falkon/falkon-24.05.1.ebuild
new file mode 100644
index 000000000000..56a8d85989af
--- /dev/null
+++ b/www-client/falkon/falkon-24.05.1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="true"
+KFMIN=6.3.0
+QTMIN=6.6.2
+PYTHON_COMPAT=( python3_{10..12} )
+inherit ecm gear.kde.org python-single-r1
+
+DESCRIPTION="Cross-platform web browser using QtWebEngine"
+HOMEPAGE="https://www.falkon.org/ https://apps.kde.org/falkon/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="dbus kde python +X"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="test" # bug 653046
+
+COMMON_DEPEND="
+ dev-libs/openssl:0=
+ >=dev-qt/qt5compat-${QTMIN}:6
+ >=dev-qt/qtbase-${QTMIN}:6[dbus?,gui,network,sql,sqlite,ssl,widgets]
+ >=dev-qt/qtdeclarative-${QTMIN}:6[widgets]
+ >=dev-qt/qtwebchannel-${QTMIN}:6
+ >=dev-qt/qtwebengine-${QTMIN}:6=[widgets]
+ >=kde-frameworks/karchive-${KFMIN}:6
+ virtual/libintl
+ kde? (
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kcrash-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/kjobwidgets-${KFMIN}:6
+ >=kde-frameworks/kwallet-${KFMIN}:6
+ >=kde-frameworks/purpose-${KFMIN}:6
+ )
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep "
+ >=dev-python/pyside6-${QTMIN}[designer,gui,webengine,widgets,\${PYTHON_USEDEP}] \
+ >=dev-python/shiboken6-${QTMIN}[\${PYTHON_USEDEP}]
+ ")
+ )
+ X? (
+ x11-libs/libxcb:=
+ x11-libs/xcb-util
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-qt/qtbase-${QTMIN}:6[concurrent]
+"
+if [[ ${KDE_BUILD_TYPE} != live ]]; then
+ DEPEND+=" >=kde-frameworks/ki18n-${KFMIN}:6"
+fi
+RDEPEND="${COMMON_DEPEND}
+ >=dev-qt/qtsvg-${QTMIN}:6
+"
+BDEPEND=">=dev-qt/qttools-${QTMIN}:6[linguist]"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+ ecm_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_KEYRING=OFF
+ -DDISABLE_DBUS=$(usex !dbus)
+ $(cmake_use_find_package kde KF6Wallet)
+ $(cmake_use_find_package kde KF6KIO)
+ -DBUILD_PYTHON_SUPPORT=$(usex python)
+ -DNO_X11=$(usex !X)
+ )
+ use python && mycmakeargs+=(
+ -DPYTHON_CONFIG_SUFFIX="-${EPYTHON}" # shiboken_helpers.cmake quirk
+ -DPython3_INCLUDE_DIR=$(python_get_includedir)
+ -DPython3_LIBRARY=$(python_get_library_path)
+ )
+ ecm_src_configure
+}