summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-21 08:41:35 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-21 09:40:59 +0200
commitab2b5f4b48208105bac1510fb73503ff471fa13b (patch)
treed3eedcfb68cb0505749e0f3846c97e1fbc5e9fb5
parentdev-python/sybil: Bump to 8.0.0 (diff)
downloadgentoo-ab2b5f4b48208105bac1510fb73503ff471fa13b.tar.gz
gentoo-ab2b5f4b48208105bac1510fb73503ff471fa13b.tar.bz2
gentoo-ab2b5f4b48208105bac1510fb73503ff471fa13b.zip
dev-python/pytest-httpx: Bump to 0.31.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-httpx/Manifest1
-rw-r--r--dev-python/pytest-httpx/pytest-httpx-0.31.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pytest-httpx/Manifest b/dev-python/pytest-httpx/Manifest
index 2e4787fb9cd0..0444f922d6f1 100644
--- a/dev-python/pytest-httpx/Manifest
+++ b/dev-python/pytest-httpx/Manifest
@@ -1 +1,2 @@
DIST pytest-httpx-0.30.0.tar.gz 36959 BLAKE2B b56f0e51558ffa6eb0c0af61aa3633a8e358f8c78916d101f1de853f683136a68e195bf0af099bbc6766198b4136a560ffd2676d9a49f0b350882896a61d935a SHA512 6aadb544bda5003156bf9c0fa309a166636dc87aea033d9a48ee10e1e8b77e6cb52350930e97cab89cff7c10111d5e26d1d74cd33f0a6c54e34c3fb7ef72ea05
+DIST pytest_httpx-0.31.0.tar.gz 38352 BLAKE2B 0e9ad5507ad4fe209dcf6a0b0077b0a16eb534fd3c6abe0f2e89f8b1bdc4761274e200ed8497da6df89778cccbea4af6ed06ca5fa61ba4cdd9b1164d540a09be SHA512 4c2fa27b0a6f4677dd237bd10661e668c1cb587ffa8196c715a4a66d85c47007813687b27afc217a6e20deb2b5ab013fa4b43bfe41590b6b17fdd85370aee34a
diff --git a/dev-python/pytest-httpx/pytest-httpx-0.31.0.ebuild b/dev-python/pytest-httpx/pytest-httpx-0.31.0.ebuild
new file mode 100644
index 000000000000..eab60d4c7025
--- /dev/null
+++ b/dev-python/pytest-httpx/pytest-httpx-0.31.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Send responses to HTTPX using pytest"
+HOMEPAGE="
+ https://colin-b.github.io/pytest_httpx/
+ https://github.com/Colin-b/pytest_httpx/
+ https://pypi.org/project/pytest-httpx/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ =dev-python/httpx-0.27*[${PYTHON_USEDEP}]
+ =dev-python/pytest-8*[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest