summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-01 16:16:57 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-01 16:44:20 +0200
commitae8b818f4e783c967ecad84ed49e86b80659bbb9 (patch)
tree2be9d20686a3abd6467c16a26a20e330254fdccf
parentwww-apps/sonarr-bin: drop 4.0.2.1408 (diff)
downloadgentoo-ae8b818f4e783c967ecad84ed49e86b80659bbb9.tar.gz
gentoo-ae8b818f4e783c967ecad84ed49e86b80659bbb9.tar.bz2
gentoo-ae8b818f4e783c967ecad84ed49e86b80659bbb9.zip
dev-python/attrs: Fix test failure with pytest-8
Closes: https://bugs.gentoo.org/928357 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/attrs/attrs-23.2.0.ebuild5
-rw-r--r--dev-python/attrs/files/attrs-23.2.0-pytest-8.patch44
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/attrs/attrs-23.2.0.ebuild b/dev-python/attrs/attrs-23.2.0.ebuild
index a0aa7acc3ff7..5c18c763b029 100644
--- a/dev-python/attrs/attrs-23.2.0.ebuild
+++ b/dev-python/attrs/attrs-23.2.0.ebuild
@@ -33,3 +33,8 @@ BDEPEND="
"
distutils_enable_tests pytest
+
+PATCHES=(
+ # https://github.com/python-attrs/attrs/pull/1249
+ "${FILESDIR}/${P}-pytest-8.patch"
+)
diff --git a/dev-python/attrs/files/attrs-23.2.0-pytest-8.patch b/dev-python/attrs/files/attrs-23.2.0-pytest-8.patch
new file mode 100644
index 000000000000..68e4c86c1315
--- /dev/null
+++ b/dev-python/attrs/files/attrs-23.2.0-pytest-8.patch
@@ -0,0 +1,44 @@
+From b9084fab02c009a593b604562a69f36a5915c8e5 Mon Sep 17 00:00:00 2001
+From: Denis Laxalde <denis@laxalde.org>
+Date: Sat, 2 Mar 2024 07:40:36 +0100
+Subject: [PATCH] Remove pytest.deprecated_call() in TestAssoc::test_unknown
+ (#1249)
+
+assoc() no longer raises a deprecation warning since commit
+22ae8473fb88d6e585b05c709e81e1a46398a649 but the 'with
+pytest.deprecated_call():' in that test was not removed then (in
+contrast with other test cases).
+
+Maybe this got unnoticed due to a pytest bug?
+In any case, using pytest 8+ (and keeping deprecated_call()) shows that
+no warning is raised and the test fails.
+
+Removing the upper bound on pytest in dev dependencies as tests now
+pass with pytest 8.0.
+
+Fix #1233.
+
+Co-authored-by: Hynek Schlawack <hs@ox.cx>
+---
+ pyproject.toml | 3 +--
+ tests/test_funcs.py | 4 +---
+ 2 files changed, 2 insertions(+), 5 deletions(-)
+
+diff --git a/tests/test_funcs.py b/tests/test_funcs.py
+index 044aaab..398ba35 100644
+--- a/tests/test_funcs.py
++++ b/tests/test_funcs.py
+@@ -600,9 +600,7 @@ class TestAssoc:
+ AttrsAttributeNotFoundError.
+ """
+ # No generated class will have a four letter attribute.
+- with pytest.raises(
+- AttrsAttributeNotFoundError
+- ) as e, pytest.deprecated_call():
++ with pytest.raises(AttrsAttributeNotFoundError) as e:
+ assoc(C(), aaaa=2)
+
+ assert (f"aaaa is not an attrs attribute on {C!r}.",) == e.value.args
+--
+2.44.0
+