summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-05 05:25:06 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-05 05:25:06 +0100
commitbbf8fb9500c4d4cbf89161675527df0f127f20ba (patch)
tree9d060b89d03384b88fc03fa9f39f5f7ad0d94321
parentdev-python/botocore: Bump to 1.35.76 (diff)
downloadgentoo-bbf8fb9500c4d4cbf89161675527df0f127f20ba.tar.gz
gentoo-bbf8fb9500c4d4cbf89161675527df0f127f20ba.tar.bz2
gentoo-bbf8fb9500c4d4cbf89161675527df0f127f20ba.zip
dev-python/boto3: Bump to 1.35.76
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.35.76.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 918f398ebefc..c40dc757aa62 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -3,3 +3,4 @@ DIST boto3-1.35.68.gh.tar.gz 901189 BLAKE2B f7449998af169c873319d7b8748035db72c3
DIST boto3-1.35.71.gh.tar.gz 903019 BLAKE2B 48bf56c54a8eaa52c1850078a92cef7e5acb06f2d9d551414d640c6f5c5f381f2edc4ae6f582d9c1578f68d78a272142033bd41caba95577af917a492e995edb SHA512 56df8d30c0d3efc71caa6d629354e1311d944c71b5568b4154fc93c315558d600e4411ccc80abca98cb4a3adf3a3ab4f4dbce22ca06184e11d720f36f33b58d2
DIST boto3-1.35.72.gh.tar.gz 906195 BLAKE2B 42fa9727d0d35eaa2ea61580538923da30d57e2569dd2ff0b75a2f19ee29b0e5745e93724bf5145296794ee2ee51f3abe1bad017435e68ce9f12c61ccfd3bdf7 SHA512 c54bd53eb6c7753a310dfa26fa9080d5331b0e5ca4cc87c32265f045a615b406e2ace93e41301c6039108ea5be4aa5fd826b875b63253ca4b8c2f8c5892f7bcd
DIST boto3-1.35.74.gh.tar.gz 908732 BLAKE2B e8e25f5a349956ebe12e80e3170b6cfb97e1e4ea166877f349191667098ae42775d2d37158470d90c41844f3ff2ddd37f40a533c7b18bc2a46dc5d21a14dc986 SHA512 86311657423cc06004268e66750037d0ea91518db156ed7712397afa66c701350b96c5ad32ead49936231e9e196a686dcaefbec8a90b5168450977ed77532486
+DIST boto3-1.35.76.gh.tar.gz 910113 BLAKE2B 3e7429976b348e29ba4184bffe03c643b85dd978cc520b924263e8430b5e5935b95152cced2f6c0807c65de4e6e1405c55bb24565ac5bc425292e9adac178c03 SHA512 132f37e77b7b36d525e9cf678fe2f624eed77a9eb9fa8e7d7f079a362e5d7a5f3edcd17c7d8bc1e27570171927d26e74a94d267a1b0cbddda3890ac6a0f21cdc
diff --git a/dev-python/boto3/boto3-1.35.76.ebuild b/dev-python/boto3/boto3-1.35.76.ebuild
new file mode 100644
index 000000000000..8cba6d95740e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.35.76.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}