summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-04-16 18:05:57 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-04-16 18:36:14 +0300
commite2631d8523872f7a568d8f368db704e837f214fd (patch)
tree77f2d37a89b6ce6aef401d7e95950a0fd5350c22
parentapp-admin/awscli: add 1.22.97 (diff)
downloadgentoo-e2631d8523872f7a568d8f368db704e837f214fd.tar.gz
gentoo-e2631d8523872f7a568d8f368db704e837f214fd.tar.bz2
gentoo-e2631d8523872f7a568d8f368db704e837f214fd.zip
dev-python/boto3: add 1.21.42
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.21.42.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 2233c6fcaad1..26e7e8553120 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -7,3 +7,4 @@ DIST boto3-1.21.37.tar.gz 487557 BLAKE2B 1c716a07279ce2c1020faee9e2e81b2bde3ed6e
DIST boto3-1.21.38.tar.gz 487786 BLAKE2B c247f51e3a7a7f9c531ab18d0fa93b90881c869631bffe35be5482a463a6580e733915d4f966d5700cf6bd822676416e9431f261fd237cb9dd85440308399e2d SHA512 a1b09de7a1dbede4000d500d96028a9ae70c60aa0cc1fc74201d52bc76a83dc27937d422592985e22b3dd1b98359255e837f66f51bae59f2104b379bfa7e49b3
DIST boto3-1.21.39.tar.gz 488120 BLAKE2B 7fc998ec59d19fd6ea0377443920e30bcacdce5f185200757a13758e5e5229a7bbd959cd6854d9520f8ca6737af9f1adba887f3caef50fb7bbc9a2a38df9b472 SHA512 7c949773e0791d170158f7a8cc47559dcd9b2b6fbe422325b12b7d90649244e0475a6c35cfa15e00f1a0f49d2e581ba27d78320514e4ab8e8533bfb8510b37eb
DIST boto3-1.21.41.tar.gz 488529 BLAKE2B a07662e4499ea6e833ee7a207dbf84522369ae0609ee7ac305fb8afca572114a938a1c0a23d75404c86c6afc2a516148a565e9ff607898566beb9b552fa44c3e SHA512 620fea69e84de1c6e705a33b00ba137f8550e0590492e13ece24bdf8ba6439be58e31821404a6dded02873a69256568d5061bf9de19ab75c37630865dcf97373
+DIST boto3-1.21.42.tar.gz 488786 BLAKE2B eba75a62e2460aeb2ea66641fadb52448314e639af3d3ecb09f2ab48336bfdc78be868a5d710ba295732a65518eaef882a162df4d25cb8cb344aa27ab3f2ecbb SHA512 3ee8a299cad05e4317916286028608f3d289e6c2c3b04606dca8ede9ba7f3e8931321f33c91c40bd9c4aa15a2cab21245de5c26f6637139fa716149fbcac9c2c
diff --git a/dev-python/boto3/boto3-1.21.42.ebuild b/dev-python/boto3/boto3-1.21.42.ebuild
new file mode 100644
index 000000000000..6fcba460ab1d
--- /dev/null
+++ b/dev-python/boto3/boto3-1.21.42.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}