summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-20 18:23:22 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-20 19:41:04 +0200
commite39699197108fe943d04274f98d9c28e29c70ab1 (patch)
treec286be63cdb0d53cf6ad072546f64441d4b48e8e
parentdev-python/fonttools: Bump to 4.42.1 (diff)
downloadgentoo-e39699197108fe943d04274f98d9c28e29c70ab1.tar.gz
gentoo-e39699197108fe943d04274f98d9c28e29c70ab1.tar.bz2
gentoo-e39699197108fe943d04274f98d9c28e29c70ab1.zip
dev-python/xarray: Bump to 2023.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/xarray/Manifest1
-rw-r--r--dev-python/xarray/xarray-2023.8.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/xarray/Manifest b/dev-python/xarray/Manifest
index b08392caeaec..ba8b535769f3 100644
--- a/dev-python/xarray/Manifest
+++ b/dev-python/xarray/Manifest
@@ -1 +1,2 @@
DIST xarray-2023.7.0.tar.gz 3725483 BLAKE2B 814af19a4c24eb0179441d07bcd6165dee2ed5430a6fd94f4014387b7b7fd4ae250b64124bdda8ca411124ab2276075af65bde2a3ed3dc6d081dd466a485007e SHA512 88863770b22978ba681a2d970453ae087a234fcfb68f047b6020b39841a91207e8d92e01486d58bbeadac8d14608aa0c744ee9b6d54890f52fe3537b28292239
+DIST xarray-2023.8.0.tar.gz 3757528 BLAKE2B f94bcf90ee06273e82400f4786af97d5cf0db32ff4070929863d5072056fa4e0a33feaf3d378d9d67eed61f349df3ac96efcd1bb3b455043e01af0abf96bb6b3 SHA512 1d712e9fbf266906ac35c199eead77cec76ba5b4b4462140bef2fffd227a52d2cba9670a042cb669b0567320e9308bf81fe4e84c1cfcff234ad2332d72e895a3
diff --git a/dev-python/xarray/xarray-2023.8.0.ebuild b/dev-python/xarray/xarray-2023.8.0.ebuild
new file mode 100644
index 000000000000..6672e7602e28
--- /dev/null
+++ b/dev-python/xarray/xarray-2023.8.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing pypi
+
+DESCRIPTION="N-D labeled arrays and datasets in Python"
+HOMEPAGE="
+ https://xarray.pydata.org/
+ https://github.com/pydata/xarray/
+ https://pypi.org/project/xarray/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/numpy-1.22[${PYTHON_USEDEP}]
+ >=dev-python/pandas-1.4[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+"
+# note: most of the test dependencies are optional
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/bottleneck[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ !hppa? ( >=dev-python/scipy-1.4[${PYTHON_USEDEP}] )
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # warning-targeted tests are fragile and not important to end users
+ xarray/tests/test_backends.py::test_no_warning_from_dask_effective_get
+ # TODO: segv in netcdf4-python
+ 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-5-5]'
+ 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-5-None]'
+ 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-None-5]'
+ 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-None-None]'
+ xarray/tests/test_backends.py::TestDask::test_save_mfdataset_compute_false_roundtrip
+ # hangs
+ xarray/tests/test_backends.py::TestDask::test_dask_roundtrip
+)
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p xdist.plugin -n "$(makeopts_jobs)" --dist=worksteal
+}