summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-08 17:18:32 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-08 18:36:09 +0100
commitf0e06bad0002fcd8a46d756f32ba25e70525ce11 (patch)
treef5a51c69b99a5a0dfa786a59b1ed35ea8c87aeee
parentdev-python/textX: Bump to 3.1.0 (diff)
downloadgentoo-f0e06bad0002fcd8a46d756f32ba25e70525ce11.tar.gz
gentoo-f0e06bad0002fcd8a46d756f32ba25e70525ce11.tar.bz2
gentoo-f0e06bad0002fcd8a46d756f32ba25e70525ce11.zip
dev-python/trove-classifiers: Bump to 2023.2.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/trove-classifiers/Manifest1
-rw-r--r--dev-python/trove-classifiers/trove-classifiers-2023.2.8.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/trove-classifiers/Manifest b/dev-python/trove-classifiers/Manifest
index 719f44032698..9db925190690 100644
--- a/dev-python/trove-classifiers/Manifest
+++ b/dev-python/trove-classifiers/Manifest
@@ -1 +1,2 @@
DIST trove-classifiers-2023.1.20.gh.tar.gz 15075 BLAKE2B 04b5902c0318d495be8ef5f3602ae93d0a540f34382dd269202f4b0e6773d9c0adf023df9c45afece0ae27da8dad25d0018b602dc2a02e775c40ea73afb77195 SHA512 f99dee6f42ef3d1e42d0d1f520d882af2d430133a317de693464a526849bf6d9990307c189b5bacf2fa97c316d0c806ecfe9cfcd05a6734e79992763f597dfd2
+DIST trove-classifiers-2023.2.8.gh.tar.gz 15070 BLAKE2B 92af68e3d967d984f60e1aedf6a32b7b4bed777c9947091a054dce27448965ea0b2221d61277932cd2d6520f112fded1af9e29c21d5d0d1dcb4170febe082252 SHA512 b1f1e25bb4bb70b059ab6a4dd0b57bdeac7b69176ced4a7e847c8b449511eaf50b2f62efcc06ddea7605dee4dc7f987e6dce2f9f92a5912f60eb74dbb1e870db
diff --git a/dev-python/trove-classifiers/trove-classifiers-2023.2.8.ebuild b/dev-python/trove-classifiers/trove-classifiers-2023.2.8.ebuild
new file mode 100644
index 000000000000..850f0b5ffda7
--- /dev/null
+++ b/dev-python/trove-classifiers/trove-classifiers-2023.2.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Canonical source for classifiers on PyPI (pypi.org)"
+HOMEPAGE="
+ https://github.com/pypa/trove-classifiers/
+ https://pypi.org/project/trove-classifiers/
+"
+SRC_URI="
+ https://github.com/pypa/trove-classifiers/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-python/calver[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest
+ "${EPYTHON}" -m tests.lib || die
+}