summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-21 08:33:36 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-21 09:40:54 +0200
commitf88b22b2143e70652bbf4a29333b1b0fb6e3da4f (patch)
treedfd7de4aa50d2db35b26c18d65751ef4f933bb75
parentdev-python/python-gnupg: Bump to 0.5.3 (diff)
downloadgentoo-f88b22b2143e70652bbf4a29333b1b0fb6e3da4f.tar.gz
gentoo-f88b22b2143e70652bbf4a29333b1b0fb6e3da4f.tar.bz2
gentoo-f88b22b2143e70652bbf4a29333b1b0fb6e3da4f.zip
dev-python/prometheus-client: Bump to 0.21.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/prometheus-client/Manifest1
-rw-r--r--dev-python/prometheus-client/prometheus-client-0.21.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/prometheus-client/Manifest b/dev-python/prometheus-client/Manifest
index b65d331d0b7e..cbbecc195bf1 100644
--- a/dev-python/prometheus-client/Manifest
+++ b/dev-python/prometheus-client/Manifest
@@ -1 +1,2 @@
DIST prometheus_client-0.20.0.tar.gz 78278 BLAKE2B ae7dea79a2c4f7b6870da9f749e9be09c353e062e744beb98538eba45d0394ef2ce5b99a696e40620b38ea228711dff30a2a571d09d7e1b4a3d75ca713938f92 SHA512 9e5aed628b052790af8954eee7914b6480226368229bb0dade2f8c3f88ab04971d2a8a55558fd7dbb125894f30cea56363cc670deb0aa6822f31562437031fb2
+DIST prometheus_client-0.21.0.tar.gz 78634 BLAKE2B 878c6b3948ebb45fced9ceb24ef5ebb07b2538117712dc2b0a6365282fa1bd0e732f5c79bf496aa54386cc42ced458202b1537c6706e3906a6c48d71a3709437 SHA512 ad86e7d7eb1919bda77c5fe80e800721c6d93f8b849955903ec346c2c6d35130f7e179b470c261aba3d8aa2f2cb10c43dcc5e8c06024dcd79fac5818b87f76c5
diff --git a/dev-python/prometheus-client/prometheus-client-0.21.0.ebuild b/dev-python/prometheus-client/prometheus-client-0.21.0.ebuild
new file mode 100644
index 000000000000..7819cd833828
--- /dev/null
+++ b/dev-python/prometheus-client/prometheus-client-0.21.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python client for the Prometheus monitoring system"
+HOMEPAGE="
+ https://github.com/prometheus/client_python/
+ https://pypi.org/project/prometheus-client/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/twisted[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # optional tests, broken with >=dev-python/asgiref-3.8
+ tests/test_asgi.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}