summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2024-05-02 18:49:54 +0200
committerUlrich Müller <ulm@gentoo.org>2024-05-02 18:49:54 +0200
commitfc5d725ae78024a96b2ef780d769fb41e9977ed6 (patch)
tree9f047e9713e44155f25dd5931935e95177ea705e
parentsys-kernel/gentoo-sources: add 6.8.9, and KSPP updates and BMQ v6.8-r6 (diff)
downloadgentoo-fc5d725ae78024a96b2ef780d769fb41e9977ed6.tar.gz
gentoo-fc5d725ae78024a96b2ef780d769fb41e9977ed6.tar.bz2
gentoo-fc5d725ae78024a96b2ef780d769fb41e9977ed6.zip
app-admin/emacs-updater: add 1.18
Closes: https://bugs.gentoo.org/931064 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--app-admin/emacs-updater/Manifest1
-rw-r--r--app-admin/emacs-updater/emacs-updater-1.18.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-admin/emacs-updater/Manifest b/app-admin/emacs-updater/Manifest
index 64b82fca614e..b5a51c19c204 100644
--- a/app-admin/emacs-updater/Manifest
+++ b/app-admin/emacs-updater/Manifest
@@ -1 +1,2 @@
DIST emacs-updater-1.17.tar.xz 7236 BLAKE2B f39a19eba794cd57b25fbfc38998775a7818d98c81bbbdf485b33ed273815dfb3a74c26ca410f0e3b8e4bd46f2114b96155485cdcf87d5bec70a96dfe1a3a279 SHA512 461f496075bd7fc057290d40d408e5243ec464d8814abbe0c47c77a223b314ba2bcc35e20bf5e22e6dcee485a024ab93ced7155fa5212bc2d9c3b6362f168c52
+DIST emacs-updater-1.18.tar.xz 7360 BLAKE2B ff890584349d87a9cdcfe4576dd3bb1f8fc73b6cb086a5dd09fef3c8bf500a519f1aab810321680a5f5d4f1093455a6c54db42d900ee50fc39fcc03f0d6db69e SHA512 15c3b6e5ea7d1935a7e472d75409c0cb0dc9658142c1270a4a487eba822dbcd3ac32ffe60cb501859a7ccb7441efa1c7dd5d3a6cf481f69a583c5c8d5001051a
diff --git a/app-admin/emacs-updater/emacs-updater-1.18.ebuild b/app-admin/emacs-updater/emacs-updater-1.18.ebuild
new file mode 100644
index 000000000000..f9cebdcb57a7
--- /dev/null
+++ b/app-admin/emacs-updater/emacs-updater-1.18.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Rebuild Emacs packages"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Emacs"
+SRC_URI="https://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+DEPEND="|| ( sys-apps/util-linux app-misc/getopt )"
+RDEPEND="${DEPEND}
+ >=app-editors/emacs-23.1:*
+ >=app-portage/portage-utils-0.80"
+
+src_prepare() {
+ default
+
+ if ! has_version sys-apps/util-linux; then
+ # BSD ships a dumb getopt(1), so use getopt-long instead
+ sed -i -e '/^GETOPT=/s/getopt/&-long/' emacs-updater || die
+ fi
+
+ if [[ -n ${EPREFIX} ]]; then
+ sed -i -e "1s:/:${EPREFIX}/:" \
+ -e "s:^\([[:upper:]]*=\)/:\1${EPREFIX}/:" \
+ emacs-updater || die
+ fi
+}
+
+src_install() {
+ dosbin emacs-updater
+ doman emacs-updater.8
+}