summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Zander <negril.nx+gentoo@gmail.com>2024-04-29 18:04:08 +0200
committerSam James <sam@gentoo.org>2024-12-01 11:52:09 +0000
commita88993d40917dc6333f48cd9a579ff821708f80a (patch)
treea9be3a7ff2e3053b3d364d6be5cbe8de1ec51edc /acct-user
parentdev-libs/libsecp256k1: set build-machine toolchain environment (diff)
downloadgentoo-a88993d40917dc6333f48cd9a579ff821708f80a.tar.gz
gentoo-a88993d40917dc6333f48cd9a579ff821708f80a.tar.bz2
gentoo-a88993d40917dc6333f48cd9a579ff821708f80a.zip
acct-user/vdr: [QA] BannedEapiCommand
Add RDEPEND for IUSE Add REQUIRED_USE for remote Signed-off-by: Paul Zander <negril.nx+gentoo@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'acct-user')
-rw-r--r--acct-user/vdr/vdr-0-r3.ebuild (renamed from acct-user/vdr/vdr-0-r2.ebuild)26
1 files changed, 25 insertions, 1 deletions
diff --git a/acct-user/vdr/vdr-0-r2.ebuild b/acct-user/vdr/vdr-0-r3.ebuild
index 7c25955a8feb..98027c414841 100644
--- a/acct-user/vdr/vdr-0-r2.ebuild
+++ b/acct-user/vdr/vdr-0-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022-2023 Gentoo Authors
+# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -14,6 +14,30 @@ IUSE="graphlcd legacy-homedir remote serial systemd"
acct-user_add_deps
+REQUIRED_USE="
+ remote? ( systemd )
+"
+
+RDEPEND+="
+ graphlcd? (
+ acct-group/lp
+ acct-group/usb
+ )
+ remote? (
+ systemd? (
+ acct-group/input
+ )
+ )
+ serial? (
+ systemd? (
+ acct-group/dialout
+ )
+ !systemd? (
+ acct-group/uucp
+ )
+ )
+"
+
pkg_setup() {
# if user wants to preserve his existing vdr installation,
# he can set USE=legacy-homedir