summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-27 14:49:27 +0000
committerSam James <sam@gentoo.org>2021-03-27 15:34:43 +0000
commitfebb66dcd6c29d2ca72da37e5f5a82ec52480639 (patch)
treedca94a788b3a2afd1c0e19b8e36bb3891c31f1ff /app-admin/authbind
parentnet-firewall/xtables-addons: remove stable 2.13-r1 (diff)
downloadgentoo-febb66dcd6c29d2ca72da37e5f5a82ec52480639.tar.gz
gentoo-febb66dcd6c29d2ca72da37e5f5a82ec52480639.tar.bz2
gentoo-febb66dcd6c29d2ca72da37e5f5a82ec52480639.zip
app-admin/authbind: fix build, *FLAGS patch
Closes: https://bugs.gentoo.org/777834 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-admin/authbind')
-rw-r--r--app-admin/authbind/authbind-2.1.2.ebuild3
-rw-r--r--app-admin/authbind/files/authbind-2.1.2-respect-flags.patch26
2 files changed, 28 insertions, 1 deletions
diff --git a/app-admin/authbind/authbind-2.1.2.ebuild b/app-admin/authbind/authbind-2.1.2.ebuild
index 5c54176d277c..d9479c70b7b0 100644
--- a/app-admin/authbind/authbind-2.1.2.ebuild
+++ b/app-admin/authbind/authbind-2.1.2.ebuild
@@ -8,6 +8,7 @@ inherit flag-o-matic toolchain-funcs
DESCRIPTION="Bind sockets to privileged ports without root"
HOMEPAGE="https://www.chiark.greenend.org.uk/ucgi/~ian/git/authbind.git/"
SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}.tar.gz"
+S="${WORKDIR}/${PN}"
LICENSE="GPL-2+"
SLOT="0"
@@ -16,7 +17,7 @@ KEYWORDS="~amd64"
BDEPEND="virtual/awk"
PATCHES=(
- "${FILESDIR}/${PN}-2.1.1-respect-flags.patch"
+ "${FILESDIR}/${PN}-2.1.2-respect-flags.patch"
)
src_configure() {
diff --git a/app-admin/authbind/files/authbind-2.1.2-respect-flags.patch b/app-admin/authbind/files/authbind-2.1.2-respect-flags.patch
new file mode 100644
index 000000000000..877c50bd1e9f
--- /dev/null
+++ b/app-admin/authbind/files/authbind-2.1.2-respect-flags.patch
@@ -0,0 +1,26 @@
+diff --git a/Makefile b/Makefile
+index 37a8673..89f83f4 100644
+--- a/Makefile
++++ b/Makefile
+@@ -34,10 +34,9 @@ INSTALL_PROGRAM ?= install -o root -g root -m 755 -s
+ INSTALL_DIR ?= install -o root -g root -m 755 -d
+ STRIP ?= strip
+
+-OPTIMISE= -O2
+-LDFLAGS= -g
+ LIBS= -ldl -lc
+-CFLAGS= -g $(OPTIMISE) \
++SHARED_LDFLAGS=
++CFLAGSS+= \
+ -Wall -Wwrite-strings -Wpointer-arith -Wimplicit \
+ -Wnested-externs -Wmissing-prototypes -Wstrict-prototypes
+ CPPFLAGS= -DMAJOR_VER='"$(MAJOR)"' -DMINOR_VER='"$(MINOR)"' \
+@@ -82,7 +81,7 @@ helper: helper.o
+ helper.o authbind.o: authbind.h
+
+ $(LIBTARGET): libauthbind.o
+- $(LD) -shared -soname $(LIBCANON) -o $@ $< $(LIBS)
++ $(LD) $(SHARED_LDFLAGS) -shared -soname $(LIBCANON) -o $@ $< $(LIBS)
+
+ clean distclean:
+ rm -f $(TARGETS) *.o *~ ./#*# *.bak *.new core