summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2023-07-31 17:46:10 +1000
committerMichael Palimaka <kensington@gentoo.org>2023-07-31 17:46:28 +1000
commit84935a3c8756ce6ebd557e7f063eec879077d696 (patch)
tree1347d733ade4b5c62216d0d5029532b7a85ab7ec /app-admin/bitwarden-desktop-bin
parentdev-util/howdoi: add python 3.11 support (diff)
downloadgentoo-84935a3c8756ce6ebd557e7f063eec879077d696.tar.gz
gentoo-84935a3c8756ce6ebd557e7f063eec879077d696.tar.bz2
gentoo-84935a3c8756ce6ebd557e7f063eec879077d696.zip
app-admin/bitwarden-desktop-bin: add 2023.7.1
Closes: https://bugs.gentoo.org/910182 Closes: https://github.com/gentoo/gentoo/pull/31686 Signed-off-by: Michael Palimaka <kensington@gentoo.org>
Diffstat (limited to 'app-admin/bitwarden-desktop-bin')
-rw-r--r--app-admin/bitwarden-desktop-bin/Manifest1
-rw-r--r--app-admin/bitwarden-desktop-bin/bitwarden-desktop-bin-2023.7.1.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/app-admin/bitwarden-desktop-bin/Manifest b/app-admin/bitwarden-desktop-bin/Manifest
index 449d3832d470..2f3e88d8583f 100644
--- a/app-admin/bitwarden-desktop-bin/Manifest
+++ b/app-admin/bitwarden-desktop-bin/Manifest
@@ -1,2 +1,3 @@
DIST Bitwarden-2022.12.0-amd64.deb 65434808 BLAKE2B 81e7f1b0d7a95fa08554fced72440d65c4fb5fb86371f4ce773904f53543a3586f56eb53d2a4f79034a475430d3b2926404a2bc178e49bb97999295100a6a352 SHA512 ca1fafe48b3dcbab8c2152ed84337c7ebd8cc1934f24d2eabf7ef65733c163e84fc9e49f8566cf2201ab557144e81360db8d8ee1883a92c275804d7c3ddf886b
DIST Bitwarden-2023.2.0-amd64.deb 70836086 BLAKE2B 84c9bfd58a0b5e1647f8bf6af8e9c0070bb940896161c58bbcf43af03109e6623d741dfe303af84fd2ed98e8c16f95ef9eaa3936b6c39c851d4960ba29d4554e SHA512 19cc12e85c2b4fdff2c52747fcea9cd888040c2d20faa0eaf81237d4ccbe4a0c4ed0df792c6c193768e33329561759357dc333fd05018a00e82bc71a4e8082e8
+DIST Bitwarden-2023.7.1-amd64.deb 74029276 BLAKE2B 1bf8dcd652271fe4ae794b9b86686de7af1edbb23279fe8ecb49dc409c62dffdf0c34bc9b49792e0a2fcf6dc887fae7c615fa30bbebba458a1cbf3d457b4eb75 SHA512 48a8301cf9824458fff39081b41bc7da208c877966eca4a00f51dd4fba6d0370370fa0edaf557d892533fc43ee2d27277465cb1203a00551428aa5032c6bd2c1
diff --git a/app-admin/bitwarden-desktop-bin/bitwarden-desktop-bin-2023.7.1.ebuild b/app-admin/bitwarden-desktop-bin/bitwarden-desktop-bin-2023.7.1.ebuild
new file mode 100644
index 000000000000..1168ac9eeda7
--- /dev/null
+++ b/app-admin/bitwarden-desktop-bin/bitwarden-desktop-bin-2023.7.1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop unpacker xdg-utils
+
+MY_PN="Bitwarden"
+
+DESCRIPTION="Bitwarden password manager desktop client"
+HOMEPAGE="https://bitwarden.com/"
+SRC_URI="https://github.com/bitwarden/clients/releases/download/desktop-v${PV}/Bitwarden-${PV}-amd64.deb"
+S="${WORKDIR}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ || (
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ ( app-accessibility/at-spi2-atk dev-libs/atk )
+ )
+ app-crypt/libsecret
+ dev-libs/expat
+ dev-libs/glib
+ dev-libs/nspr
+ dev-libs/nss
+ dev-libs/wayland
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-print/cups
+ sys-apps/dbus
+ sys-apps/util-linux
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXScrnSaver
+ x11-libs/libxshmfence
+ x11-libs/libXtst
+ x11-libs/pango
+"
+IDEPEND="
+ dev-util/desktop-file-utils
+ dev-util/gtk-update-icon-cache
+"
+
+QA_PREBUILT="
+ opt/Bitwarden/*.so*
+ opt/Bitwarden/bitwarden
+ opt/Bitwarden/chrome-sandbox
+ opt/Bitwarden/chrome_crashpad_handler
+"
+
+src_install() {
+ insinto /opt
+ doins -r opt/${MY_PN}
+ fperms 755 /opt/Bitwarden/bitwarden
+ fperms 4755 /opt/Bitwarden/chrome-sandbox
+
+ domenu usr/share/applications/bitwarden.desktop
+
+ local x
+ for x in 16 32 64 128 256 512; do
+ doicon -s ${x} usr/share/icons/hicolor/${x}*/*
+ done
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}