summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/ec2-ami-tools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/ec2-ami-tools')
-rw-r--r--app-admin/ec2-ami-tools/Manifest1
-rw-r--r--app-admin/ec2-ami-tools/ec2-ami-tools-1.5.6.ebuild52
-rw-r--r--app-admin/ec2-ami-tools/metadata.xml10
3 files changed, 63 insertions, 0 deletions
diff --git a/app-admin/ec2-ami-tools/Manifest b/app-admin/ec2-ami-tools/Manifest
new file mode 100644
index 000000000000..e7ed5a1fb042
--- /dev/null
+++ b/app-admin/ec2-ami-tools/Manifest
@@ -0,0 +1 @@
+DIST ec2-ami-tools-1.5.6.zip 156541 SHA256 7aa6f2e581d52febf8850b3657a2f01c2f0180d91d33bdb1c246d485c1194708 SHA512 77ce82acbccf32bb1b900ef0b8c7440d4fc05e9b883081432935c6fef94b1f27191a0147e73c9eec680eca94c62075ab81bb8b0c33bec56bb2b861876de0129d WHIRLPOOL 1c7d20edde821e307eb8190413658e48d49a9c17d73b6c67a93b89f6b22512b1149c524d0a8111c5e6d36ca26465ae4a7f44cf4adf523318692dbef9213ce1ac
diff --git a/app-admin/ec2-ami-tools/ec2-ami-tools-1.5.6.ebuild b/app-admin/ec2-ami-tools/ec2-ami-tools-1.5.6.ebuild
new file mode 100644
index 000000000000..938f477fa980
--- /dev/null
+++ b/app-admin/ec2-ami-tools/ec2-ami-tools-1.5.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit versionator
+
+DESCRIPTION="These command-line tools serve as the client interface to the Amazon EC2 web service"
+HOMEPAGE="http://developer.amazonwebservices.com/connect/entry.jspa?externalID=368&categoryID=88"
+SRC_URI="http://s3.amazonaws.com/ec2-downloads/${P}.zip"
+
+LICENSE="Amazon
+ || ( Ruby GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+ruby_slot="2.0"
+
+DEPEND="app-arch/unzip"
+RDEPEND="dev-lang/ruby:${ruby_slot}[ssl]
+ net-misc/rsync
+ net-misc/curl"
+
+src_prepare() {
+ # Simplify the scripts to always run Ruby 20, since Gentoo supports
+ # alternative implementations as well it is not guaranteed that ruby is ruby19.
+ sed -i -e "\$s:^ruby:exec ruby${ruby_slot/./}:" bin/* || die 'Sed failed.'
+
+ # Remove a left behind license file.
+ rm lib/ec2/oem/LICENSE.txt || die 'Removal of LICENSE failed.'
+}
+
+src_install() {
+ dobin bin/*
+
+ insinto /usr
+ doins -r lib
+
+ insinto /etc/ec2/amitools
+ doins etc/ec2/amitools/*
+
+ dodir /etc/env.d
+ echo "EC2_AMITOOL_HOME=/usr" >> "${T}"/99${PN} || die "Can't write environment variable."
+ doenvd "${T}"/99${PN}
+}
+
+pkg_postinst() {
+ ewarn "Remember to run \`env-update && source /etc/profile\` if you plan"
+ ewarn "to use these tools in a shell before logging out (or restarting"
+ ewarn "your login manager)."
+}
diff --git a/app-admin/ec2-ami-tools/metadata.xml b/app-admin/ec2-ami-tools/metadata.xml
new file mode 100644
index 000000000000..daccbacc9d37
--- /dev/null
+++ b/app-admin/ec2-ami-tools/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ These command-line tools serve as the client interface to the Amazon EC2 web service.
+ </longdescription>
+</pkgmetadata>