summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-04-25 11:16:28 +0200
committerDavid Seifert <soap@gentoo.org>2021-04-25 11:16:28 +0200
commit818e65e80a907e9de7bb10ae90fbc25abd200579 (patch)
tree2f166a4d6d809de4ad5fa82bccb636baa148d411 /app-admin/metalog
parentapp-arch/unrar: Reformat metadata.xml (diff)
downloadgentoo-818e65e80a907e9de7bb10ae90fbc25abd200579.tar.gz
gentoo-818e65e80a907e9de7bb10ae90fbc25abd200579.tar.bz2
gentoo-818e65e80a907e9de7bb10ae90fbc25abd200579.zip
app-admin/metalog: Remove old 3-r2, 20181125
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-admin/metalog')
-rw-r--r--app-admin/metalog/Manifest2
-rw-r--r--app-admin/metalog/files/consolelog.sh20
-rw-r--r--app-admin/metalog/files/metalog.initd41
-rw-r--r--app-admin/metalog/metalog-20181125.ebuild65
-rw-r--r--app-admin/metalog/metalog-3-r2.ebuild56
5 files changed, 0 insertions, 184 deletions
diff --git a/app-admin/metalog/Manifest b/app-admin/metalog/Manifest
index ba655692076b..d99dd76fd94a 100644
--- a/app-admin/metalog/Manifest
+++ b/app-admin/metalog/Manifest
@@ -1,3 +1 @@
-DIST metalog-20181125.tar.gz 39472 BLAKE2B 64d90835d50c7cb10ab2bf2708d00189b9f8cb56438c29d5c445c5527cce030f918ba74f83cdcd54017f04fe2a8ab30e5631bcdf6681e56c311f8069981a9b5c SHA512 4b187a29b9e25a0f762f929c6993fa6e49ead470916a43a0dfbf16720a1a633121357d2f152bf4cdcd71c016aa4fc8fd6cffb35249abd430fbbf66651986bc4b
DIST metalog-20200113.tar.gz 40276 BLAKE2B f2fcaccf610f3b7f1974aa97f2c7b5181f3c625c9e28d72832ba1570cfa369873887c83468bcea6a9f3d3080356bd1dd62849ec34a5d03c1272ada7f476946f6 SHA512 d399d86f988c69c9f74553cd682a5fe04886bca458e6f8bb3132fe1fb9f522510a428cfde8af0857c5ba22531b276b04fa05183e0006c2d28ef0f0aead488f93
-DIST metalog-3.tar.xz 360784 BLAKE2B 951841d423769cd97e14985e15d5a2499ca351e082c0effe28dc16d46db91235b7ef0448fe32d38b2ed5b53011d04b3375dc87c2a859c49bede2ae177ec16954 SHA512 2ac614bb85fe466308c4ced0842fdab5f056eda60e892189a8220719f1e06a72fce3c76842a2ac8c63a6808c20d8b7a7d8676896e14f7f54e40630ecbd21e289
diff --git a/app-admin/metalog/files/consolelog.sh b/app-admin/metalog/files/consolelog.sh
deleted file mode 100644
index 90fb38e9921a..000000000000
--- a/app-admin/metalog/files/consolelog.sh
+++ /dev/null
@@ -1,20 +0,0 @@
-#!/bin/sh
-# consolelog.sh
-# For metalog -- log to a console
-
-set -f
-
-. /etc/conf.d/metalog
-if [ -z "${CONSOLE}" ] ; then
- CONSOLE="/dev/console"
-fi
-
-if [ -z "${FORMAT}" ] ; then
- FORMAT='$1 [$2] $3'
-fi
-
-for d in ${CONSOLE} ; do
- eval echo ${FORMAT} > ${d}
-done
-
-exit 0
diff --git a/app-admin/metalog/files/metalog.initd b/app-admin/metalog/files/metalog.initd
deleted file mode 100644
index f81e9eec51ca..000000000000
--- a/app-admin/metalog/files/metalog.initd
+++ /dev/null
@@ -1,41 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-extra_started_commands="buffer unbuffer"
-
-PIDFILE=/var/run/metalog.pid
-
-depend() {
- need localmount
- use clock hostname
- after bootmisc
- provide logger
-}
-
-ssd() { start-stop-daemon --exec /usr/sbin/metalog --pidfile "${PIDFILE}" "$@" ; }
-
-start() {
- ebegin "Starting metalog"
- ssd --start -- \
- --daemonize --pidfile="${PIDFILE}" ${METALOG_OPTS}
- eend $?
-}
-
-stop() {
- ebegin "Stopping metalog"
- ssd --stop
- eend $?
-}
-
-buffer() {
- ebegin "Enabling log buffering"
- ssd --signal USR2
- eend $?
-}
-
-unbuffer() {
- ebegin "Disabling log buffering"
- ssd --signal USR1
- eend $?
-}
diff --git a/app-admin/metalog/metalog-20181125.ebuild b/app-admin/metalog/metalog-20181125.ebuild
deleted file mode 100644
index e06a89c5be0d..000000000000
--- a/app-admin/metalog/metalog-20181125.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit autotools systemd
-
-DESCRIPTION="A highly configurable replacement for syslogd/klogd"
-HOMEPAGE="https://github.com/hvisage/metalog"
-SRC_URI="https://github.com/hvisage/${PN}/archive/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin"
-IUSE="unicode"
-
-RDEPEND=">=dev-libs/libpcre-3.4"
-DEPEND="${RDEPEND}
- sys-devel/autoconf-archive
- virtual/pkgconfig"
-
-S="${WORKDIR}/${PN}-${P}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.9-metalog-conf.patch
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- econf $(use_with unicode)
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS ChangeLog README NEWS metalog.conf
-
- into /
- dosbin "${FILESDIR}"/consolelog.sh
-
- newinitd "${FILESDIR}"/metalog.initd-r1 metalog
- newconfd "${FILESDIR}"/metalog.confd metalog
- systemd_newunit "${FILESDIR}/${PN}.service-r1" "${PN}.service"
-}
-
-pkg_preinst() {
- if [[ -d "${ROOT}"/etc/metalog ]] && [[ ! -e "${ROOT}"/etc/metalog.conf ]] ; then
- mv -f "${ROOT}"/etc/metalog/metalog.conf "${ROOT}"/etc/metalog.conf
- rmdir "${ROOT}"/etc/metalog
- export MOVED_METALOG_CONF=true
- else
- export MOVED_METALOG_CONF=false
- fi
-}
-
-pkg_postinst() {
- if ${MOVED_METALOG_CONF} ; then
- ewarn "The default metalog.conf file has been moved"
- ewarn "from /etc/metalog/metalog.conf to just"
- ewarn "/etc/metalog.conf. If you had a standard"
- ewarn "setup, the file has been moved for you."
- fi
-}
diff --git a/app-admin/metalog/metalog-3-r2.ebuild b/app-admin/metalog/metalog-3-r2.ebuild
deleted file mode 100644
index 9e8bf5948a52..000000000000
--- a/app-admin/metalog/metalog-3-r2.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-inherit systemd
-
-DESCRIPTION="A highly configurable replacement for syslogd/klogd"
-HOMEPAGE="http://metalog.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86"
-IUSE="unicode"
-
-RDEPEND=">=dev-libs/libpcre-3.4"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- app-arch/xz-utils"
-
-PATCHES=( "${FILESDIR}"/${PN}-0.9-metalog-conf.patch )
-
-src_configure() {
- econf $(use_with unicode)
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS ChangeLog README NEWS metalog.conf
-
- into /
- dosbin "${FILESDIR}"/consolelog.sh
-
- newinitd "${FILESDIR}"/metalog.initd metalog
- newconfd "${FILESDIR}"/metalog.confd metalog
- systemd_newunit "${FILESDIR}/${PN}.service-r1" "${PN}.service"
-}
-
-pkg_preinst() {
- if [[ -d "${ROOT}"/etc/metalog ]] && [[ ! -e "${ROOT}"/etc/metalog.conf ]] ; then
- mv -f "${ROOT}"/etc/metalog/metalog.conf "${ROOT}"/etc/metalog.conf
- rmdir "${ROOT}"/etc/metalog
- export MOVED_METALOG_CONF=true
- else
- export MOVED_METALOG_CONF=false
- fi
-}
-
-pkg_postinst() {
- if ${MOVED_METALOG_CONF} ; then
- ewarn "The default metalog.conf file has been moved"
- ewarn "from /etc/metalog/metalog.conf to just"
- ewarn "/etc/metalog.conf. If you had a standard"
- ewarn "setup, the file has been moved for you."
- fi
-}