summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2020-11-09 13:44:00 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2020-11-09 15:11:42 +0100
commit49f2eff9ca5d67ecdfe1e6646ebe1aa789ea0201 (patch)
treed0db040fc5943747082f700a2a2995f529f521c6 /app-admin/mongo-tools
parentdev-db/mongodb: bump to 4.0.20/4.2.10 (diff)
downloadgentoo-49f2eff9ca5d67ecdfe1e6646ebe1aa789ea0201.tar.gz
gentoo-49f2eff9ca5d67ecdfe1e6646ebe1aa789ea0201.tar.bz2
gentoo-49f2eff9ca5d67ecdfe1e6646ebe1aa789ea0201.zip
app-admin/mongo-tools: bump to 100.2.0
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Alexys Jacob <ultrabug@gentoo.org>
Diffstat (limited to 'app-admin/mongo-tools')
-rw-r--r--app-admin/mongo-tools/Manifest1
-rw-r--r--app-admin/mongo-tools/mongo-tools-100.2.0.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-admin/mongo-tools/Manifest b/app-admin/mongo-tools/Manifest
index b74867df2d2d..748af4fd1f0b 100644
--- a/app-admin/mongo-tools/Manifest
+++ b/app-admin/mongo-tools/Manifest
@@ -1,3 +1,4 @@
+DIST mongo-tools-100.2.0.tar.gz 27401773 BLAKE2B 359747ffe9e53e9ac62fa70517bd5e64c6b082076b9d54e325200cabbd9e3f7ab3aa9f96f7a84c60b044082e505e2ca4d6bdeac6f0b1ca0bfaa03583603a7962 SHA512 1b093482d3abfbd354ff6010f270836a13842fc6ff33126effb4e843beefeabc233bb610b423cac8ce8718366e7aa7411679e4cd5125d44a235f244f5ea49da5
DIST mongo-tools-3.6.13.tar.gz 4990848 BLAKE2B 022ddf214869c3a3e545aa9572f77f0adc21c0dbd6ea6ad9e083633c2e972b7ef77c0bda4354dbde9fd0e23c6dd02a7de8873d4b2c2a3e4423ea6f8e1c23ed52 SHA512 fac21c4841bfecba11a7765bb6c36d1fa19d4dd94f6f4168fa767fc11dc8b3caf04a5029becd09eba01dd694274e9cc22da8566ce878769e5c3c97016c162432
DIST mongo-tools-3.6.17.tar.gz 4991196 BLAKE2B 53e86b3513aa74ad174801cea987d574c5248f438cb0a9419c2352c04333eae2f92214b11c59ee8688ad7235dc7a4586c39cc27450c654b1fc0e2eec2e4e22e2 SHA512 ea7a010097fdfe7807daf9352519b808b4a7b614b793ee2ac27495207bcf1cf8b4151fecd525946a0d6b8aa9332c205f437d5141b16efb613810963f502061be
DIST mongo-tools-4.0.12.tar.gz 11134652 BLAKE2B d3c9703046dc577b85cefe1185678e0029411ddd44d0648f9b09fc3ab41e3661891d18afd83bf1a148dc4c9208895f444c115948e515e09dfa3062e89d98fc24 SHA512 068d8c456386caddcce23fa8917ffecdc9b5c39fb6794c5cd1d9099be1f127ecf680b006055581dc3d90507072a87788b46be7410f0dbede42da64c664b77ced
diff --git a/app-admin/mongo-tools/mongo-tools-100.2.0.ebuild b/app-admin/mongo-tools/mongo-tools-100.2.0.ebuild
new file mode 100644
index 000000000000..a60bc8a3e1af
--- /dev/null
+++ b/app-admin/mongo-tools/mongo-tools-100.2.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A high-performance, open source, schema-free document-oriented database"
+HOMEPAGE="https://www.mongodb.com"
+SRC_URI="https://github.com/mongodb/mongo-tools/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="sasl ssl"
+
+DEPEND="dev-lang/go:=
+ net-libs/libpcap
+ sasl? ( dev-libs/cyrus-sasl )
+ ssl? ( dev-libs/openssl:0= )"
+
+# Do not complain about CFLAGS etc since go projects do not use them.
+QA_FLAGS_IGNORED='.*'
+
+EGO_PN="github.com/mongodb/mongo-tools"
+S="${WORKDIR}/src/${EGO_PN}"
+
+src_unpack() {
+ mkdir -p "${S%/*}" || die
+ default
+ mv ${P} "${S}" || die
+}
+
+src_compile() {
+ local myconf=()
+
+ if use sasl; then
+ myconf+=(sasl)
+ fi
+
+ if use ssl; then
+ myconf+=(ssl)
+ fi
+
+ # build pie to avoid text relocations wrt #582854
+ local buildmode="pie"
+
+ # skip on ppc64 wrt #610984
+ if use ppc64; then
+ buildmode="default"
+ fi
+
+ mkdir -p bin || die
+ for i in bsondump mongostat mongofiles mongoexport mongoimport mongorestore mongodump mongotop; do
+ echo "Building $i"
+ GOROOT="$(go env GOROOT)" GOPATH="${WORKDIR}" go build -buildmode="${buildmode}" -o "bin/$i" \
+ -ldflags "-X ${EGO_PN}/common/options.VersionStr=${PV}" --tags "${myconf[*]}" "$i/main/$i.go" || die
+ done
+}
+
+src_install() {
+ dobin bin/*
+}