summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2018-11-26 05:43:38 +0100
committerMatt Turner <mattst88@gentoo.org>2018-12-07 12:28:12 -0800
commita5ec7ab750b7f7a9c229c027f070c5783d28f795 (patch)
treedbee3d6c3ae3523e6a2b9a9200b27893524a7fb1 /app-admin/pass-otp/pass-otp-1.2.0.ebuild
parentapp-admin/pass-otp: Update copyright format (diff)
downloadgentoo-a5ec7ab750b7f7a9c229c027f070c5783d28f795.tar.gz
gentoo-a5ec7ab750b7f7a9c229c027f070c5783d28f795.tar.bz2
gentoo-a5ec7ab750b7f7a9c229c027f070c5783d28f795.zip
app-admin/pass-otp: Bump to 1.2.0
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-admin/pass-otp/pass-otp-1.2.0.ebuild')
-rw-r--r--app-admin/pass-otp/pass-otp-1.2.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-admin/pass-otp/pass-otp-1.2.0.ebuild b/app-admin/pass-otp/pass-otp-1.2.0.ebuild
new file mode 100644
index 000000000000..b93a38c51e23
--- /dev/null
+++ b/app-admin/pass-otp/pass-otp-1.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1
+
+DESCRIPTION="A pass extension for managing one-time-password (OTP) tokens."
+HOMEPAGE="https://github.com/tadfisher/pass-otp"
+SRC_URI="https://github.com/tadfisher/pass-otp/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="qrcode test"
+
+DEPEND="test? ( dev-tcltk/expect:* )"
+
+RDEPEND=">=app-admin/pass-1.7
+ sys-auth/oath-toolkit
+ qrcode? ( media-gfx/qrencode )"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ emake install DESTDIR="${D}" BASHCOMPDIR="$(get_bashcompdir)"
+}